Bildschirm wird nicht gefunden

classic Classic list List threaded Threaded
38 messages Options
12
Reply | Threaded
Open this post in threaded view
|

Bildschirm wird nicht gefunden

Klaus Becker-2
Moin,

unter unstable habe ich seit gestern keinen Graphikmodus mehr."startx" sagt, es werde kein Bildschirm gefunden.

Das ist mir schon mehr als einmal passiert, und es genügte jedesmal, den entsprechenden Graphiktreiber wieder zu installieren, der irgendwie abhanden gekommen war. Ich habe eine Nvidia Gforce 2010, und "nouveau" ist installiert.

Ich habe keine xorg.conf, /etc/X11/xorg.conf.d/ ist leer.

Was kann ich da machen?

Gruß

Klaus
Reply | Threaded
Open this post in threaded view
|

Re: Bildschirm wird nicht gefunden

Hilmar Preuße
Am 20.05.2020 um 11:02 teilte Klaus Becker mit:

Moin,

> Ich habe keine xorg.conf, /etc/X11/xorg.conf.d/ ist leer.
>
> Was kann ich da machen?
>
Logs lesen:

/home/<user>/.local/share/xorg

H.
--
sigfault
#206401 http://counter.li.org


signature.asc (849 bytes) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: Bildschirm wird nicht gefunden

Klaus Becker-2
/home/<user>/.local/share/xorg gibt es bei mir nicht

Klaus

On Wed, May 20, 2020 at 11:09 AM Hilmar Preuße <[hidden email]> wrote:
Am 20.05.2020 um 11:02 teilte Klaus Becker mit:

Moin,

> Ich habe keine xorg.conf, /etc/X11/xorg.conf.d/ ist leer.
>
> Was kann ich da machen?
>
Logs lesen:

/home/<user>/.local/share/xorg

H.
--
sigfault
#206401 http://counter.li.org

Reply | Threaded
Open this post in threaded view
|

Re: Bildschirm wird nicht gefunden

Michael Schumacher


On 5/20/20 11:33 AM, Klaus Becker wrote:

> /home/<user>/.local/share/xorg gibt es bei mir nicht

Nur zur Sicherheit: du hast statt <user> deinen Benutzernamen eingesetzt?


--
Regards,
Michael
GPG: 96A8 B38A 728A 577D 724D 60E5 F855 53EC B36D 4CDD

Reply | Threaded
Open this post in threaded view
|

Re: Bildschirm wird nicht gefunden

Robert Stephan
Hier, Debian Bullseye/Sid, findet sich unter ~/.local/share auch nix mit x

Am Mittwoch, 20. Mai 2020, 12:19:36 CEST schrieb Michael Schumacher:

> On 5/20/20 11:33 AM, Klaus Becker wrote:
> > /home/<user>/.local/share/xorg gibt es bei mir nicht
>
> Nur zur Sicherheit: du hast statt <user> deinen Benutzernamen eingesetzt?
>
>
> --
> Regards,
> Michael
> GPG: 96A8 B38A 728A 577D 724D 60E5 F855 53EC B36D 4CDD


signature.asc (499 bytes) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: Bildschirm wird nicht gefunden

Christian Knoke
In reply to this post by Michael Schumacher
Du schriebst am 20. Mai um 12:19 Uhr:
>
>
> On 5/20/20 11:33 AM, Klaus Becker wrote:
>
> > /home/<user>/.local/share/xorg gibt es bei mir nicht
>
> Nur zur Sicherheit: du hast statt <user> deinen Benutzernamen eingesetzt?

bei mir gibt es die auch nicht. Bei mir gibts nur
 .xsession-errors und .xfce4-session.verbose-log
und natürlich /var/log/Xorg.0.log .

Gruß

--
http://cknoke.de

Reply | Threaded
Open this post in threaded view
|

Re: Bildschirm wird nicht gefunden

Elimar Riesebieter
In reply to this post by Hilmar Preuße
* Hilmar Preuße <[hidden email]> [2020-05-20 11:08 +0200]:

> Am 20.05.2020 um 11:02 teilte Klaus Becker mit:
>
> Moin,
>
> > Ich habe keine xorg.conf, /etc/X11/xorg.conf.d/ ist leer.
> >
> > Was kann ich da machen?
> >
> Logs lesen:
>
> /home/<user>/.local/share/xorg

Der X-server logt hier:

/var/log/Xorg.0.log

Fehler lassen sich via:

# egrep "\(EE\)" /var/log/Xorg.0.log

finden.

Elimar
--
  We all know Linux is great... it does infinite loops in 5 seconds.
        -Linus Torvalds

Reply | Threaded
Open this post in threaded view
|

Re: Bildschirm wird nicht gefunden

Dirk Paul Finkeldey
In reply to this post by Klaus Becker-2
Am 20.05.20 um 11:02 schrieb Klaus Becker:
Moin,

~

Was kann ich da machen?

Gruß

Klaus


Systemweit sollten die Konfigurationen hier liegen :

/usr/share/X11/xorg.conf.d/

Gruß

Dirk


smime.p7s (5K) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: Bildschirm wird nicht gefunden

Elimar Riesebieter
* Dirk Paul Finkeldey <[hidden email]> [2020-05-20 13:21 +0200]:

> Am 20.05.20 um 11:02 schrieb Klaus Becker:
> > Moin,
> >
> > ~
> >
> > Was kann ich da machen?
> >
> > Gruß
> >
> > Klaus
>
>
> Systemweit sollten die Konfigurationen hier liegen :
>
> > /usr/share/X11/xorg.conf.d/

Und daran sollte man nicht 'rumschrauben!
Elimar
--
  Excellent day for drinking heavily.
  Spike the office water cooler;-)

Reply | Threaded
Open this post in threaded view
|

Re: Bildschirm wird nicht gefunden

Jochen Van Geldern
Am Wed, 20 May 2020 13:33:14 +0200
schrieb Elimar Riesebieter <[hidden email]>:

> * Dirk Paul Finkeldey <[hidden email]> [2020-05-20 13:21
> +0200]:
>
> > Am 20.05.20 um 11:02 schrieb Klaus Becker:  
> > > Moin,
> > >
> > > ~
> > >
> > > Was kann ich da machen?
> > >
> > > Gruß
> > >
> > > Klaus  
> >
> >
> > Systemweit sollten die Konfigurationen hier liegen :
> >  
> > > /usr/share/X11/xorg.conf.d/  
>
> Und daran sollte man nicht 'rumschrauben!
Weil die eventuell beim nächsten Update überschieben werden können.
> Elimar

Reply | Threaded
Open this post in threaded view
|

Re: Bildschirm wird nicht gefunden

Klaus Becker-2
In /usr/share/X11/xorg.conf.d/ befinden sich:
10-quirks.conf, 40-libinput.conf, .70-wacom.conf.

Müsste da nicht 'ne Datei für nouveau drin sein? Auf dem Lappi, den ich im Moment benutze, ist eine Ati-Karte, und in obigem Ordner befindet sich eine Datei für Ati.

egrep "\(EE\)" /var/log/Xorg.0.log sagt:

[   704.099] (EE) Failed to load module "nv" (module does not exist, 0)
[   704.100] (EE) Failed to load module "fbdev" (module does not exist, 0)
[   704.100] (EE) Failed to load module "vesa" (module does not exist, 0)
[   704.101] (EE) [drm] Failed to open DRM device for (null): -22
[   704.101] (EE) [drm] Failed to open DRM device for pci:0000:01:00.0: -22
[   704.101] (EE) [drm] Failed to open DRM device for (null): -22
[   704.101] (EE) Screen 0 deleted because of no matching config section.
[   704.101] (EE) Device(s) detected, but none match those in the config file.
[   704.101] (EE) no screens found(EE)
[   704.103] (EE) Server terminated with error (1). Closing log file.

Klaus

On Wed, May 20, 2020 at 2:46 PM Jochen van Geldern <[hidden email]> wrote:
Am Wed, 20 May 2020 13:33:14 +0200
schrieb Elimar Riesebieter <[hidden email]>:

> * Dirk Paul Finkeldey <[hidden email]> [2020-05-20 13:21
> +0200]:
>
> > Am 20.05.20 um 11:02 schrieb Klaus Becker: 
> > > Moin,
> > >
> > > ~
> > >
> > > Was kann ich da machen?
> > >
> > > Gruß
> > >
> > > Klaus 
> >
> >
> > Systemweit sollten die Konfigurationen hier liegen :
> >   
> > > /usr/share/X11/xorg.conf.d/ 
>
> Und daran sollte man nicht 'rumschrauben!
Weil die eventuell beim nächsten Update überschieben werden können.
> Elimar

Reply | Threaded
Open this post in threaded view
|

Re: Bildschirm wird nicht gefunden

Elimar Riesebieter
* Klaus Becker <[hidden email]> [2020-05-20 21:03 +0200]:

> In /usr/share/X11/xorg.conf.d/ befinden sich: 10-quirks.conf,
> 40-libinput.conf, .70-wacom.conf.
>
> Müsste da nicht 'ne Datei für nouveau drin sein?

Nein.

> Auf dem Lappi, den ich im Moment benutze, ist eine Ati-Karte, und
> in obigem Ordner befindet sich eine Datei für Ati.

> egrep "\(EE\)" /var/log/Xorg.0.log sagt:
>
> [   704.099] (EE) Failed to load module "nv" (module does not exist, 0)
> [   704.100] (EE) Failed to load module "fbdev" (module does not exist, 0)
> [   704.100] (EE) Failed to load module "vesa" (module does not exist, 0)
> [   704.101] (EE) [drm] Failed to open DRM device for (null): -22
> [   704.101] (EE) [drm] Failed to open DRM device for pci:0000:01:00.0: -22
> [   704.101] (EE) [drm] Failed to open DRM device for (null): -22
> [   704.101] (EE) Screen 0 deleted because of no matching config section.
> [   704.101] (EE) Device(s) detected, but none match those in the config
> file.
> [   704.101] (EE) no screens found(EE)
> [   704.103] (EE) Server terminated with error (1). Closing log file.

Was sagt

# dpkg -l | egrep "(drm|nouveau)"

?
Elimar
--
  Alles, was viel bedacht wird, wird bedenklich!;-)
         Friedrich Nietzsche

Reply | Threaded
Open this post in threaded view
|

Re: Bildschirm wird nicht gefunden

Klaus Becker-2

ii libdrm-amdgpu1:amd64 2.4.101-2 amd64 Userspace interface to amdgpu-specific kernel DRM services -- runtime

ii libdrm-common 2.4.101-2 all Userspace interface to kernel DRM services -- common files

ii libdrm-intel1:amd64 2.4.101-2 amd64 Userspace interface to intel-specific kernel DRM services -- runtime

ii libdrm-nouveau2:amd64 2.4.101-2 amd64 Userspace interface to nouveau-specific kernel DRM services -- runtime

ii libdrm-radeon1:amd64 2.4.101-2 amd64 Userspace interface to radeon-specific kernel DRM services -- runtime

ii libdrm2:amd64 2.4.101-2 amd64 Userspace interface to kernel DRM services -- runtime

ii libva-drm2:amd64 2.7.1-1 amd64 Video Acceleration (VA) API for Linux -- DRM runtime

ii xserver-xorg-video-nouveau 1:1.0.16-1 amd64 X.Org X server -- Nouveau display driver


Klaus

Reply | Threaded
Open this post in threaded view
|

Re: Bildschirm wird nicht gefunden

Elimar Riesebieter
* Klaus Becker <[hidden email]> [2020-05-20 21:48 +0200]:

> ii libdrm-amdgpu1:amd64 2.4.101-2 amd64 Userspace interface to
> amdgpu-specific kernel DRM services -- runtime
>
> ii libdrm-common 2.4.101-2 all Userspace interface to kernel DRM services
> -- common files
>
> ii libdrm-intel1:amd64 2.4.101-2 amd64 Userspace interface to
> intel-specific kernel DRM services -- runtime
>
> ii libdrm-nouveau2:amd64 2.4.101-2 amd64 Userspace interface to
> nouveau-specific kernel DRM services -- runtime
>
> ii libdrm-radeon1:amd64 2.4.101-2 amd64 Userspace interface to
> radeon-specific kernel DRM services -- runtime
>
> ii libdrm2:amd64 2.4.101-2 amd64 Userspace interface to kernel DRM services
> -- runtime
>
> ii libva-drm2:amd64 2.7.1-1 amd64 Video Acceleration (VA) API for Linux --
> DRM runtime
>
> ii xserver-xorg-video-nouveau 1:1.0.16-1 amd64 X.Org X server -- Nouveau
> display driver

Das sieht perfekt aus :) Ist denn das nouveau Modul geladen?

# lsmod  grep nouv

Elimar
--
  You cannot propel yourself forward by
  patting yourself on the back.

Reply | Threaded
Open this post in threaded view
|

Re: Bildschirm wird nicht gefunden

Klaus Becker-2
"lsmod  grep nouv" zeigt nichts an, "# modprobe nouveau" geht auch nicht; "Invalid argument".

Ich glaube, wir kommen der Sache langsam näher.

Klaus

On Wed, May 20, 2020 at 10:00 PM Elimar Riesebieter <[hidden email]> wrote:
* Klaus Becker <[hidden email]> [2020-05-20 21:48 +0200]:

> ii libdrm-amdgpu1:amd64 2.4.101-2 amd64 Userspace interface to
> amdgpu-specific kernel DRM services -- runtime
>
> ii libdrm-common 2.4.101-2 all Userspace interface to kernel DRM services
> -- common files
>
> ii libdrm-intel1:amd64 2.4.101-2 amd64 Userspace interface to
> intel-specific kernel DRM services -- runtime
>
> ii libdrm-nouveau2:amd64 2.4.101-2 amd64 Userspace interface to
> nouveau-specific kernel DRM services -- runtime
>
> ii libdrm-radeon1:amd64 2.4.101-2 amd64 Userspace interface to
> radeon-specific kernel DRM services -- runtime
>
> ii libdrm2:amd64 2.4.101-2 amd64 Userspace interface to kernel DRM services
> -- runtime
>
> ii libva-drm2:amd64 2.7.1-1 amd64 Video Acceleration (VA) API for Linux --
> DRM runtime
>
> ii xserver-xorg-video-nouveau 1:1.0.16-1 amd64 X.Org X server -- Nouveau
> display driver

Das sieht perfekt aus :) Ist denn das nouveau Modul geladen?

# lsmod  grep nouv

Elimar
--
  You cannot propel yourself forward by
  patting yourself on the back.

Reply | Threaded
Open this post in threaded view
|

Re: Bildschirm wird nicht gefunden

Elimar Riesebieter
* Klaus Becker <[hidden email]> [2020-05-20 22:12 +0200]:

> "lsmod  grep nouv" zeigt nichts an, "# modprobe nouveau" geht auch nicht;
> "Invalid argument".
>
> Ich glaube, wir kommen der Sache langsam näher.

Ist das Modul vorhanden?

# find /lib/modules/$(uname -r) -name '*nouveau*'

Elimar
--
  Do you smell something burning or is it me?

Reply | Threaded
Open this post in threaded view
|

Re: Bildschirm wird nicht gefunden

Klaus Becker-2
Ja:

/lib/modules/5.6.0-1-amd64/kernel/drivers/gpu/drm/nouveau
/lib/modules/5.6.0-1-amd64/kernel/drivers/gpu/drm/nouveau/nouveau.ko

Klaus

On Wed, May 20, 2020 at 10:46 PM Elimar Riesebieter <[hidden email]> wrote:
* Klaus Becker <[hidden email]> [2020-05-20 22:12 +0200]:

> "lsmod  grep nouv" zeigt nichts an, "# modprobe nouveau" geht auch nicht;
> "Invalid argument".
>
> Ich glaube, wir kommen der Sache langsam näher.

Ist das Modul vorhanden?

# find /lib/modules/$(uname -r) -name '*nouveau*'

Elimar
--
  Do you smell something burning or is it me?

Reply | Threaded
Open this post in threaded view
|

Re: Bildschirm wird nicht gefunden

Elimar Riesebieter
* Klaus Becker <[hidden email]> [2020-05-20 23:01 +0200]:

> Ja:
>
> /lib/modules/5.6.0-1-amd64/kernel/drivers/gpu/drm/nouveau
> /lib/modules/5.6.0-1-amd64/kernel/drivers/gpu/drm/nouveau/nouveau.ko

Dann sollte

# modprobe -v nouveau.ko

funtionieren?

Wenn nicht kontrolliere:

# dmesg | grep nouv


Elimar
--
  "Talking much about oneself can also
   be a means to conceal oneself."
         -Friedrich Nietzsche

Reply | Threaded
Open this post in threaded view
|

Re: Bildschirm wird nicht gefunden

Dirk Paul Finkeldey
In reply to this post by Klaus Becker-2
Am 20.05.20 um 21:03 schrieb Klaus Becker:
In /usr/share/X11/xorg.conf.d/ befinden sich:
10-quirks.conf, 40-libinput.conf, .70-wacom.conf.

Müsste da nicht 'ne Datei für nouveau drin sein? Auf dem Lappi, den ich im Moment benutze, ist eine Ati-Karte, und in obigem Ordner befindet sich eine Datei für Ati.

Nicht unbedingt.

Normalerweise werden beim Systemstart Grafikkarte und Monitor automatisch erkannt und konfiguriert.

Da sind in den meisten Fällen keine festen Konfigurationen für Xserver und Monitor mehr erforderlich.

Wenn man die Konfigurationen vor ungewollten Änderungen im Rahmen eines Upgrade schützen möchte, sollte man diese unter  /usr/local/X11 ablegen.


Das steht auch irgendwo in den Mann zu X11, weiß jetzt nur nicht so genau wo ich das mal gelesen habe.


Gruß

Dirk


smime.p7s (5K) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: Bildschirm wird nicht gefunden

Christian Knoke
In reply to this post by Klaus Becker-2
Klaus Becker schriebst am 20. Mai um 22:12 Uhr:
> "lsmod  grep nouv" zeigt nichts an, "# modprobe nouveau" geht auch nicht;
> "Invalid argument".

sieh' noch mal Elimars Post von 23:13 Uhr

> Ich glaube, wir kommen der Sache langsam näher.
>
> Klaus

--
http://cknoke.de

12