Bootproblem SSD

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

Bootproblem SSD

anthropos
Hallo Debian-Gemeinschaft,

Ich schreibe an die Liste mit Hoffnung auf Hilfe bei der Installation von Debian auf meinem Laptop.

Ich habe ein Problem mit einem Acer Aspire VN7-592G, in dass Ich nachträglich eine WD Gen3x4 NVMeSSD verbaut habe.
Die Installation mit USB-Stick der aktuellen version läuft ohne Probleme, allerdings funktioniert beim Neustart der Boot nicht.
[1] schreibt:
Acer hat anscheinend bei der EFI-Implementierung geschlampt. Es wird nur aus dem Ordner EFI/Microsoft/Boot gebootet. Das bedeutet, man muss seine EFI-Bootpartition mit Live-USB mounten und den im Ordner EFI/ubuntu vorhandenen Bootloader in dieses Verzeichnis (vorher anlegen) kopieren und die entsprechende Datei auch noch umbenennen. (bootmgfw.efi)

Ich habe mir also eine Live-Betriebssystem besorgt und auf der erstellten 30GB Partition der ganzen Systemordner den vormals leeren /boot/efi mit Microsoft/Boot/bootmgfw.efi gefüllt. Die Datei habe Ich aus boot/grub/x86_64-efi/grub.efi genommen.

Desweiteren wurde an anderer Stelle darauf hingewiesen, im UEFI-Menü vor der Installation Secure-Boot zu aktivieren, nach der Installation die grub*.efi Datei als vertraut eingestellt. Diese Datei wurde aber an der Stelle Platte/EFI/BOOT/ angezeigt und manuell von mir nicht gefunden.

[2] ist keine wirkliche Hilfestellung, da Ich die originale Festplatte weiterhin für einen Dual-Boot nutzen mchte und gerade abgeklemmt habe.

Als Anmerkung habe Ich bis vor einiger Zeit Ubuntu auf der SSD mit 'boot-repair' zum Laufen bekommen, keine logs oä. wie.
Jetzt will Ich zu Debian wechseln und das Bootproblem manuell lösen, komme aber nicht weiter.

Ich freue mich über jede Anregung und Hilfe & Eine schöne Bastelzeit

[1]
https://www.fizzgig.de/linux-mint-17-3-auf-acer-aspire-v-nitro-black-edition-vn7-592g-71jf/
[2]https://wiki.debian.org/InstallingDebianOn/Acer/Aspire_V15_Nitro_BE_VN7-592G-79DV
Reply | Threaded
Open this post in threaded view
|

Re: Bootproblem SSD

Richard Kraut-3
-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA512

Am Sonntag, den 19.04.2020, 18:52 +0000 schrieb [hidden email]:

> Ich habe ein Problem mit einem Acer Aspire VN7-592G, in dass Ich
> nachträglich eine WD Gen3x4 NVMeSSD verbaut habe.

Evtl. hilft Dir die folgende Seite weiter [1].
Hinweis: Das dort genannte Acer Aspire-Modell könnte von Deinem abweichen.

> Die Installation mit USB-Stick der aktuellen version läuft ohne Probleme,
> allerdings funktioniert beim Neustart der Boot nicht.
> [1] schreibt:
> Acer hat anscheinend bei der EFI-Implementierung geschlampt. Es wird nur aus
> dem Ordner EFI/Microsoft/Boot gebootet. Das bedeutet, man muss seine EFI-
> Bootpartition mit Live-USB mounten und den im Ordner EFI/ubuntu vorhandenen
> Bootloader in dieses Verzeichnis (vorher anlegen) kopieren und die
> entsprechende Datei auch noch umbenennen. (bootmgfw.efi)

Hast Du es auch schon mit einem BIOS-Update versucht? Vielleicht hat Acer ja
etwas nachgebessert.

> Ich habe mir also eine Live-Betriebssystem besorgt und auf der erstellten
> 30GB Partition der ganzen Systemordner den vormals leeren /boot/efi mit
> Microsoft/Boot/bootmgfw.efi gefüllt. Die Datei habe Ich aus
> boot/grub/x86_64-efi/grub.efi genommen.

/boot/efi/ ist bei einer Installation von Debian im UEFI-Modus nicht leer bzw.
darf nicht leer sein.

Unterhalb von /boot/efi gibt es einen weiteren Ordner "EFI" (Groß-
/Kleinschreibung beachten) und hier drin befindet sich der Unterordner
"debian". In diesem Verzeichnis befinden sich nötigen Dateien, um mit UEFI
starten zu können. Bspw. der UEFI-Grub, den Shim-Bootloader für das starten
des Systems mit aktiviertem Secure Boot, ...

Die korrekte Grub-Datei für den UEFI-Start, welche dann auch getriggert wird,
heißt "grubx64.efi". Und für selbige wird auch eine "grub.cfg" angelegt (alles
im Pfad /boot/efi/EFI/debian/).

Was noch ein wichtiger Punkt ist - die ESP-Partition _muss_ mit FAT32
formatiert sein und _muss_ nach /boot/efi gemountet werden.

> Desweiteren wurde an anderer Stelle darauf hingewiesen, im UEFI-Menü vor der
> Installation Secure-Boot zu aktivieren, nach der Installation die grub*.efi
> Datei als vertraut eingestellt. Diese Datei wurde aber an der Stelle
> Platte/EFI/BOOT/ angezeigt und manuell von mir nicht gefunden.

Meist ist es umgekehrt. SecureBoot deaktivieren.
Auch würde ich den BIOS Kompatibilitätsmodus (CSM) deaktivieren. Dann muss
sich das System im UEFI-Modus installieren und kann nicht still und heimlich
in den BIOS-Modus wechseln.

1: "
https://wiki.debian.org/InstallingDebianOn/Acer/Aspire_V15_Nitro_BE_VN7-592G-79DV
"

- --

MfG Richi

-----BEGIN PGP SIGNATURE-----

iQIzBAEBCgAdFiEERqPC1cUAShrzNBXW+NRy+KEKcZgFAl6d8IAACgkQ+NRy+KEK
cZhO5A//a8m07o+UXiQfcpFDwemgMKmNuWQ8Qti175+ApykzelLq6FTqW8V4802p
ZU9aHxoTu7ICYrWmXcs7Q3wf+T2iS2lcoWhHXaudYo5nO0E/HPjKKXJoJY/Gxp/M
2jVrIXwevzUVb9HC7DVa3UYABrTrWalk1mmks6KS/I7/IHSNETCknqhRmvvsG/pk
eEuJGQTDCJJ0EwbFFAQHpUU1VWKNU2PIySAJ/6hU32dsyAs/GqfeuCu3CHJHpW4m
PPaK0A5sX7S+eReKPBYU+2WOnA5WxyXUtZs7ZyG2hHsAZ6+jtDyrf8WAwMsdJKsP
DWyoLDAm0cyTUEspvKCVZswThgm66Lbap1lo1Lv80Xx0sfO1G1aAUBDDgwVy9R8Q
U/nWbloeen7phKKHOoJmwJm4tLG+SNY1tndnNOAHpf/ayITrIdCrkgxIE/7c4yh4
QDvWNPmQN94q0PN3VCmNaOwsd0N11Rt7YpeZ2tFLh5Ba70xlr8WEDso57XTi6qN7
aLQzdDz3BRbR69cut/Kwdcg198K/L4GAoJQQMeSTgt/SZheVqm1iXZTz5sPy/6sA
PyOfxyubrrxY/DOIGxoqjMl8yS0/gqai+qXzYUixCjDYCsWsmwMZwY+lehbGdHMc
tP5osJW9Z3zpl9Ly+KZA/OHPyom3bSU53pM4x8E2O3yiARTIRKA=
=XiHK
-----END PGP SIGNATURE-----