Bug#269451: marked as done (hotplug: pciehp / shpchp can't be loaded)

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

Bug#269451: marked as done (hotplug: pciehp / shpchp can't be loaded)

Debian Bug Tracking System
Your message dated Sun, 8 Jan 2006 23:53:13 +0100
with message-id <[hidden email]>
and subject line Fwd: Re: Bug#268583: hotplug failure with shpchp and pciehp
has caused the attached Bug report to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
Bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what I am
talking about this indicates a serious mail system misconfiguration
somewhere.  Please contact me immediately.)

Debian bug tracking system administrator
(administrator, Debian Bugs database)

--------------------------------------
Received: (at submit) by bugs.debian.org; 1 Sep 2004 15:29:09 +0000
>From [hidden email] Wed Sep 01 08:29:09 2004
Return-path: <[hidden email]>
Received: from zivlnx01.uni-muenster.de [128.176.188.24]
        by spohr.debian.org with esmtp (Exim 3.35 1 (Debian))
        id 1C2X2q-0003Jd-00; Wed, 01 Sep 2004 08:29:09 -0700
Received: from localhost (unknown [127.0.0.1])
        by ZIVLNX01.uni-muenster.de (Postfix) with ESMTP id 9CA3C367CC
        for <[hidden email]>; Wed,  1 Sep 2004 17:29:07 +0200 (CEST)
Received: from ZIVLNX01.uni-muenster.de ([127.0.0.1])
 by localhost (ZIVLNX01 [127.0.0.1]) (amavisd-new, port 10024) with ESMTP
 id 19979-07 for <[hidden email]>;
 Wed,  1 Sep 2004 17:29:07 +0200 (CEST)
Received: from EBBALANIN.UNI-MUENSTER.DE (EBBALANIN.UNI-MUENSTER.DE [128.176.122.184])
        by ZIVLNX01.uni-muenster.de (Postfix) with ESMTP id F3F24367CA
        for <[hidden email]>; Wed,  1 Sep 2004 17:29:06 +0200 (CEST)
Date: Wed, 1 Sep 2004 17:28:42 +0200 (CEST)
From: January Weiner <[hidden email]>
To: [hidden email]
Subject: hotplug: pciehp / shpchp can't be loaded
Message-ID: <[hidden email]>
MIME-Version: 1.0
Content-Type: TEXT/PLAIN; charset=US-ASCII
X-Virus-Scanned: by amavisd-new at uni-muenster.de
Delivered-To: [hidden email]
X-Spam-Checker-Version: SpamAssassin 2.60-bugs.debian.org_2004_03_25
        (1.212-2003-09-23-exp) on spohr.debian.org
X-Spam-Status: No, hits=-8.0 required=4.0 tests=BAYES_00,HAS_PACKAGE
        autolearn=no version=2.60-bugs.debian.org_2004_03_25
X-Spam-Level:

Package: hotplug
Version: 0.0.20040329-14
Severity: normal

During boot time, hotplug gives me the following errors:

Sep  1 16:52:58 ebbjw isapnp.rc[6340]:      parport_pc: loaded sucessfully
Sep  1 16:52:59 ebbjw pci.agent[6431]:      intel-agp: already loaded
Sep  1 16:53:01 ebbjw pci.agent[6459]:      pciehp: can't be loaded
Sep  1 16:53:01 ebbjw pci.agent[6459]: missing kernel or user mode driver pciehp
Sep  1 16:53:01 ebbjw pci.agent[6459]:      shpchp: can't be loaded
Sep  1 16:53:01 ebbjw pci.agent[6459]: missing kernel or user mode driver shpchp

I do not know how serious is that.  I did not observe any adverse effects
in my system.  The corresponding modules cannot be loaded manually:

ebbjw:/home/january# modprobe pciehp
FATAL: Error inserting pciehp (/lib/modules/2.6.7-1-386/kernel/drivers/pci/hotplug/pciehp.ko): Operation not permitted
ebbjw:/home/january# modprobe shpchp
FATAL: Error inserting shpchp (/lib/modules/2.6.7-1-386/kernel/drivers/pci/hotplug/shpchp.ko): Operation not permitted

I have a Thinkpad X20 laptop.

Could it be somehow related to the fact that hotplug does not load all
necessary modules to have a working PS/2 mouse?  I need to put "psmouse" in
/etc/modules, otherwise it is not loaded correctly (see bug 247126).

Regards,
January


-- System Information:
Debian Release: 3.1
  APT prefers testing
  APT policy: (500, 'testing')
Architecture: i386 (i686)
Kernel: Linux 2.6.7-1-386
Locale: LANG=pl_PL, LC_CTYPE=pl_PL

Versions of packages hotplug depends on:
ii  debconf                      1.4.30      Debian configuration management sy
ii  grep                         2.5.1.ds1-3 GNU grep, egrep and fgrep
ii  module-init-tools            3.1-pre5-6  tools for managing Linux kernel mo
ii  modutils                     2.4.26-1    Linux module utilities
ii  procps                       1:3.2.1-2   The /proc file system utilities

-- debconf information:
  hotplug/ignore_pci_class_display: true
  hotplug/net_agent_policy: hotplug
* hotplug/usb_keyboard:
  hotplug/static_module_list:
  hotplug/x11_usbmice_hack: false


---------------------------------------
Received: (at 268583-done) by bugs.debian.org; 8 Jan 2006 22:53:43 +0000
>From [hidden email] Sun Jan 08 14:53:43 2006
Return-path: <[hidden email]>
Received: from poseidon.uni-ak.ac.at ([193.170.188.104] ident=Debian-exim)
        by spohr.debian.org with esmtp (Exim 4.50)
        id 1EvjPy-0005MA-Ho
        for [hidden email]; Sun, 08 Jan 2006 14:53:42 -0800
Received: from chello062178045213.16.11.tuwien.teleweb.at ([62.178.45.213] helo=[10.1.0.3])
        by poseidon.uni-ak.ac.at with esmtpa (Exim 4.50)
        id 1EvjPs-0000dT-Av
        for [hidden email]; Sun, 08 Jan 2006 23:53:39 +0100
From: David Schmitt <[hidden email]>
Organization: EDV-Beratung&Service
To: [hidden email]
Subject: Fwd: Re: Bug#268583: hotplug failure with shpchp and pciehp
Date: Sun, 8 Jan 2006 23:53:13 +0100
User-Agent: KMail/1.8.3
MIME-Version: 1.0
Content-Type: Multipart/Mixed;
  boundary="Boundary-00=_afZwDhsAnjejERB"
Message-Id: <[hidden email]>
X-test-SpamScore: +
X-Spam-Checker-Version: SpamAssassin 2.60-bugs.debian.org_2005_01_02
        (1.212-2003-09-23-exp) on spohr.debian.org
X-Spam-Level:
X-Spam-Status: No, hits=-5.0 required=4.0 tests=BAYES_00,HAS_BUG_NUMBER,
        RCVD_IN_SORBS autolearn=no version=2.60-bugs.debian.org_2005_01_02

--Boundary-00=_afZwDhsAnjejERB
Content-Type: text/plain;
  charset="iso-8859-15"
Content-Transfer-Encoding: quoted-printable
Content-Disposition: inline

Version: 2.6.15-1

Mike Gilbert reports this as fixed.


Regards, D.
=2D-=20
=2D hallo... wie gehts heute?
=2D *hust* gut *rotz* *keuch*
=2D gott sei dank kommunizieren wir =FCber ein septisches medium ;)
 -- Matthias Leeb, Uni f. angewandte Kunst, 2005-02-15

--Boundary-00=_afZwDhsAnjejERB
Content-Type: message/rfc822;
  name="forwarded message"
Content-Transfer-Encoding: 7bit
Content-Description: Michael Gilbert <[hidden email]>: Re: Bug#268583: hotplug failure with shpchp and pciehp
Content-Disposition: inline

Return-path: <[hidden email]>
Envelope-to: [hidden email]
Delivery-date: Sun, 08 Jan 2006 02:04:48 +0100
Received: from wproxy.gmail.com ([64.233.184.203])
        by diode.black.co.at with esmtp (Exim 4.50)
        id 1EvOzG-00038Y-Re
        for [hidden email]; Sun, 08 Jan 2006 02:04:48 +0100
Received: by wproxy.gmail.com with SMTP id i14so3177162wra
        for <[hidden email]>; Sat, 07 Jan 2006 17:04:41 -0800 (PST)
DomainKey-Signature: a=rsa-sha1; q=dns; c=nofws;
        s=beta; d=gmail.com;
        h=received:message-id:date:from:to:subject:cc:in-reply-to:mime-version:content-type:content-transfer-encoding:content-disposition:references;
        b=j+sATtcBdPSqSsXw1xl+KeVcGAtpJ3UZtlEnqVveEqo+3PIe+ABnaz51uO3CfQbROakYbhqFaS/QpvGxWIEP1TzorTnvOHNqarEM4Nf6DosczivRz/Gd2grM37W+/T7+BJZp5wcWzG+cVU1AnL9YkhqpX3sZ3RnPpakD89y36Us=
Received: by 10.54.158.16 with SMTP id g16mr5470080wre;
        Sat, 07 Jan 2006 17:04:35 -0800 (PST)
Received: by 10.54.151.7 with HTTP; Sat, 7 Jan 2006 17:04:41 -0800 (PST)
Message-ID: <[hidden email]>
Date: Sat, 7 Jan 2006 20:04:41 -0500
From: Michael Gilbert <[hidden email]>
To: David Schmitt <[hidden email]>
Subject: Re: Bug#268583: hotplug failure with shpchp and pciehp
Cc: [hidden email]
In-Reply-To: <[hidden email]>
MIME-Version: 1.0
Content-Type: text/plain;
  charset=ISO-8859-1
Content-Transfer-Encoding: quoted-printable
Content-Disposition: inline
References: <[hidden email]>
         <[hidden email]>
X-edvbus-SpamScore: -2.6 (--)
X-UID: 2880
X-Length: 2595

Hello,

Looks like this is indeed fixed as you suggest.  The shpchp line in
/var/log/kern.log with 2.6.15 is:

Jan  7 19:49:56 localhost kernel: shpchp: Standard Hot Plug PCI
Controller Driver version: 0.4

So its working correctly.  Thanks for the hard work!  Peace.
Mike

On 1/3/06, David Schmitt <[hidden email]> wrote:

> On Wed, Nov 02, 2005 at 08:45:41PM -0500, Michael Gilbert wrote:
> > Package: linux-2.6
> > Followup-For: Bug #268583
> >
> > > Could any of the affected parties verify this is still a problem
> > > with 2.6.12-4. I expect it is, but it would be good to verify.
> >
> > i couldn't find a linux-image-2.6.12-4 package anwhere, but i can
> > verify that the kernel log contains this error:
>
> Could you please retest this with a current linux image?
>
> 2.6.15 will enter unstable tomorrow.
>
> Thanks for your time and work, David
>


--Boundary-00=_afZwDhsAnjejERB--


--
To UNSUBSCRIBE, email to [hidden email]
with a subject of "unsubscribe". Trouble? Contact [hidden email]