Bug#286756: marked as done (udev gets tmpfs kernel support test wrong)

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

Bug#286756: marked as done (udev gets tmpfs kernel support test wrong)

Debian Bug Tracking System
Your message dated Wed, 11 Jan 2006 11:43:22 +0100
with message-id <20060111104322.GI7691@nancy>
and subject line Bug#286756: udev gets tmpfs kernel support test wrong
has caused the attached Bug report to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
Bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what I am
talking about this indicates a serious mail system misconfiguration
somewhere.  Please contact me immediately.)

Debian bug tracking system administrator
(administrator, Debian Bugs database)

--------------------------------------
Received: (at submit) by bugs.debian.org; 22 Dec 2004 00:39:19 +0000
>From [hidden email] Tue Dec 21 16:39:19 2004
Return-path: <[hidden email]>
Received: from hoiho.wlug.org.nz [203.97.10.50] (root)
        by spohr.debian.org with esmtp (Exim 3.35 1 (Debian))
        id 1CguX9-00011m-00; Tue, 21 Dec 2004 16:39:19 -0800
Received: from jrm by hoiho.wlug.org.nz with local (Exim 3.35 #1 (Debian))
        id 1CguX6-0002wJ-00
        for <[hidden email]>; Wed, 22 Dec 2004 13:39:16 +1300
Date: Wed, 22 Dec 2004 13:39:16 +1300
From: "John R. McPherson" <[hidden email]>
To: [hidden email]
Subject: udev gets tmpfs kernel support test wrong
Message-ID: <[hidden email]>
Mime-Version: 1.0
Content-Type: text/plain; charset=utf-8
Content-Disposition: inline
User-Agent: Mutt/1.3.28i
Sender: John McPherson <[hidden email]>
Delivered-To: [hidden email]
X-Spam-Checker-Version: SpamAssassin 2.60-bugs.debian.org_2004_03_25
        (1.212-2003-09-23-exp) on spohr.debian.org
X-Spam-Status: No, hits=-8.0 required=4.0 tests=BAYES_00,HAS_PACKAGE
        autolearn=no version=2.60-bugs.debian.org_2004_03_25
X-Spam-Level:

Package: udev
Version: 0.048-2
Severity: grave
Justification: renders computer unusable

Debian sarge/x86, custom kernel 2.6.9.

I built a kernel and didn't set CONFIG_TMPFS, and after installing the
kernel and rebooting, udev mounts an unusable tmpfs over /dev, so
no device files are accessible. The mount doesn't fail, but the
directory is unusable.
If I use 'strace', any accesses to files or dirs in "/dev" return ENODIR.
The init process complains that it can't mount filesystems and only
single-user login prompt is available.
Changing this kernel option and recompiling/installed fixed it.

The problem seems to be that the kernel lists "tmpfs" in
/proc/filesystems even if CONFIG_TMPFS is not set, and /etc/init.d/udev
tests for that to assume tmpfs can be used.

As seen in /usr/src/linux/Documentation/filesystems/tmpfs.txt:
   1) There is always a kernel internal mount which you will not see at
     all. This is used for shared anonymous mappings and SYSV shared
     memory.

     This mount does not depend on CONFIG_TMPFS. If CONFIG_TMPFS is not
     set, the user visible part of tmpfs is not build. But the internal
     mechanisms are always present.

So maybe the kernel will list tmpfs in /proc/filesystems if other
options are set, even if tmpfs ramdisks are not available?

I can provide a kernel config if more information is required.

John McPherson


---------------------------------------
Received: (at 286756-done) by bugs.debian.org; 11 Jan 2006 10:43:33 +0000
>From [hidden email] Wed Jan 11 02:43:33 2006
Return-path: <[hidden email]>
Received: from baikonur.stro.at ([213.239.196.228])
        by spohr.debian.org with esmtp (Exim 4.50)
        id 1EwdS1-0006xj-L3
        for [hidden email]; Wed, 11 Jan 2006 02:43:33 -0800
Received: from nancy (stallburg.stro.at [128.131.216.190])
        by baikonur.stro.at (Postfix) with ESMTP id 30B0E5C00B
        for <[hidden email]>; Wed, 11 Jan 2006 11:44:14 +0100 (CET)
Received: from max by nancy with local (Exim 4.60)
        (envelope-from <max@nancy>)
        id 1EwdRq-00032A-GK
        for [hidden email]; Wed, 11 Jan 2006 11:43:22 +0100
Date: Wed, 11 Jan 2006 11:43:22 +0100
From: maximilian attems <[hidden email]>
To: [hidden email]
Subject: Re: Bug#286756: udev gets tmpfs kernel support test wrong
Message-ID: <20060111104322.GI7691@nancy>
References: <[hidden email]> <[hidden email]>
MIME-Version: 1.0
Content-Type: text/plain; charset=us-ascii
Content-Disposition: inline
In-Reply-To: <[hidden email]>
User-Agent: Mutt/1.5.11
X-Virus-Scanned: by Amavis (ClamAV) at stro.at
X-Spam-Checker-Version: SpamAssassin 2.60-bugs.debian.org_2005_01_02
        (1.212-2003-09-23-exp) on spohr.debian.org
X-Spam-Level:
X-Spam-Status: No, hits=-6.0 required=4.0 tests=BAYES_00,HAS_BUG_NUMBER
        autolearn=no version=2.60-bugs.debian.org_2005_01_02

Version: linux-image-2.6.15

On Tue, 03 Jan 2006, John R. McPherson wrote:

> On Mon, Jan 02, 2006 at 09:36:23PM +0100, David Schmitt wrote:
> > Hi John!
> >
> > Could you please retest with a current kernel (testing:2.6.12,
> > unstable:2.6.14) and a current udev (>= 0.076)?
>  
> Hi,
> I thought this was fixed some time ago... the /etc/init.d/udev
> script now checks if files can successfully be created in the tmpfs
> /dev dir:
>
>   # using ln to test if /dev works, because touch is in /usr/bin/
>   if ln -s test /dev/test-file; then
>     rm /dev/test-file
>     log_end_msg 0
>   else
>     log_failure_msg "FATAL: udev requires tmpfs support, not started."
>     umount /etc/udev
>     umount /dev
>     log_end_msg 1
>     exit 1
>   fi
>
> (This is from udev version 0.060-1ubuntu1, I'm not sure which version
> in debian fixed it).

ok cool.

> The problem only occurred if someone was using a kernel that they compiled
> themselves, since the debian provided kernels had the required support.

well then he gains some experience about badly chosen .configs ;)
 
> So it's fixed for udev, at least. I thought it had been re-assigned to
> linux-2.6 because someone thought the bug was for listing tmpfs in
> /proc/filesystems when tmpfs wasn't available.

egrep tmpfs /proc/filesystems
nodev   tmpfs


closing therefor


--
maks


--
To UNSUBSCRIBE, email to [hidden email]
with a subject of "unsubscribe". Trouble? Contact [hidden email]