Bug#337610: BASIC error on saving a document

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

Bug#337610: BASIC error on saving a document

Martin Steigerwald
Package: openoffice.org-writer
Version: 2.0.0-2
Severity: normal

Hello, today I installed OpenOffice.org 2.0 on my Debian etch/sid
system. It works nicely, thanks for the great work.

But there is some glitch on saving OOWriter documents. It gives
two BASIC errors:

"Error loading BASIC of document
file:///usr/lib/openoffice/share/basic/WebWizard/script.xlb/:
General Error.
General input/output error."

"Error loading BASIC of document
file:///usr/lib/openoffice/share/basic/WebWizard/dialog.xlb/:
General Error.
General input/output error."

Well what this "general error" is trying to tell me is:
Those directories are not there. ;-) In fact I do not have a
/usr/lib/openoffice/share/basic/WebWizard/ directory on my
system at all.

Ah, I found the cause: Its some old stuff in
~/openoffice.org2. I used a Klik package of a pre-version of
OpenOffice.org 2 before.

After rm -rf .openoffice.org2/ saving OOWriter document works
as expected.

I am still reporting this as other users having used a OOo 2 klik
package or some other OOo 2 installation before, might have
the same problem. Maybe a readme or probably even a debconf
warning message (at least on install, not on upgrade) should
mention that such problems may happen when
non-debian-official OOo 2 was installed before.

Anyway when its just my previous setup and no one else complains
feel free to close the bug. ;)

Regards, Martin Steigerwald

-- System Information:
Debian Release: testing/unstable
  APT prefers testing
  APT policy: (990, 'testing'), (500, 'unstable')
Architecture: i386 (i686)
Shell:  /bin/sh linked to /bin/bash
Kernel: Linux 2.6.13.4-tp23
Locale: LANG=de_DE@euro, LC_CTYPE=de_DE@euro (charmap=ISO-8859-15)

Versions of packages openoffice.org-writer depends on:
ii  libc6                         2.3.5-6    GNU C Library: Shared libraries an
ii  libgcc1                       1:4.0.2-3  GCC support library
ii  libicu34                      3.4-2      International Components for Unico
ii  libstdc++6                    4.0.2-3    The GNU Standard C++ Library v3
ii  libstlport4.6c2               4.6.2-3    STLport C++ class library
ii  libwpd8c2                     0.8.3-1    Library for handling WordPerfect d
ii  openoffice.org-core           2.0.0-2    OpenOffice.org office suite archit
ii  python-uno                    2.0.0-2    Python interface for OpenOffice.or
ii  zlib1g                        1:1.2.3-4  compression library - runtime

Versions of packages openoffice.org-writer recommends:
ii  ope 2.0.0-2                              OpenOffice.org office suite Java s
ii  sun 1.5.0.05+debian-1.unofficial.sarge.1 Sun Java 2 Platform Standard Editi

-- no debconf information


--
To UNSUBSCRIBE, email to [hidden email]
with a subject of "unsubscribe". Trouble? Contact [hidden email]

Reply | Threaded
Open this post in threaded view
|

Bug#337610: marked as done (BASIC error on saving a document)

Debian Bug Tracking System
Your message dated Sat, 5 Nov 2005 12:47:50 +0100
with message-id <[hidden email]>
and subject line Bug#337610: BASIC error on saving a document
has caused the attached Bug report to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
Bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what I am
talking about this indicates a serious mail system misconfiguration
somewhere.  Please contact me immediately.)

Debian bug tracking system administrator
(administrator, Debian Bugs database)

--------------------------------------
Received: (at submit) by bugs.debian.org; 5 Nov 2005 10:12:41 +0000
>From [hidden email] Sat Nov 05 02:12:40 2005
Return-path: <[hidden email]>
Received: from master.debian.org [146.82.138.7]
        by spohr.debian.org with esmtp (Exim 3.36 1 (Debian))
        id 1EYL2O-0006vJ-00; Sat, 05 Nov 2005 02:12:40 -0800
Received: from dslb-084-056-077-165.pools.arcor-ip.net (deepdance.local) [84.56.77.165]
        by master.debian.org with esmtp (Exim 3.35 1 (Debian))
        id 1EYL2M-0006I8-00; Sat, 05 Nov 2005 04:12:38 -0600
Content-Type: text/plain; charset="us-ascii"
MIME-Version: 1.0
Content-Transfer-Encoding: 7bit
From: Martin Steigerwald <[hidden email]>
To: Debian Bug Tracking System <[hidden email]>
Subject: BASIC error on saving a document
X-Mailer: reportbug 3.17
Date: Sat, 05 Nov 2005 11:12:36 +0100
X-Debbugs-Cc: [hidden email]
Message-Id: <[hidden email]>
Delivered-To: [hidden email]
X-Spam-Checker-Version: SpamAssassin 2.60-bugs.debian.org_2005_01_02
        (1.212-2003-09-23-exp) on spohr.debian.org
X-Spam-Level:
X-Spam-Status: No, hits=-9.0 required=4.0 tests=BAYES_00,HAS_PACKAGE,
        OUR_MTA_MSGID,X_DEBBUGS_CC autolearn=ham
        version=2.60-bugs.debian.org_2005_01_02

Package: openoffice.org-writer
Version: 2.0.0-2
Severity: normal

Hello, today I installed OpenOffice.org 2.0 on my Debian etch/sid
system. It works nicely, thanks for the great work.

But there is some glitch on saving OOWriter documents. It gives
two BASIC errors:

"Error loading BASIC of document
file:///usr/lib/openoffice/share/basic/WebWizard/script.xlb/:
General Error.
General input/output error."

"Error loading BASIC of document
file:///usr/lib/openoffice/share/basic/WebWizard/dialog.xlb/:
General Error.
General input/output error."

Well what this "general error" is trying to tell me is:
Those directories are not there. ;-) In fact I do not have a
/usr/lib/openoffice/share/basic/WebWizard/ directory on my
system at all.

Ah, I found the cause: Its some old stuff in
~/openoffice.org2. I used a Klik package of a pre-version of
OpenOffice.org 2 before.

After rm -rf .openoffice.org2/ saving OOWriter document works
as expected.

I am still reporting this as other users having used a OOo 2 klik
package or some other OOo 2 installation before, might have
the same problem. Maybe a readme or probably even a debconf
warning message (at least on install, not on upgrade) should
mention that such problems may happen when
non-debian-official OOo 2 was installed before.

Anyway when its just my previous setup and no one else complains
feel free to close the bug. ;)

Regards, Martin Steigerwald

-- System Information:
Debian Release: testing/unstable
  APT prefers testing
  APT policy: (990, 'testing'), (500, 'unstable')
Architecture: i386 (i686)
Shell:  /bin/sh linked to /bin/bash
Kernel: Linux 2.6.13.4-tp23
Locale: LANG=de_DE@euro, LC_CTYPE=de_DE@euro (charmap=ISO-8859-15)

Versions of packages openoffice.org-writer depends on:
ii  libc6                         2.3.5-6    GNU C Library: Shared libraries an
ii  libgcc1                       1:4.0.2-3  GCC support library
ii  libicu34                      3.4-2      International Components for Unico
ii  libstdc++6                    4.0.2-3    The GNU Standard C++ Library v3
ii  libstlport4.6c2               4.6.2-3    STLport C++ class library
ii  libwpd8c2                     0.8.3-1    Library for handling WordPerfect d
ii  openoffice.org-core           2.0.0-2    OpenOffice.org office suite archit
ii  python-uno                    2.0.0-2    Python interface for OpenOffice.or
ii  zlib1g                        1:1.2.3-4  compression library - runtime

Versions of packages openoffice.org-writer recommends:
ii  ope 2.0.0-2                              OpenOffice.org office suite Java s
ii  sun 1.5.0.05+debian-1.unofficial.sarge.1 Sun Java 2 Platform Standard Editi

-- no debconf information

---------------------------------------
Received: (at 337610-done) by bugs.debian.org; 5 Nov 2005 11:48:23 +0000
>From [hidden email] Sat Nov 05 03:48:23 2005
Return-path: <[hidden email]>
Received: from mail.gmx.net [213.165.64.20]
        by spohr.debian.org with smtp (Exim 3.36 1 (Debian))
        id 1EYMX0-0000f4-00; Sat, 05 Nov 2005 03:48:23 -0800
Received: (qmail invoked by alias); 05 Nov 2005 11:47:51 -0000
Received: from dslb-084-056-065-232.pools.arcor-ip.net (EHLO frodo) [84.56.65.232]
  by mail.gmx.net (mp012) with SMTP; 05 Nov 2005 12:47:51 +0100
X-Authenticated: #1545045
Received: by frodo (Postfix, from userid 1000)
        id EB5802800C; Sat,  5 Nov 2005 12:47:50 +0100 (CET)
Date: Sat, 5 Nov 2005 12:47:50 +0100
From: Rene Engelhard <[hidden email]>
To: [hidden email]
Subject: Re: Bug#337610: BASIC error on saving a document
Message-ID: <[hidden email]>
References: <[hidden email]>
MIME-Version: 1.0
Content-Type: multipart/signed; micalg=pgp-sha1;
        protocol="application/pgp-signature"; boundary="YZ5djTAD1cGYuMQK"
Content-Disposition: inline
In-Reply-To: <[hidden email]>
X-PGP-Key: 248AEB73
X-PGP-Fingerprint: 41FA F208 28D4 7CA5 19BB  7AD9 F859 90B0 248A EB73
Organization: The Debian Project
User-Agent: Mutt/1.5.11
X-Y-GMX-Trusted: 0
Delivered-To: [hidden email]
X-Spam-Checker-Version: SpamAssassin 2.60-bugs.debian.org_2005_01_02
        (1.212-2003-09-23-exp) on spohr.debian.org
X-Spam-Level:
X-Spam-Status: No, hits=-6.0 required=4.0 tests=BAYES_00,HAS_BUG_NUMBER
        autolearn=no version=2.60-bugs.debian.org_2005_01_02


--YZ5djTAD1cGYuMQK
Content-Type: text/plain; charset=us-ascii
Content-Disposition: inline

Hi,

Martin Steigerwald wrote:
> Anyway when its just my previous setup and no one else complains
> feel free to close the bug. ;)

I'll do that :)

Regards,

Rene

--YZ5djTAD1cGYuMQK
Content-Type: application/pgp-signature; name="signature.asc"
Content-Description: Digital signature
Content-Disposition: inline

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.2 (GNU/Linux)

iD8DBQFDbJvm+FmQsCSK63MRAnuBAJ0dXO/1mFjzMI38OpgS96RQ6a9/EgCcDimK
yzp9z2nY0VPrGugLpWDr8hM=
=dP0W
-----END PGP SIGNATURE-----

--YZ5djTAD1cGYuMQK--


--
To UNSUBSCRIBE, email to [hidden email]
with a subject of "unsubscribe". Trouble? Contact [hidden email]