Bug#346294: linux-image-2.6.15-1-686: does not install (yaird complains about "dm-9")

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

Bug#346294: linux-image-2.6.15-1-686: does not install (yaird complains about "dm-9")

Brian Minton-2
Package: linux-image-2.6.15-1-686
Version: 2.6.15-1
Severity: normal


dpkg -i linux-image-2.6.15-1-686_2.6.15-1_i386.deb
(Reading database ... 1269464 files and directories currently installed.)
Preparing to replace linux-image-2.6.15-1-686 2.6.15-1 (using linux-image-2.6.15-1-686_2.6.15-1_i386.deb) ...
The directory /lib/modules/2.6.15-1-686 still exists. Continuing as directed.
Done.
Unpacking replacement linux-image-2.6.15-1-686 ...
Setting up linux-image-2.6.15-1-686 (2.6.15-1) ...
Running depmod.
Finding valid ramdisk creators.
Using mkinitrd.yaird to build the ramdisk.
yaird error: unsupported device required: dm-9 (fatal)
Failed to create initrd image.
dpkg: error processing linux-image-2.6.15-1-686 (--install):
 subprocess post-installation script returned error exit status 9
Errors were encountered while processing:
 linux-image-2.6.15-1-686

-- System Information:
Debian Release: testing/unstable
  APT prefers stable
  APT policy: (900, 'stable'), (100, 'unstable')
Architecture: i386 (i686)
Shell:  /bin/sh linked to /bin/bash
Kernel: Linux 2.6.12.5
Locale: LANG=C, LC_CTYPE=C (charmap=ANSI_X3.4-1968)

Versions of packages linux-image-2.6.15-1-686 depends on:
ii  initramfs-tools [linux-initra 0.39       tools for generating an initramfs
ii  module-init-tools             3.2-pre9-4 tools for managing Linux kernel mo
ii  yaird [linux-initramfs-tool]  0.0.11-12  Yet Another mkInitRD

Versions of packages linux-image-2.6.15-1-686 recommends:
pn  libc6-i686                    <none>     (no description available)

-- debconf information:
  linux-image-2.6.15-1-686/postinst/kimage-is-a-directory:
  linux-image-2.6.15-1-686/preinst/abort-install-2.6.15-1-686:
  linux-image-2.6.15-1-686/preinst/abort-overwrite-2.6.15-1-686:
  linux-image-2.6.15-1-686/prerm/would-invalidate-boot-loader-2.6.15-1-686: true
  linux-image-2.6.15-1-686/preinst/bootloader-initrd-2.6.15-1-686: true
  linux-image-2.6.15-1-686/preinst/initrd-2.6.15-1-686:
  linux-image-2.6.15-1-686/postinst/depmod-error-2.6.15-1-686: false
  linux-image-2.6.15-1-686/postinst/old-dir-initrd-link-2.6.15-1-686: true
  linux-image-2.6.15-1-686/postinst/create-kimage-link-2.6.15-1-686: true
  linux-image-2.6.15-1-686/prerm/removing-running-kernel-2.6.15-1-686: true
  linux-image-2.6.15-1-686/postinst/depmod-error-initrd-2.6.15-1-686: false
  linux-image-2.6.15-1-686/postinst/bootloader-test-error-2.6.15-1-686:
  linux-image-2.6.15-1-686/preinst/lilo-has-ramdisk:
  linux-image-2.6.15-1-686/postinst/old-initrd-link-2.6.15-1-686: true
  linux-image-2.6.15-1-686/preinst/already-running-this-2.6.15-1-686:
  linux-image-2.6.15-1-686/preinst/elilo-initrd-2.6.15-1-686: true
* linux-image-2.6.15-1-686/preinst/overwriting-modules-2.6.15-1-686: false
  linux-image-2.6.15-1-686/postinst/bootloader-error-2.6.15-1-686:
  linux-image-2.6.15-1-686/preinst/failed-to-move-modules-2.6.15-1-686:
  linux-image-2.6.15-1-686/postinst/old-system-map-link-2.6.15-1-686: true
  linux-image-2.6.15-1-686/preinst/lilo-initrd-2.6.15-1-686: true


--
To UNSUBSCRIBE, email to [hidden email]
with a subject of "unsubscribe". Trouble? Contact [hidden email]