Bug#369500: stellarium: Some text cannot be output (missing font?)

classic Classic list List threaded Threaded
4 messages Options
Reply | Threaded
Open this post in threaded view
|

Bug#369500: stellarium: Some text cannot be output (missing font?)

Uwe Steinmann-2
Package: stellarium
Version: 0.8.0-1
Severity: important


Hi,

some text is unreadable, e.g. the planet names. Instead of letters
there are just rectancles. This looks like a missing font. In the
headline of the screen almost everything is readable, except for
the coordinates before '@' and after the '('.

  Uwe

-- System Information:
Debian Release: testing/unstable
  APT prefers unstable
  APT policy: (990, 'unstable'), (500, 'sid'), (500, 'testing'), (500, 'stable')
Architecture: powerpc (ppc)
Shell:  /bin/sh linked to /bin/bash
Kernel: Linux 2.6.12-1-powerpc
Locale: LANG=de_DE.ISO-8859-15@euro, LC_CTYPE=de_DE.ISO-8859-15@euro (charmap=ISO-8859-15) (ignored: LC_ALL set to de_DE.ISO-8859-15@euro)

Versions of packages stellarium depends on:
ii  libc6                       2.3.6-10     GNU C Library: Shared libraries
ii  libfreetype6                2.2.1-2      FreeType 2 font engine, shared lib
ii  libgcc1                     1:4.1.0-4    GCC support library
ii  libgl1-mesa-glx [libgl1]    6.4.1-0.4    A free implementation of the OpenG
ii  libglu1-mesa [libglu1]      6.4.1-0.4    The OpenGL utility library (GLU)
ii  libpng12-0                  1.2.8rel-5.1 PNG library - runtime
ii  libsdl-mixer1.2             1.2.6-1.1+b1 mixer library for Simple DirectMed
ii  libsdl1.2debian             1.2.9-5+b1   Simple DirectMedia Layer
ii  libstdc++6                  4.1.0-4      The GNU Standard C++ Library v3
ii  stellarium-data             0.8.0-1      datafiles for Stellarium, a real-t
ii  zlib1g                      1:1.2.3-11   compression library - runtime

stellarium recommends no packages.

-- no debconf information


--
To UNSUBSCRIBE, email to [hidden email]
with a subject of "unsubscribe". Trouble? Contact [hidden email]

Reply | Threaded
Open this post in threaded view
|

Bug#369500: stellarium: Some text cannot be output (missing font?)

Cédric Delfosse-2
That's weird, because the fonts that are used are in fact shipped by the
package:
 - /usr/share/stellarium/data/DejaVuSansMono.ttf
 - /usr/share/stellarium/data/DejaVuSans.ttf

Could you send me a screenshot ? Thanks




--
To UNSUBSCRIBE, email to [hidden email]
with a subject of "unsubscribe". Trouble? Contact [hidden email]

Reply | Threaded
Open this post in threaded view
|

Bug#369500: stellarium: Some text cannot be output (missing font?)

Cédric Delfosse-2
In reply to this post by Uwe Steinmann-2
OK, I found another ppc user that has the same bug.



--
To UNSUBSCRIBE, email to [hidden email]
with a subject of "unsubscribe". Trouble? Contact [hidden email]

Reply | Threaded
Open this post in threaded view
|

Bug#369500: stellarium: Some text cannot be output (missing font?)

Uwe Steinmann
In reply to this post by Cédric Delfosse-2
On Tue, Jun 06, 2006 at 10:20:24PM +0200, Cédric Delfosse wrote:
> That's weird, because the fonts that are used are in fact shipped by the
> package:
>  - /usr/share/stellarium/data/DejaVuSansMono.ttf
>  - /usr/share/stellarium/data/DejaVuSans.ttf
>
> Could you send me a screenshot ? Thanks
Thinks are becoming more weird. Shouldn't 'stellarium -h' output
something useful?
Here is what I get.

steinm@ibook:~$ stellarium -h
???????-????????????????????????????????????????????????????????????????????????????????????????????????????????????????????????????????steinm@ibook:~$

Could this be related to my locale/encoding?
steinm@ibook:~$ echo $LANG
de_DE.ISO-8859-15@euro

  Uwe

--
  MMK GmbH, Fleyer Str. 196, 58097 Hagen
  [hidden email]
  Tel: +2331 840446    Fax: +2331 843920

signature.asc (196 bytes) Download Attachment