Bug#377423: linux-image-2.6.16-2-em64t-p4-smp: Fails to find boot device (AHCI ICH7 Family)

classic Classic list List threaded Threaded
4 messages Options
Reply | Threaded
Open this post in threaded view
|

Bug#377423: linux-image-2.6.16-2-em64t-p4-smp: Fails to find boot device (AHCI ICH7 Family)

Andrew Nady
Package: linux-image-2.6.16-2-em64t-p4-smp
Version: 2.6.16-14
Severity: serious
Justification: 3

Hardware:
ASUS P5WD2
Maxtor SATA 300G
DELL monitor with 4 usb card readers FPW2004

Configuration:
Maxtor hard drive connected to SATA port 1 (sda)
The ATA bus is configured in BIOS to AHCI mode.

Problem:

The kernel randomly swaps the /dev/sda to /dev/sde device and back on boot-up.
The confusion occurs when the kernel spontaneously
assigns /dev/sda, /dev/sdb, /dev/sdc and /dev/sdd to the USB based card
readers.
If the kernel selects /dev/sda (SATA IDE) as the boot drive all is good.
If the kernel assigns /dev/sda to one of the USB card readers, than the AHCI
bus SATA drive gets /dev/sde and the error is"  "Waiting for no boot device"

P.S same thing occurs with   2.6.17-1-em64t-p4-smp

Andrew.

-- System Information:
Debian Release: testing/unstable
  APT prefers unstable
  APT policy: (500, 'unstable')
Architecture: amd64 (x86_64)
Shell:  /bin/sh linked to /bin/bash
Kernel: Linux 2.6.16-2-em64t-p4-smp
Locale: LANG=C, LC_CTYPE=C (charmap=ANSI_X3.4-1968)

Versions of packages linux-image-2.6.16-2-em64t-p4-smp depends on:
ii  e2fsprogs                     1.39-1     ext2 file system utilities and
lib ii  initramfs-tools [linux-initra 0.60       tools for generating an
 initramfs ii  module-init-tools             3.2.2-3    tools for managing
 Linux kernel mo

linux-image-2.6.16-2-em64t-p4-smp recommends no packages.

-- debconf information:
 
 linux-image-2.6.16-2-em64t-p4-smp/preinst/abort-install-2.6.16-2-em64t-p4-sm
p:
 linux-image-2.6.16-2-em64t-p4-smp/preinst/bootloader-initrd-2.6.16-2-em64t-p
4-smp: true
 linux-image-2.6.16-2-em64t-p4-smp/preinst/initrd-2.6.16-2-em64t-p4-smp:
 linux-image-2.6.16-2-em64t-p4-smp/postinst/old-dir-initrd-link-2.6.16-2-em64
t-p4-smp: true
 linux-image-2.6.16-2-em64t-p4-smp/postinst/old-initrd-link-2.6.16-2-em64t-p4
-smp: true
 linux-image-2.6.16-2-em64t-p4-smp/preinst/already-running-this-2.6.16-2-em64
t-p4-smp:
 linux-image-2.6.16-2-em64t-p4-smp/postinst/bootloader-test-error-2.6.16-2-em
64t-p4-smp:
 linux-image-2.6.16-2-em64t-p4-smp/postinst/depmod-error-initrd-2.6.16-2-em64
t-p4-smp: false
 linux-image-2.6.16-2-em64t-p4-smp/postinst/kimage-is-a-directory:
 
 linux-image-2.6.16-2-em64t-p4-smp/postinst/old-system-map-link-2.6.16-2-em64
t-p4-smp: true
 linux-image-2.6.16-2-em64t-p4-smp/prerm/would-invalidate-boot-loader-2.6.16-
2-em64t-p4-smp: true
 linux-image-2.6.16-2-em64t-p4-smp/preinst/failed-to-move-modules-2.6.16-2-em
64t-p4-smp:
 linux-image-2.6.16-2-em64t-p4-smp/postinst/bootloader-error-2.6.16-2-em64t-p
4-smp:
 linux-image-2.6.16-2-em64t-p4-smp/postinst/depmod-error-2.6.16-2-em64t-p4-sm
p: false
 linux-image-2.6.16-2-em64t-p4-smp/preinst/lilo-initrd-2.6.16-2-em64t-p4-smp:
 true
 linux-image-2.6.16-2-em64t-p4-smp/preinst/elilo-initrd-2.6.16-2-em64t-p4-smp
: true
 linux-image-2.6.16-2-em64t-p4-smp/preinst/overwriting-modules-2.6.16-2-em64t
-p4-smp: true
 linux-image-2.6.16-2-em64t-p4-smp/preinst/abort-overwrite-2.6.16-2-em64t-p4-
smp:
 linux-image-2.6.16-2-em64t-p4-smp/postinst/create-kimage-link-2.6.16-2-em64t
-p4-smp: true
 linux-image-2.6.16-2-em64t-p4-smp/prerm/removing-running-kernel-2.6.16-2-em6
4t-p4-smp: true linux-image-2.6.16-2-em64t-p4-smp/preinst/lilo-has-ramdisk:

-------------------------------------------------------

--
Andrew


--
To UNSUBSCRIBE, email to [hidden email]
with a subject of "unsubscribe". Trouble? Contact [hidden email]

Reply | Threaded
Open this post in threaded view
|

Bug#377423: marked as done (linux-image-2.6.16-2-em64t-p4-smp: Fails to find boot device (AHCI ICH7 Family))

Debian Bug Tracking System
Your message dated Sat, 8 Jul 2006 22:48:45 +0200
with message-id <[hidden email]>
and subject line Bug#377423: linux-image-2.6.16-2-em64t-p4-smp: Fails to find boot device (AHCI ICH7 Family)
has caused the attached Bug report to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
Bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what I am
talking about this indicates a serious mail system misconfiguration
somewhere.  Please contact me immediately.)

Debian bug tracking system administrator
(administrator, Debian Bugs database)


Package: linux-image-2.6.16-2-em64t-p4-smp
Version: 2.6.16-14
Severity: serious
Justification: 3

Hardware:
ASUS P5WD2
Maxtor SATA 300G
DELL monitor with 4 usb card readers FPW2004

Configuration:
Maxtor hard drive connected to SATA port 1 (sda)
The ATA bus is configured in BIOS to AHCI mode.

Problem:

The kernel randomly swaps the /dev/sda to /dev/sde device and back on boot-up.
The confusion occurs when the kernel spontaneously
assigns /dev/sda, /dev/sdb, /dev/sdc and /dev/sdd to the USB based card
readers.
If the kernel selects /dev/sda (SATA IDE) as the boot drive all is good.
If the kernel assigns /dev/sda to one of the USB card readers, than the AHCI
bus SATA drive gets /dev/sde and the error is"  "Waiting for no boot device"

P.S same thing occurs with   2.6.17-1-em64t-p4-smp

Andrew.

-- System Information:
Debian Release: testing/unstable
  APT prefers unstable
  APT policy: (500, 'unstable')
Architecture: amd64 (x86_64)
Shell:  /bin/sh linked to /bin/bash
Kernel: Linux 2.6.16-2-em64t-p4-smp
Locale: LANG=C, LC_CTYPE=C (charmap=ANSI_X3.4-1968)

Versions of packages linux-image-2.6.16-2-em64t-p4-smp depends on:
ii  e2fsprogs                     1.39-1     ext2 file system utilities and
lib ii  initramfs-tools [linux-initra 0.60       tools for generating an
 initramfs ii  module-init-tools             3.2.2-3    tools for managing
 Linux kernel mo

linux-image-2.6.16-2-em64t-p4-smp recommends no packages.

-- debconf information:
 
 linux-image-2.6.16-2-em64t-p4-smp/preinst/abort-install-2.6.16-2-em64t-p4-sm
p:
 linux-image-2.6.16-2-em64t-p4-smp/preinst/bootloader-initrd-2.6.16-2-em64t-p
4-smp: true
 linux-image-2.6.16-2-em64t-p4-smp/preinst/initrd-2.6.16-2-em64t-p4-smp:
 linux-image-2.6.16-2-em64t-p4-smp/postinst/old-dir-initrd-link-2.6.16-2-em64
t-p4-smp: true
 linux-image-2.6.16-2-em64t-p4-smp/postinst/old-initrd-link-2.6.16-2-em64t-p4
-smp: true
 linux-image-2.6.16-2-em64t-p4-smp/preinst/already-running-this-2.6.16-2-em64
t-p4-smp:
 linux-image-2.6.16-2-em64t-p4-smp/postinst/bootloader-test-error-2.6.16-2-em
64t-p4-smp:
 linux-image-2.6.16-2-em64t-p4-smp/postinst/depmod-error-initrd-2.6.16-2-em64
t-p4-smp: false
 linux-image-2.6.16-2-em64t-p4-smp/postinst/kimage-is-a-directory:
 
 linux-image-2.6.16-2-em64t-p4-smp/postinst/old-system-map-link-2.6.16-2-em64
t-p4-smp: true
 linux-image-2.6.16-2-em64t-p4-smp/prerm/would-invalidate-boot-loader-2.6.16-
2-em64t-p4-smp: true
 linux-image-2.6.16-2-em64t-p4-smp/preinst/failed-to-move-modules-2.6.16-2-em
64t-p4-smp:
 linux-image-2.6.16-2-em64t-p4-smp/postinst/bootloader-error-2.6.16-2-em64t-p
4-smp:
 linux-image-2.6.16-2-em64t-p4-smp/postinst/depmod-error-2.6.16-2-em64t-p4-sm
p: false
 linux-image-2.6.16-2-em64t-p4-smp/preinst/lilo-initrd-2.6.16-2-em64t-p4-smp:
 true
 linux-image-2.6.16-2-em64t-p4-smp/preinst/elilo-initrd-2.6.16-2-em64t-p4-smp
: true
 linux-image-2.6.16-2-em64t-p4-smp/preinst/overwriting-modules-2.6.16-2-em64t
-p4-smp: true
 linux-image-2.6.16-2-em64t-p4-smp/preinst/abort-overwrite-2.6.16-2-em64t-p4-
smp:
 linux-image-2.6.16-2-em64t-p4-smp/postinst/create-kimage-link-2.6.16-2-em64t
-p4-smp: true
 linux-image-2.6.16-2-em64t-p4-smp/prerm/removing-running-kernel-2.6.16-2-em6
4t-p4-smp: true linux-image-2.6.16-2-em64t-p4-smp/preinst/lilo-has-ramdisk:

-------------------------------------------------------

--
Andrew


On Sat, Jul 08, 2006 at 04:10:53PM -0400, Andrew Nady wrote:
> The kernel randomly swaps the /dev/sda to /dev/sde device and back on boot-up.
> The confusion occurs when the kernel spontaneously
> assigns /dev/sda, /dev/sdb, /dev/sdc and /dev/sdd to the USB based card
> readers.

The device names are not considered stable. Use udev.

Bastian

--
Totally illogical, there was no chance.
                -- Spock, "The Galileo Seven", stardate 2822.3

signature.asc (204 bytes) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Bug#377423: linux-image-2.6.16-2-em64t-p4-smp: Fails to find boot device (AHCI ICH7 Family)

Florian Weimer
In reply to this post by Andrew Nady
reopen 377423
thanks

* Bastian Blank:

> On Sat, Jul 08, 2006 at 04:10:53PM -0400, Andrew Nady wrote:
>> The kernel randomly swaps the /dev/sda to /dev/sde device and back on boot-up.
>> The confusion occurs when the kernel spontaneously
>> assigns /dev/sda, /dev/sdb, /dev/sdc and /dev/sdd to the USB based card
>> readers.
>
> The device names are not considered stable. Use udev.

Please make sure that (a) this is documented in the release notes, (b)
the priority of udev is bumped, (c) debian-installer actually puts
path-based device names into /etc/fstab (which it didn't, last time I
checked).  Or fix the kernel and the boot process to deal with this
situation more gracefully.


--
To UNSUBSCRIBE, email to [hidden email]
with a subject of "unsubscribe". Trouble? Contact [hidden email]

Reply | Threaded
Open this post in threaded view
|

Processed: Re: Bug#377423: linux-image-2.6.16-2-em64t-p4-smp: Fails to find boot device (AHCI ICH7 Family)

Debian Bug Tracking System
Processing commands for [hidden email]:

> reopen 377423
Bug#377423: linux-image-2.6.16-2-em64t-p4-smp: Fails to find boot device (AHCI ICH7 Family)
Bug reopened, originator not changed.

> thanks
Stopping processing here.

Please contact me if you need assistance.

Debian bug tracking system administrator
(administrator, Debian Bugs database)


--
To UNSUBSCRIBE, email to [hidden email]
with a subject of "unsubscribe". Trouble? Contact [hidden email]