Bug#384352: server doesnt start, module ABI major version mismatch

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

Bug#384352: server doesnt start, module ABI major version mismatch

Florian Ludwig
Package: xserver-xorg-video-savage
Version: 1:2.0.2.3-4
Severity: grave


Since the last apt-get upgrade my xserver doesnt work: anymore.

/var/log/Xorg.0.log
[...]
(II) Module savage: vendor="X.Org Foundation"
        compiled for 7.0.0, module version = 2.0.2
        Module class: X.Org Video Driver
        ABI class: X.Org Video Driver, version 0.8
(EE) module ABI major version (0) doesn't match the server's version (1)
(II) UnloadModule: "savage"
(II) Unloading /usr/lib/xorg/modules/drivers/savage_drv.so
(EE) Failed to load module "savage" (module requirement mismatch, 0)
[...]

-- System Information:
Debian Release: testing/unstable
  APT prefers unstable
  APT policy: (650, 'unstable')
Architecture: i386 (i686)
Shell:  /bin/sh linked to /bin/dash
Kernel: Linux 2.6.17-1-686
Locale: LANG=en_US.UTF-8, LC_CTYPE=en_US.UTF-8 (charmap=UTF-8)

Versions of packages xserver-xorg-video-savage depends on:
ii  libc6                        2.3.6.ds1-2 GNU C Library: Shared libraries
ii  xserver-xorg-core            1:1.1.1-3   X.Org X server -- core server

xserver-xorg-video-savage recommends no packages.

-- no debconf information


--
To UNSUBSCRIBE, email to [hidden email]
with a subject of "unsubscribe". Trouble? Contact [hidden email]