Bug#384887: init script stop action warns about running apache2 processes when there are none

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

Bug#384887: init script stop action warns about running apache2 processes when there are none

Martin Steigerwald
Package: apache2
Version: 2.2.3-1~exp.r170
Severity: minor

The init script stop action warns about running apache2 processes when
there are none. This only seem to happen when upon start apache2
complains about configuration errors (see debian bug #384882, #384883):

root@deepdance:~ -> /etc/init.d/apache2 stop
Stopping web server (apache2)... ... failed!
You may still have some apache2 processes running.  There are
processes named 'apache2' which do not match your pid file,
and in the name of safety, we've left them alone.  Please review
the situation by hand.
 failed!
root@deepdance:~ -> ps aux | grep apache
root      3096  0.0  0.1   3916   788 pts/1    S+   17:28   0:00 grep apache

Well otherwise its up and running (without PHP and Ruby atm) ;-)

-- System Information:
Debian Release: testing/unstable
  APT prefers testing
  APT policy: (990, 'testing'), (500, 'unstable'), (1, 'experimental')
Architecture: i386 (i686)
Shell:  /bin/sh linked to /bin/bash
Kernel: Linux 2.6.17.11-ck1-tp23-sws2-2.2.7
Locale: LANG=de_DE@euro, LC_CTYPE=de_DE@euro (charmap=ISO-8859-15)

Versions of packages apache2 depends on:
ii  apache2-mpm-prefork     2.2.3-1~exp.r170 Traditional model for Apache HTTPD

apache2 recommends no packages.

-- no debconf information


--
To UNSUBSCRIBE, email to [hidden email]
with a subject of "unsubscribe". Trouble? Contact [hidden email]

Reply | Threaded
Open this post in threaded view
|

Bug#384887: marked as done (init script stop action warns about running apache2 processes when there are none)

Debian Bug Tracking System
Your message dated Mon, 25 Jun 2007 22:29:22 +0200
with message-id <[hidden email]>
and subject line init script stop action warns about running apache2 processes when there are none
has caused the attached Bug report to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
Bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what I am
talking about this indicates a serious mail system misconfiguration
somewhere.  Please contact me immediately.)

Debian bug tracking system administrator
(administrator, Debian Bugs database)


Package: apache2
Version: 2.2.3-1~exp.r170
Severity: minor

The init script stop action warns about running apache2 processes when
there are none. This only seem to happen when upon start apache2
complains about configuration errors (see debian bug #384882, #384883):

root@deepdance:~ -> /etc/init.d/apache2 stop
Stopping web server (apache2)... ... failed!
You may still have some apache2 processes running.  There are
processes named 'apache2' which do not match your pid file,
and in the name of safety, we've left them alone.  Please review
the situation by hand.
 failed!
root@deepdance:~ -> ps aux | grep apache
root      3096  0.0  0.1   3916   788 pts/1    S+   17:28   0:00 grep apache

Well otherwise its up and running (without PHP and Ruby atm) ;-)

-- System Information:
Debian Release: testing/unstable
  APT prefers testing
  APT policy: (990, 'testing'), (500, 'unstable'), (1, 'experimental')
Architecture: i386 (i686)
Shell:  /bin/sh linked to /bin/bash
Kernel: Linux 2.6.17.11-ck1-tp23-sws2-2.2.7
Locale: LANG=de_DE@euro, LC_CTYPE=de_DE@euro (charmap=ISO-8859-15)

Versions of packages apache2 depends on:
ii  apache2-mpm-prefork     2.2.3-1~exp.r170 Traditional model for Apache HTTPD

apache2 recommends no packages.

-- no debconf information


Version: 2.2.3-3

I cannot reproduce this bug anymore. Looking at the svn changelog,
this was likely fixed in 2.2.3-3. Feel free to reopen it if you
encounter it again.