Bug#390626: glxgears flickers a lot, slow 2d graphic operations

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

Bug#390626: glxgears flickers a lot, slow 2d graphic operations

Martin Steigerwald
Package: xserver-xorg-video-savage
Version: 1:2.1.2-1
Severity: important

Hello,

while 2.1.2-1 apparently fixes bug 389404 + 389794, 2d graphic operations
are quite slow with it compared to 2.0.2.3-4 of the driver.

glxgears shows the gears again but it is flickering a lot... After
quitting it it shows the following message:

martin@deepdance:/usr/share/doc/xserver-xorg-video-savage -> glxgears
libGL error: drmMap of framebuffer failed (Invalid argument)
libGL error: reverting to (slow) indirect rendering
X connection to :0.0 broken (explicit kill or server shutdown).

I tried 6.5.0.cvs.20060524-1.1 of libgl1-mesa-dri, libgl1-mesa-glx,
libglu1-mesa and then I updated 6.5.1.

Scrolling in Konqueror, KMail, Firefox and other apps is quite slow.
Scrolling in Konsole is still fast. Scrolling was really fast with
version 2.0.2.3-4 of the driver

My xorg.conf Driver section:

Section "Device"
        Identifier      "Savage"
        Driver          "savage"
        BusID           "PCI:1:0:0"
        Option          "Accel" "True"
        # Acceleration
        Option          "AccelMethod" "exa"
        # Hardware-Cursor
        Option          "HWCursor" "True"
        # AGP: Should be able to do 4x
        Option          "AGPMode" "4"
        # Powermanagement: Don't know whether this works with the savage
        Option          "DynamicClocks" "True"
        # For AROS http://www.aros.org
        Option          "BackingStore" "True"
EndSection

I also tried without AccelMethod exa, without DynamicClocks and without
BackingStore - no change.

This is on an IBM ThinkPad T23 with

01:00.0 VGA compatible controller: S3 Inc. SuperSavage IX/C SDR (rev 05)

Regards,
Martin

-- System Information:
Debian Release: testing/unstable
  APT prefers testing
  APT policy: (990, 'testing'), (500, 'unstable'), (1, 'experimental')
Architecture: i386 (i686)
Shell:  /bin/sh linked to /bin/bash
Kernel: Linux 2.6.18-ck1-tp23-sws-2.2.8
Locale: LANG=de_DE@euro, LC_CTYPE=de_DE@euro (charmap=ISO-8859-15)

Versions of packages xserver-xorg-video-savage depends on:
ii  libc6                        2.3.6.ds1-4 GNU C Library: Shared libraries
ii  xserver-xorg-core            2:1.1.1-9   X.Org X server -- core server

xserver-xorg-video-savage recommends no packages.

-- no debconf information


--
To UNSUBSCRIBE, email to [hidden email]
with a subject of "unsubscribe". Trouble? Contact [hidden email]

Reply | Threaded
Open this post in threaded view
|

Bug#390626: marked as done (glxgears flickers a lot, slow 2d graphic operations)

Debian Bug Tracking System
Your message dated Sat, 05 May 2007 17:43:42 +0200
with message-id <[hidden email]>
and subject line Bug#390626: glxgears flickers a lot, slow 2d graphic operations
has caused the attached Bug report to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
Bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what I am
talking about this indicates a serious mail system misconfiguration
somewhere.  Please contact me immediately.)

Debian bug tracking system administrator
(administrator, Debian Bugs database)


Package: xserver-xorg-video-savage
Version: 1:2.1.2-1
Severity: important

Hello,

while 2.1.2-1 apparently fixes bug 389404 + 389794, 2d graphic operations
are quite slow with it compared to 2.0.2.3-4 of the driver.

glxgears shows the gears again but it is flickering a lot... After
quitting it it shows the following message:

martin@deepdance:/usr/share/doc/xserver-xorg-video-savage -> glxgears
libGL error: drmMap of framebuffer failed (Invalid argument)
libGL error: reverting to (slow) indirect rendering
X connection to :0.0 broken (explicit kill or server shutdown).

I tried 6.5.0.cvs.20060524-1.1 of libgl1-mesa-dri, libgl1-mesa-glx,
libglu1-mesa and then I updated 6.5.1.

Scrolling in Konqueror, KMail, Firefox and other apps is quite slow.
Scrolling in Konsole is still fast. Scrolling was really fast with
version 2.0.2.3-4 of the driver

My xorg.conf Driver section:

Section "Device"
        Identifier      "Savage"
        Driver          "savage"
        BusID           "PCI:1:0:0"
        Option          "Accel" "True"
        # Acceleration
        Option          "AccelMethod" "exa"
        # Hardware-Cursor
        Option          "HWCursor" "True"
        # AGP: Should be able to do 4x
        Option          "AGPMode" "4"
        # Powermanagement: Don't know whether this works with the savage
        Option          "DynamicClocks" "True"
        # For AROS http://www.aros.org
        Option          "BackingStore" "True"
EndSection

I also tried without AccelMethod exa, without DynamicClocks and without
BackingStore - no change.

This is on an IBM ThinkPad T23 with

01:00.0 VGA compatible controller: S3 Inc. SuperSavage IX/C SDR (rev 05)

Regards,
Martin

-- System Information:
Debian Release: testing/unstable
  APT prefers testing
  APT policy: (990, 'testing'), (500, 'unstable'), (1, 'experimental')
Architecture: i386 (i686)
Shell:  /bin/sh linked to /bin/bash
Kernel: Linux 2.6.18-ck1-tp23-sws-2.2.8
Locale: LANG=de_DE@euro, LC_CTYPE=de_DE@euro (charmap=ISO-8859-15)

Versions of packages xserver-xorg-video-savage depends on:
ii  libc6                        2.3.6.ds1-4 GNU C Library: Shared libraries
ii  xserver-xorg-core            2:1.1.1-9   X.Org X server -- core server

xserver-xorg-video-savage recommends no packages.

-- no debconf information


Closing as suggested by the submitter a while ago since the problem was
fixed by not using EXA. Note that there are a couple EXA fixes pending
upstream, they should be in the next upload of this driver.

Brice