Bug#392764: Can't reproduce on PowerStack, MAC partition issue only?

classic Classic list List threaded Threaded
10 messages Options
Reply | Threaded
Open this post in threaded view
|

Bug#392764: Can't reproduce on PowerStack, MAC partition issue only?

Ulrich Teichert-2
Hi,

I tried to reproduce this bug on my Motorola PowerStack II (PPC prep),
but did not succeed. I've used the d-i daily build from 2007-01-19,
netinst iso and booted the netinst kernel over TFTP (yes, I know this
isn't supported, but my bandwith doesn't allow a full netinstall).

During manual partitioning, I created two RAID partitions:

ut@pleddis:~$ cat /proc/partitions
major minor  #blocks  name

   8     0    8891556 sda
   8     1      16033 sda1
   8     2     489982 sda2
   8     3    4184932 sda3
   8     4    4192965 sda4
   9     0    4184832 md0

Which is a brain-dead setup with only one disk and a RAID1 on two partitions:

ut@pleddis:~$ df -h
Filesystem            Size  Used Avail Use% Mounted on
/dev/md0              4.0G  390M  3.4G  11% /
tmpfs                  62M     0   62M   0% /lib/init/rw
udev                   10M   44K   10M   1% /dev
tmpfs                  62M     0   62M   0% /dev/shm

I haven't seen any failure, which suggests that the problem only shows up
on MAC partition types (the PowerStack uses PC-style partitions).

Sorry, but it looks like I don't have the hardware to track this down,

HTH anyway,
Uli
--
Dipl. Inf. Ulrich Teichert|e-mail: [hidden email]
Stormweg 24               |listening to: Single (Hushpuppies), Pay The Cobra
24539 Neumuenster, Germany|(The Bellrays), She's Got Standards (The Rifles)


--
To UNSUBSCRIBE, email to [hidden email]
with a subject of "unsubscribe". Trouble? Contact [hidden email]

Reply | Threaded
Open this post in threaded view
|

Bug#392764: Can't reproduce on PowerStack, MAC partition issue only?

Frans Pop-3
On Sunday 21 January 2007 19:58, Ulrich Teichert wrote:
> I haven't seen any failure, which suggests that the problem only shows
> up on MAC partition types (the PowerStack uses PC-style partitions).

That corresponds to Sven's findings.

> Sorry, but it looks like I don't have the hardware to track this down,

According to Sven, it should be possible to create a MAC partition table
for testing, even if an MSDOS table is normally used. I have no idea if
this is true or what risks that may bring.

If you want to give this a go, installing in expert mode will allow you to
select the type of partition table when you select a disk in partman.

> HTH anyway,

Yes, thanks for taking the trouble to look into this.

attachment0 (196 bytes) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Bug#392764: Can't reproduce on PowerStack, MAC partition issue only?

Sven Luther
In reply to this post by Ulrich Teichert-2
On Sun, Jan 21, 2007 at 07:58:47PM +0100, Ulrich Teichert wrote:

> Hi,
>
> I tried to reproduce this bug on my Motorola PowerStack II (PPC prep),
> but did not succeed. I've used the d-i daily build from 2007-01-19,
> netinst iso and booted the netinst kernel over TFTP (yes, I know this
> isn't supported, but my bandwith doesn't allow a full netinstall).
>
> During manual partitioning, I created two RAID partitions:
>
> ut@pleddis:~$ cat /proc/partitions
> major minor  #blocks  name
>
>    8     0    8891556 sda
>    8     1      16033 sda1
>    8     2     489982 sda2
>    8     3    4184932 sda3
>    8     4    4192965 sda4
>    9     0    4184832 md0
>
> Which is a brain-dead setup with only one disk and a RAID1 on two partitions:
>
> ut@pleddis:~$ df -h
> Filesystem            Size  Used Avail Use% Mounted on
> /dev/md0              4.0G  390M  3.4G  11% /
> tmpfs                  62M     0   62M   0% /lib/init/rw
> udev                   10M   44K   10M   1% /dev
> tmpfs                  62M     0   62M   0% /dev/shm
>
> I haven't seen any failure, which suggests that the problem only shows up
> on MAC partition types (the PowerStack uses PC-style partitions).
>
> Sorry, but it looks like I don't have the hardware to track this down,

yes, it is a mac partition table issue. There where actually two bugs, one
which i fixed, and was long fixed in ubuntu but the fix didn't go back to
debian until i investigated, and the other which is not in parted, but in
partman, and is still open.

It is possible to test this on any hardware, but you would need a second disk
if your firmware/bios is not able to boot from mac partition tables, like i
believe is the case for PReP boxes. This can also be tested on plain x86 boxes
with a second disk.

My believe is that since mac partitions used to not have the RAID flag, that
partman somewhere has some explicit test for x86 partitions, and sets the RAID
flag only in those cases, or something. I will try to reproduce his on pegasos
and its amiga partition tables, which are in the same case as the mac
partitions.

partman actually *ERASES* the raid flag set by hand by parted, which is rather
strange, and hints strongly at some problem in partman-md (but also possibly
mirrored in partman-lvm, which has a similar flag setup).

Friendly,

Sven Luther


--
To UNSUBSCRIBE, email to [hidden email]
with a subject of "unsubscribe". Trouble? Contact [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: PPC prep doing TFTP boot

Geert Stappers
In reply to this post by Ulrich Teichert-2
Op 21-01-2007 om 19:58 schreef Ulrich Teichert:
> Hi,
>
~ I tried to reproduce Bug #392764 on my Motorola PowerStack II (PPC prep),
> but did not succeed. I've used the d-i daily build from 2007-01-19,
> netinst iso and booted the netinst kernel over TFTP (yes, I know this
> isn't supported, but my bandwith doesn't allow a full netinstall).

I do read there:

  There is no netboot image for PPC prep,
  but the netinst kernel can be used for it.


At http://ftp.nl.debian.org/debian/dists/testing/main/installer-powerpc/rc1/images/powerpc/netboot/
is a initrd.gz and a vmlinux-initrd-chrp.gz.

What about adding a "prep initrd"?



Cheers
Geert Stappers


--
To UNSUBSCRIBE, email to [hidden email]
with a subject of "unsubscribe". Trouble? Contact [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: PPC prep doing TFTP boot

Geert Stappers
Op 22-01-2007 om 21:27 schreef Off-list-reply:

> On Mon, Jan 22, 2007 at 07:32:42PM +0100, Geert Stappers wrote:
> > Op 21-01-2007 om 19:58 schreef Ulrich Teichert:
> > > Hi,
> > >
> > ~ I tried to reproduce Bug #392764 on my Motorola PowerStack II (PPC prep),
> > > but did not succeed. I've used the d-i daily build from 2007-01-19,
> > > netinst iso and booted the netinst kernel over TFTP (yes, I know this
> > > isn't supported, but my bandwith doesn't allow a full netinstall).
> >
> > I do read there:
> >
> >   There is no netboot image for PPC prep,
> >   but the netinst kernel can be used for it.
> >
> >
> > At http://ftp.nl.debian.org/debian/dists/testing/main/installer-powerpc/rc1/images/powerpc/netboot/
> > is a initrd.gz and a vmlinux-initrd-chrp.gz.
> >
> > What about adding a "prep initrd"?
>
> I have no clue what you are asking.
>
> What Ulrich is doing, is netbooting the cdrom/vmlinux-initrd-chrp.gz and then do a
> cdrom install with it.


Euh, I'm also lost in all those PowerPC sub architectures ...


Seeing the chrp initrd being used on prep doesn't help neither.



The thing I'm trying to say is that having initrds named with a matching title.

So an initrd-prep for prep and  initrd-chrp for chrp
or an initrd-chrp-prep if it can be use for bot sub archs.


Cheers
Geert Stappers


--
To UNSUBSCRIBE, email to [hidden email]
with a subject of "unsubscribe". Trouble? Contact [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: PPC prep doing TFTP boot

Ulrich Teichert-2
Hi,

[sorry for not writing this yesterday, but we had a release today, so I
came home rather....late....]

>Op 22-01-2007 om 21:27 schreef Off-list-reply:
>> On Mon, Jan 22, 2007 at 07:32:42PM +0100, Geert Stappers wrote:
>> > Op 21-01-2007 om 19:58 schreef Ulrich Teichert:
>> > > Hi,
>> > >
>> > ~ I tried to reproduce Bug #392764 on my Motorola PowerStack II (PPC prep),
>> > > but did not succeed. I've used the d-i daily build from 2007-01-19,
>> > > netinst iso and booted the netinst kernel over TFTP (yes, I know this
>> > > isn't supported, but my bandwith doesn't allow a full netinstall).
>> >
>> > I do read there:
>> >
>> >   There is no netboot image for PPC prep,
>> >   but the netinst kernel can be used for it.

Somewhat, yes. But booting the supplied initrd-image on the netinst iso (or
on a full CD set for that matter) over TFTP is my favourite install type if
CD-ROM booting does not work or I have no CD-ROM ready or I'm too lazy ;-)

I believe there are offical netboot images for PReP somewhere as well.

>> > At http://ftp.nl.debian.org/debian/dists/testing/main/installer-powerpc/rc1/images/powerpc/netboot/
>> > is a initrd.gz and a vmlinux-initrd-chrp.gz.
>> >
>> > What about adding a "prep initrd"?
>>
>> I have no clue what you are asking.
>>
>> What Ulrich is doing, is netbooting the cdrom/vmlinux-initrd-chrp.gz and then do a
>> cdrom install with it.

Almost, but I'm using vmlinuz-prep.initrd on the PowerStack.


>Euh, I'm also lost in all those PowerPC sub architectures ...
>Seeing the chrp initrd being used on prep doesn't help neither.

Not the case, don't worry.

>The thing I'm trying to say is that having initrds named with a matching title.
>
>So an initrd-prep for prep and  initrd-chrp for chrp

Yes, that's how it's now.

>or an initrd-chrp-prep if it can be use for bot sub archs.

Gee, I don't think so. I can't even boot other PReP boxes as my PowerStack
with the PReP image, but I would be very happy if that would be possible,

CU,
Uli
--
Dipl. Inf. Ulrich Teichert|e-mail: [hidden email]
Stormweg 24               |listening to: Single (Hushpuppies), Pay The Cobra
24539 Neumuenster, Germany|(The Bellrays), She's Got Standards (The Rifles)


--
To UNSUBSCRIBE, email to [hidden email]
with a subject of "unsubscribe". Trouble? Contact [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: PPC prep doing TFTP boot

Geert Stappers
Op 23-01-2007 om 23:04 schreef Ulrich Teichert:
> >Op 22-01-2007 om 21:27 schreef Off-list-reply:
> >> On Mon, Jan 22, 2007 at 07:32:42PM +0100, Geert Stappers wrote:
>
> I believe there are offical netboot images for PReP somewhere as well.

Where?

> >> > At http://ftp.nl.debian.org/debian/dists/testing/main/installer-powerpc/rc1/images/powerpc/netboot/
> >> > is a initrd.gz and a vmlinux-initrd-chrp.gz.
> >> >
> >> > What about adding a "prep initrd"?
> >>
> >> I have no clue what you are asking.
> >>
> >> What Ulrich is doing, is netbooting the cdrom/vmlinux-initrd-chrp.gz and then do a
> >> cdrom install with it.
>
> Almost, but I'm using vmlinuz-prep.initrd on the PowerStack.
>
>
> >Euh, I'm also lost in all those PowerPC sub architectures ...
> >Seeing the chrp initrd being used on prep doesn't help neither.
>
> Not the case, don't worry.
>
> >The thing I'm trying to say is that having initrds named with a matching title.
> >
> >So an initrd-prep for prep and  initrd-chrp for chrp
>
> Yes, that's how it's now.
>

http://ftp.de.debian.org/debian/dists/testing/main/installer-powerpc/rc1/images/powerpc/netboot/
has neither a prep initrd.


GSt


--
To UNSUBSCRIBE, email to [hidden email]
with a subject of "unsubscribe". Trouble? Contact [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: PPC prep doing TFTP boot

Ulrich Teichert-2
Hi,

>> I believe there are offical netboot images for PReP somewhere as well.
>
>Where?

http://people.debian.org/~wouter/d-i/powerpc/daily/prep/netboot/

I'm not sure if that are offical images, though.

[del]
>http://ftp.de.debian.org/debian/dists/testing/main/installer-powerpc/rc1/images/powerpc/netboot/
>has neither a prep initrd.

AFAIK, they got added after RC1,

HTH,
Uli
--
Dipl. Inf. Ulrich Teichert|e-mail: [hidden email]
Stormweg 24               |listening to: Single (Hushpuppies), Pay The Cobra
24539 Neumuenster, Germany|(The Bellrays), She's Got Standards (The Rifles)


--
To UNSUBSCRIBE, email to [hidden email]
with a subject of "unsubscribe". Trouble? Contact [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: PPC prep doing TFTP boot

Frans Pop-3
On Wednesday 31 January 2007 20:41, Ulrich Teichert wrote:
> http://people.debian.org/~wouter/d-i/powerpc/daily/prep/netboot/
>
> I'm not sure if that are offical images, though.

Yes, they are.

> >http://ftp.de.debian.org/debian/dists/testing/main/installer-powerpc/r
> >c1/images/powerpc/netboot/ has neither a prep initrd.
>
> AFAIK, they got added after RC1,

Correct, because prep was only enabled again in the 2.6.18 kernel images.

attachment0 (196 bytes) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: PPC prep doing TFTP boot

Geert Stappers
Op 31-01-2007 om 22:11 schreef Frans Pop:

> On Wednesday 31 January 2007 20:41, Ulrich Teichert wrote:
> > http://people.debian.org/~wouter/d-i/powerpc/daily/prep/netboot/
> >
> > I'm not sure if that are offical images, though.
>
> Yes, they are.
>
> > >http://ftp.de.debian.org/debian/dists/testing/main/installer-powerpc/r
> > >c1/images/powerpc/netboot/ has neither a prep initrd.
> >
> > AFAIK, they got added after RC1,
>
> Correct, because prep was only enabled again in the 2.6.18 kernel images.

TNx
GSt


--
To UNSUBSCRIBE, email to [hidden email]
with a subject of "unsubscribe". Trouble? Contact [hidden email]