Bug#513826: kaddressbook: weird dependecies

classic Classic list List threaded Threaded
11 messages Options
Reply | Threaded
Open this post in threaded view
|

Bug#513826: kaddressbook: weird dependecies

Salvo Tomaselli-3
Package: kaddressbook
Version: 4:4.2.0-1
Severity: important

doing aptitude -t experimental install kaddressbook it says that i should install exim... mysql-server...
Aren't those dependencies a bit exagerated for a simple address book?


-- System Information:
Debian Release: 5.0
  APT prefers unstable
  APT policy: (500, 'unstable'), (500, 'testing'), (500, 'stable'), (101, 'experimental')
Architecture: i386 (i686)

Kernel: Linux 2.6.27-6.slh.5-sidux-686 (SMP w/2 CPU cores; PREEMPT)
Locale: LANG=it_IT.UTF-8, LC_CTYPE=it_IT.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/bash

Versions of packages kaddressbook depends on:
ii  kdebase-runtime               4:4.2.0-1  runtime components from the offici
ii  kdelibs5                      4:4.2.0-3  core libraries for all KDE 4 appli
ii  kdepimlibs5                   4:4.2.0-1  core libraries for KDE PIM 4 appli
ii  libc6                         2.7-18     GNU C Library: Shared libraries
pn  libgnokii3                    <none>     (no description available)
pn  libkabcommon4                 <none>     (no description available)
ii  libkdepim4                    4:4.2.0-1  KDE PIM library
ii  libkleo4                      4:4.2.0-1  certificate based crypto library f
ii  libkontactinterfaces4         4:4.2.0-1  KDE Kontact interface library
ii  libphonon4                    4:4.3.0-1  Phonon multimedia framework for Qt
ii  libqt4-dbus                   4.4.3-2    Qt 4 D-Bus module
ii  libqt4-qt3support             4.4.3-2    Qt 3 compatibility library for Qt
ii  libqt4-xml                    4.4.3-2    Qt 4 XML module
ii  libqtcore4                    4.4.3-2    Qt 4 core module
ii  libqtgui4                     4.4.3-2    Qt 4 GUI module
ii  libstdc++6                    4.3.3-3    The GNU Standard C++ Library v3
ii  phonon                        4:4.3.0-1  metapackage for Phonon multimedia

kaddressbook recommends no packages.

Versions of packages kaddressbook suggests:
pn  kdepim-kresources             <none>     (no description available)



--
To UNSUBSCRIBE, email to [hidden email]
with a subject of "unsubscribe". Trouble? Contact [hidden email]

Reply | Threaded
Open this post in threaded view
|

Bug#513826: kaddressbook: weird dependecies

xavier.vello (Bugzilla)
severity 513826 minor
thanks

> doing aptitude -t experimental install kaddressbook it says that i should
> install exim... mysql-server... Aren't those dependencies a bit exagerated
> for a simple address book?

kaddressbook 4.2 is based on akonadi, which uses a mysql database as cache.
That is compulsory.
As for the exim dep, I can't find any. Please provide more info, for instance
the output of `aptitude why kaddressbook exim` (please note that suggests are
not installed automatically)

Regards
--
Xavier Vello



--
To UNSUBSCRIBE, email to [hidden email]
with a subject of "unsubscribe". Trouble? Contact [hidden email]

Reply | Threaded
Open this post in threaded view
|

Processed: Re: Bug#513826: kaddressbook: weird dependecies

Debian Bug Tracking System
Processing commands for [hidden email]:

> severity 513826 minor
Bug#513826: kaddressbook: weird dependecies
Severity set to `minor' from `important'

> thanks
Stopping processing here.

Please contact me if you need assistance.

Debian bug tracking system administrator
(administrator, Debian Bugs database)


--
To UNSUBSCRIBE, email to [hidden email]
with a subject of "unsubscribe". Trouble? Contact [hidden email]

Reply | Threaded
Open this post in threaded view
|

Bug#513826: kaddressbook: weird dependecies

Kevin Krammer
In reply to this post by xavier.vello (Bugzilla)
On Sunday 01 February 2009, Xavier Vello wrote:

> kaddressbook 4.2 is based on akonadi, which uses a mysql database as cache.

Actually the first part is not true.
The plan is to port KAddressBook and KOrganizer to Akonadi in KDE 4.3
(actually KAddressBook will most likely be replaced by a new application)

The KResource plugins for Akonadi in kdepim-kresources depend on Akonadi, the
applications don't.

Cheers,
Kevin


signature.asc (196 bytes) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Bug#513826: kaddressbook: weird dependecies

Salvo Tomaselli-3
In reply to this post by xavier.vello (Bugzilla)
On domenica 1 febbraio 2009 16:52:55 you wrote:
> As for the exim dep, I can't find any. Please provide more info, for
> instance the output of `aptitude why kaddressbook exim` (please note that
> suggests are not installed automatically)

# aptitude why kaddressbook exim
i   kaddressbook        Consiglia kdebase-kio-plugins
i A kdebase-kio-plugins Dipende   man-db (>= 2.5.1-1)
i   man-db              Dipende   dpkg (>= 1.9.0)
i   dpkg                Consiglia apt
i A apt                 Consiglia aptitude | synaptic | gnome-apt | wajig
p   wajig               Consiglia reportbug
i   reportbug           Consiglia postfix | exim4 | mail-transport-agent
p   exim                Fornisce  mail-transport-agent



Trying to install:
# aptitude -t experimental install kaddressbook                                                                    
Lettura della lista dei pacchetti in corso... Fatto
Generazione dell'albero delle dipendenze in corso
Lettura informazioni sullo stato... Fatto
Lettura delle informazioni sullo stato esteso
Inizializzazione dello stato dei pacchetti... Fatto
I seguenti pacchetti sono DIFETTOSI:
  libgnokii3
I seguenti pacchetti NUOVI (NEW) saranno installati:
  akonadi-server{a} bsd-mailx{a} exim4{a} exim4-base{a} exim4-config{a} exim4-
daemon-light{a} libdbd-mysql-perl{a} libdbi-perl{a} libkabcommon4{a}
  libmysqlclient16{a} libnet-daemon-perl{a} libplrpc-perl{a} libqt4-sql-
mysql{a} mailx{a} mysql-client-5.1{a} mysql-server{a} mysql-server-5.1{a}
I seguenti pacchetti saranno RIMOSSI:
  libkcal2b{u} libkdepim1a{u} libkleopatra1{u} libktnef1{u}
I seguenti pacchetti saranno aggiornati:
  kaddressbook mysql-common
2 pacchetti aggiornati, 18 installati, 4 da rimuovere e 181 non aggiornati.
È necessario prelevare 25,8MB di archivi. Dopo l'estrazione, verranno occupati
49,0MB.
I seguenti pacchetti hanno dipendenze non soddisfatte:
  libgnokii3: Dipende: gnokii-common (= 0.6.26.dfsg-3) ma non è installabile
Le seguenti azioni permetteranno di soddisfare queste dipendenze:

Installare i seguenti pacchetti:
gnokii-common [0.6.26.dfsg-3 (unstable, testing, now)]

Il punteggio è 21

Accettare questa soluzione? [Y/n/q/?]
I seguenti pacchetti NUOVI (NEW) saranno installati:
  akonadi-server{a} bsd-mailx{a} exim4{a} exim4-base{a} exim4-config{a} exim4-
daemon-light{a} gnokii-common{a} libdbd-mysql-perl{a} libdbi-perl{a}
  libgnokii3{a} libkabcommon4{a} libmysqlclient16{a} libnet-daemon-perl{a}
libplrpc-perl{a} libqt4-sql-mysql{a} mailx{a} mysql-client-5.1{a}
  mysql-server{a} mysql-server-5.1{a}
I seguenti pacchetti saranno RIMOSSI:
  libkcal2b{u} libkdepim1a{u} libkleopatra1{u} libktnef1{u}
I seguenti pacchetti saranno aggiornati:
  kaddressbook mysql-common
2 pacchetti aggiornati, 19 installati, 4 da rimuovere e 181 non aggiornati.
È necessario prelevare 26,0MB di archivi. Dopo l'estrazione, verranno occupati
49,4MB.

--
Salvo



--
To UNSUBSCRIBE, email to [hidden email]
with a subject of "unsubscribe". Trouble? Contact [hidden email]

Reply | Threaded
Open this post in threaded view
|

Bug#513826: kaddressbook: weird dependecies

xavier.vello (Bugzilla)
Le dimanche 01 février 2009 21:53:13, LtWorf a écrit :
> On domenica 1 febbraio 2009 16:52:55 you wrote:
> > As for the exim dep, I can't find any. Please provide more info, for
> > instance the output of `aptitude why kaddressbook exim` (please note that
> > suggests are not installed automatically)

I found the dependancy chain :

akonadi-server -> mysql-server-5.0 -> mailx -> bsd-mailx -> exim4 | mail-
transport-agent

You can install an alternative to exim providing the "mail-transport-agent"
virtual package, like ssmtp or nullmailer

--
Xavier Vello

signature.asc (204 bytes) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Bug#513826: kaddressbook: weird dependecies

Salvo Tomaselli-3
On domenica 1 febbraio 2009 22:47:41 you wrote:

> Le dimanche 01 février 2009 21:53:13, LtWorf a écrit :
> > On domenica 1 febbraio 2009 16:52:55 you wrote:
> > > As for the exim dep, I can't find any. Please provide more info, for
> > > instance the output of `aptitude why kaddressbook exim` (please note
> > > that suggests are not installed automatically)
>
> I found the dependancy chain :
>
> akonadi-server -> mysql-server-5.0 -> mailx -> bsd-mailx -> exim4 | mail-
> transport-agent

But i don't want the mysqlserver either! I mean... i've installed kaddressbook
on another computer, where i have mysql-server and postfix. Nothing asked me
to configure the access to a database, so i bet there is no access to
database.
--
Salvo



--
To UNSUBSCRIBE, email to [hidden email]
with a subject of "unsubscribe". Trouble? Contact [hidden email]

Reply | Threaded
Open this post in threaded view
|

Bug#513826: marked as done (kaddressbook: weird dependecies)

Debian Bug Tracking System
In reply to this post by Salvo Tomaselli-3

Your message dated Mon, 2 Feb 2009 10:37:59 +0100
with message-id <[hidden email]>
and subject line Re: Bug#513826: kaddressbook: weird dependecies
has caused the Debian Bug report #513826,
regarding kaddressbook: weird dependecies
to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
Bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what this
message is talking about, this may indicate a serious mail system
misconfiguration somewhere. Please contact [hidden email]
immediately.)


--
513826: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=513826
Debian Bug Tracking System
Contact [hidden email] with problems

Package: kaddressbook
Version: 4:4.2.0-1
Severity: important

doing aptitude -t experimental install kaddressbook it says that i should install exim... mysql-server...
Aren't those dependencies a bit exagerated for a simple address book?


-- System Information:
Debian Release: 5.0
  APT prefers unstable
  APT policy: (500, 'unstable'), (500, 'testing'), (500, 'stable'), (101, 'experimental')
Architecture: i386 (i686)

Kernel: Linux 2.6.27-6.slh.5-sidux-686 (SMP w/2 CPU cores; PREEMPT)
Locale: LANG=it_IT.UTF-8, LC_CTYPE=it_IT.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/bash

Versions of packages kaddressbook depends on:
ii  kdebase-runtime               4:4.2.0-1  runtime components from the offici
ii  kdelibs5                      4:4.2.0-3  core libraries for all KDE 4 appli
ii  kdepimlibs5                   4:4.2.0-1  core libraries for KDE PIM 4 appli
ii  libc6                         2.7-18     GNU C Library: Shared libraries
pn  libgnokii3                    <none>     (no description available)
pn  libkabcommon4                 <none>     (no description available)
ii  libkdepim4                    4:4.2.0-1  KDE PIM library
ii  libkleo4                      4:4.2.0-1  certificate based crypto library f
ii  libkontactinterfaces4         4:4.2.0-1  KDE Kontact interface library
ii  libphonon4                    4:4.3.0-1  Phonon multimedia framework for Qt
ii  libqt4-dbus                   4.4.3-2    Qt 4 D-Bus module
ii  libqt4-qt3support             4.4.3-2    Qt 3 compatibility library for Qt
ii  libqt4-xml                    4.4.3-2    Qt 4 XML module
ii  libqtcore4                    4.4.3-2    Qt 4 core module
ii  libqtgui4                     4.4.3-2    Qt 4 GUI module
ii  libstdc++6                    4.3.3-3    The GNU Standard C++ Library v3
ii  phonon                        4:4.3.0-1  metapackage for Phonon multimedia

kaddressbook recommends no packages.

Versions of packages kaddressbook suggests:
pn  kdepim-kresources             <none>     (no description available)



> But i don't want the mysqlserver either! I mean... i've installed
> kaddressbook on another computer, where i have mysql-server and postfix.
> Nothing asked me to configure the access to a database, so i bet there is
> no access to database.

Please carefully read http://techbase.kde.org/Projects/PIM/Akonadi#Akonadi_FAQ

There is nothing Debian can do about it, closing the bug.

Regards.
--
Xavier Vello

signature.asc (204 bytes) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Bug#513826: kaddressbook: weird dependecies

Kevin Krammer
In reply to this post by Salvo Tomaselli-3
On Monday 02 February 2009, LtWorf wrote:

> But i don't want the mysqlserver either! I mean... i've installed
> kaddressbook on another computer, where i have mysql-server and postfix.
> Nothing asked me to configure the access to a database, so i bet there is
> no access to database.

The conclusion is only partly correct.
It is not accessing your systemwide mysql database, but it is accessing its
own.

Cheers,
Kevin

signature.asc (196 bytes) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Bug#513826: kaddressbook: weird dependecies

Salvo Tomaselli-3
In reply to this post by Salvo Tomaselli-3
On Monday 02 February 2009 10:37:59 you wrote:
> > But i don't want the mysqlserver either! I mean... i've installed
> > kaddressbook on another computer, where i have mysql-server and postfix.
> > Nothing asked me to configure the access to a database, so i bet there is
> > no access to database.
>
> Please carefully read
> http://techbase.kde.org/Projects/PIM/Akonadi#Akonadi_FAQ
>
> There is nothing Debian can do about it, closing the bug.

Well... I can install kaddressbook from experimental and have the same
contacts i have in kde3 (soft link .kde4 points to .kde). Then i can install
back the unstable version and i see the modifications i did. So the new one is
using exactly the same system of the old one. And that means that no
mysqlblablabla is needed.
Can't you just patch it to ignore mysql since it isn't really needed?

Thanks.
--
Salvo



--
To UNSUBSCRIBE, email to [hidden email]
with a subject of "unsubscribe". Trouble? Contact [hidden email]

Reply | Threaded
Open this post in threaded view
|

Bug#513826: kaddressbook: weird dependecies

Kevin Krammer
On Monday 02 February 2009, LtWorf wrote:

> On Monday 02 February 2009 10:37:59 you wrote:
> > > But i don't want the mysqlserver either! I mean... i've installed
> > > kaddressbook on another computer, where i have mysql-server and
> > > postfix. Nothing asked me to configure the access to a database, so i
> > > bet there is no access to database.
> >
> > Please carefully read
> > http://techbase.kde.org/Projects/PIM/Akonadi#Akonadi_FAQ
> >
> > There is nothing Debian can do about it, closing the bug.
>
> Well... I can install kaddressbook from experimental and have the same
> contacts i have in kde3 (soft link .kde4 points to .kde). Then i can
> install back the unstable version and i see the modifications i did. So the
> new one is using exactly the same system of the old one. And that means
> that no mysqlblablabla is needed.
If the traditional resource framework for contacts is not explicitly
configured to go through Akonadi rather than directly accessing the file,
then it won't.

This particular action of the automated migration was deactivated for the KDE
4.2 release, it had been enabled in betas and the RC though.

Independent of that, even a fully Akonadi enabled setup, i.e. even with
applications directly accessing Akonadi instead of using just another plugin,
would obviously still affect the files the data is stored in. After all one
would be rather surprised to have an address book file, make changes and not
see those changes in the file.

> Can't you just patch it to ignore mysql since it isn't really needed?

Well, mysqld or rather any database engine implementation fulfilling the
requirements, is needed by the Akonadi server.

At the moment, i.e. for the 4.2. period, the Debian packagers could decide to
have only those packages depend on akonadi-server which actually work with
it, e.g. the Akonadi resource plugins (most likely in kdepim-kresources), the
Akonadi agents and resources and KPilot.

My guess is that the direct dependency is at the application packages in order
not to have to change dependencies for 4.3

Cheers,
Kevin





signature.asc (196 bytes) Download Attachment