Bug#515094: Vim::Repo and Atom can't be loaded

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

Bug#515094: Vim::Repo and Atom can't be loaded

Dmitry Borodaenko-3
Package: vpim
Version: 0.658-1
Severity: normal

irb(main):001:0> require 'vpim/repo'
LoadError: no such file to load -- plist/generator
        from /usr/lib/ruby/1.8/plist.rb:17:in `require'
        from /usr/lib/ruby/1.8/plist.rb:17
        from /usr/lib/ruby/1.8/vpim/repo.rb:11:in `require'
        from /usr/lib/ruby/1.8/vpim/repo.rb:11
        from (irb):1:in `require'
        from (irb):1

irb(main):001:0> require 'atom'
LoadError: no such file to load -- xml/libxml
        from /usr/lib/ruby/1.8/rubygems/custom_require.rb:27:in `gem_original_require'
        from /usr/lib/ruby/1.8/rubygems/custom_require.rb:27:in `require'
        from /usr/lib/ruby/1.8/atom.rb:30
        from (irb):1:in `require'
        from (irb):1
        from /usr/lib/ruby/1.8/i486-linux/thread.so:0

Looks like plist.rb and atom.rb were copied from other libraries without
their associated files. Atom isn't used anywere in Vpim and can be
safely removed from the binary package, but Plist is used by Vpim::Repo.


-- System Information:
Debian Release: 5.0
  APT prefers unstable
  APT policy: (990, 'unstable'), (70, 'testing'), (50, 'stable'), (1, 'experimental')
Architecture: i386 (i686)

Kernel: Linux 2.6.26-1-686 (SMP w/1 CPU core)
Locale: LANG=be_BY.UTF-8, LC_CTYPE=be_BY.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/bash

Versions of packages vpim depends on:
ii  ruby                          4.2        An interpreter of object-oriented
ii  ruby1.8                       1.8.7.72-3 Interpreter of object-oriented scr

vpim recommends no packages.

vpim suggests no packages.

-- no debconf information



--
To UNSUBSCRIBE, email to [hidden email]
with a subject of "unsubscribe". Trouble? Contact [hidden email]

Reply | Threaded
Open this post in threaded view
|

Bug#515094: Vim::Repo and Atom can't be loaded

Joey Schulze
Dmitry Borodaenko wrote:

> Package: vpim
> Version: 0.658-1
> Severity: normal
>
> irb(main):001:0> require 'vpim/repo'
> LoadError: no such file to load -- plist/generator
>         from /usr/lib/ruby/1.8/plist.rb:17:in `require'
>         from /usr/lib/ruby/1.8/plist.rb:17
>         from /usr/lib/ruby/1.8/vpim/repo.rb:11:in `require'
>         from /usr/lib/ruby/1.8/vpim/repo.rb:11
>         from (irb):1:in `require'
>         from (irb):1
>
> irb(main):001:0> require 'atom'
> LoadError: no such file to load -- xml/libxml
>         from /usr/lib/ruby/1.8/rubygems/custom_require.rb:27:in `gem_original_require'
>         from /usr/lib/ruby/1.8/rubygems/custom_require.rb:27:in `require'
>         from /usr/lib/ruby/1.8/atom.rb:30
>         from (irb):1:in `require'
>         from (irb):1
>         from /usr/lib/ruby/1.8/i486-linux/thread.so:0
>
> Looks like plist.rb and atom.rb were copied from other libraries without
> their associated files. Atom isn't used anywere in Vpim and can be
> safely removed from the binary package, but Plist is used by Vpim::Repo.

I'll remove those files and require the plist from facter.  I'll add a
Suggests entry as well.

Regards,

        Joey

--
It's practically impossible to look at a penguin and feel angry.

Please always Cc to me when replying to me on the lists.



--
To UNSUBSCRIBE, email to [hidden email]
with a subject of "unsubscribe". Trouble? Contact [hidden email]