Bug#518409: gv resources incompatible

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

Bug#518409: gv resources incompatible

Joey Schulze
Package: gv
Version: 3.6.5-2

Hi,

I would like to add some larger page sizes to the GV menus but
currently fail because GV thinks the config file belongs to an
older version.

My problem is that copying the current system configuration
also results in the same error messages.

$ cp /usr/share/gv/gv_system.ad ~/.Xresources/GV

$ gv
gv Error: incompatible resources.
One of the files
    /usr/share/gv/gv_system.ad
    /home/joey/.Xresources/GV
belongs to an older version of gv and can not be used.
Please remove or update the outdated file.
Quite probable your ~/.gv is too old.
Running gv-update-userconfig should help
by removing all incomatible resources.

The same happens for another config file:

$ cp /usr/share/gv/gv_system.ad ~/.gv

Older versions of gv understood such files.
It would be nice if they would do so again.

Regards,

        Joey

--
Life is too short to run proprietary software.  -- Bdale Garbee

Please always Cc to me when replying to me on the lists.



--
To UNSUBSCRIBE, email to [hidden email]
with a subject of "unsubscribe". Trouble? Contact [hidden email]

Reply | Threaded
Open this post in threaded view
|

Bug#518409: gv resources incompatible

Markus Steinborn-2
Joey Schulze wrote:
> It would be nice if they would do so again.
>  
You can do that quite easily: Add a line

GV.version: 3.6.5

to your file "~/.Xresources/GV" resp. "~/.gv".

(Yes, I know: gv-update-userconfig would have inserted "3.6.4.91" as
version number, but when editing the files by hand, you can use the real
version number without problems. )

With this versioned resources, we are able to check if we had a change
of resources between the resources the user has installed and the
version of GNU gv being executed.

It remains the misleading error message which has been fixed in GNU gv
3.6.7.

IMHO we should leave this bug open, because the real bug is a lack of
documentation. Adding the single "GV.version"-line isn't a problem if
the user knows that he should do that.


Greetings from Germany

Markus Steinborn
GNU gv upstream maintainer





--
To UNSUBSCRIBE, email to [hidden email]
with a subject of "unsubscribe". Trouble? Contact [hidden email]