Bug#566272: shares-admin fails to start: Error loading UI

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

Bug#566272: shares-admin fails to start: Error loading UI

Dr. Oliver Muth-2
Package: gnome-system-tools
Version: 2.22.0-3
Severity: normal

shares-admin does not start and yields  the following error message:
** (shares-admin:7155): CRITICAL **: Error loading UI: Duplicate object id 'label' on line 144 (previously on line 97)

The line numbers probably refer to one of the backend scripts - but I could not find out which nor why it would fail.

Best regards

Oliver
-- System Information:
Debian Release: 5.0.3
  APT prefers stable
  APT policy: (500, 'stable')
Architecture: i386 (i686)

Kernel: Linux 2.6.32-k7-100118 (SMP w/1 CPU core; PREEMPT)
Locale: LANG=de_DE.UTF-8, LC_CTYPE=de_DE.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/bash

Versions of packages gnome-system-tools depends on:
ii  gconf2                  2.22.0-1         GNOME configuration database syste
ii  gksu                    2.0.0-8          graphical frontend to su
ii  libatk1.0-0             1.22.0-1         The ATK accessibility toolkit
ii  libc6                   2.7-18           GNU C Library: Shared libraries
ii  libcairo2               1.6.4-7          The Cairo 2D vector graphics libra
ii  libdbus-1-3             1.2.1-5+lenny1   simple interprocess messaging syst
ii  libgconf2-4             2.22.0-1         GNOME configuration database syste
ii  libglib2.0-0            2.22.2-2~bpo50+1 The GLib library of C routines
ii  libgnomevfs2-0          1:2.22.0-5       GNOME Virtual File System (runtime
ii  libgtk2.0-0             2.18.3-1~bpo50+1 The GTK+ graphical user interface
ii  libnautilus-extension1  2.20.0-7         libraries for nautilus components
ii  liboobs-1-4             2.22.0-2         GObject based interface to system-
ii  libpango1.0-0           1.20.5-5         Layout and rendering of internatio
ii  perl                    5.10.0-19lenny2  Larry Wall's Practical Extraction
ii  system-tools-backends   2.6.0-2lenny3    System Tools to manage computer co

Versions of packages gnome-system-tools recommends:
ii  gnome-control-center        1:2.22.2.1-2 utilities to configure the GNOME d

Versions of packages gnome-system-tools suggests:
ii  ntp               1:4.2.4p4+dfsg-8lenny3 Network Time Protocol daemon and u
ii  samba-common      2:3.2.5-4lenny7        Samba common files used by both th
pn  wvdial            <none>                 (no description available)

-- no debconf information



--
To UNSUBSCRIBE, email to [hidden email]
with a subject of "unsubscribe". Trouble? Contact [hidden email]

Reply | Threaded
Open this post in threaded view
|

Bug#566272: shares-admin fails to start: Error loading UI

Josselin Mouette
Le vendredi 22 janvier 2010 à 17:02 +0100, Dr. Oliver Muth a écrit :
> shares-admin does not start and yields  the following error message:
> ** (shares-admin:7155): CRITICAL **: Error loading UI: Duplicate
> object id 'label' on line 144 (previously on line 97)
>
> The line numbers probably refer to one of the backend scripts - but I
> could not find out which nor why it would fail.

It is a duplicate identifier in the .ui file, and it causes a crash
because of the following upgrade:

> ii  libgtk2.0-0             2.18.3-1~bpo50+1 The GTK+ graphical user interface

I guess we could do a stable upgrade to fix that, but I consider it of
low priority.

Cheers,
--
 .''`.      Josselin Mouette
: :' :
`. `'   “I recommend you to learn English in hope that you in
  `-     future understand things”  -- Jörg Schilling


signature.asc (196 bytes) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Bug#566272: shares-admin fails to start: Error loading UI

Dr. Oliver Muth-2
Bonjour Josselin,

Merci beaucoup for the quick response and for pointing me to the right file (I was looking in the backends directory).

> > ii  libgtk2.0-0             2.18.3-1~bpo50+1 The GTK+ graphical user
> interface
I think this was pulled in by building nvidia-settings and the new nvidia-driver 190.43, which was required by the 2.6.32 kernel that I am forced to use. Once you start upgrading _one_ package...

> I guess we could do a stable upgrade to fix that, but I consider it of
> low priority.
I just changed the second defintion of "label" into "label2". That fixes it.
(I should probably build a new local package...)

But you are right: low priority, as I am probably the one in a million who has this issue due to a newer kernel and a backported package.

Salut

Oliver
--
Jetzt kostenlos herunterladen: Internet Explorer 8 und Mozilla Firefox 3.5 -
sicherer, schneller und einfacher! http://portal.gmx.net/de/go/atbrowser



--
To UNSUBSCRIBE, email to [hidden email]
with a subject of "unsubscribe". Trouble? Contact [hidden email]