Bug#627833: gramps crashes while trying to add the first person

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

Bug#627833: gramps crashes while trying to add the first person

Ross Gammon
-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

tag 627833 +patch
thanks

Hi,

As Version 3.4.6 of Gramps may not be packaged for Debian for some
time, I have created a patch for v3.4.0 from the latest upstream that
forces a UTF-8 locale to be used if available.

It is done as an NMU, and requires a sponsor to upload it.

Regards,

Ross
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.12 (GNU/Linux)
Comment: Using GnuPG with undefined - http://www.enigmail.net/

iQIcBAEBAgAGBQJSJOV+AAoJEFP+e72miRD8iHYP/RjS06pfW3pzE28pWenzDi0G
zdqcmASS83WLzmU5cy5t9pLvzMK88xH9J3Lw8KI1trHcYvdRqbu/alnOW8zPDoTD
gI6NV4m6b98XB4DfIYvaVKfs2gDQees7btF6OIAi0tJNhDnQVqTBwIuSc4c8o3Ju
dQHt1aX3JbPmui3nATKYXE4nPMmr2AW37pO8oyP+zez1+PsqqS8ACnUzPh6+UomD
C/Q3nprfFIkpgpk1lqykoBzL4qJEKnFfETYU7zuX4PSnMJNN+oIWcmGaULESPAtv
QB2VqydyuM+RyXDEEcWv8Cba4r6pBnTTVmPC4wn+P6YEcBm9hG5a4sawUZ+BYTt/
ufGimMilxrMpZkQoXND4eAFGxd1ezVSn7hiI5MoPloMzgBdOhs9z5RqE3POTo+ek
35WZYYhIxs2Fk7GaT4MEVhh4kqu61B7ydxChAvfoP5s8dUJ+oNr4MrAw5jWOYcwz
1IrONmp9hqwlTvkeqy+flB/i21In8PqK8mX0tZVwnPtX+olFE2amku4ZzQh+SjDa
J8+XFSVFYVuuInV9LDddQHrIGmQJa8gG9K8g27DRJ6G5IVY+6YhavmsmnKLX2RQN
MmIPON/Pvhsus0ABpZ97qsLpiLWpiB7wfEYWHlU3PZvS7ewRZZM+IpF8c4pTPypN
KEtOh9g0Mw2jINX6DBHh
=RvJd
-----END PGP SIGNATURE-----

gramps-debdiff (4K) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Bug#627833: gramps crashes while trying to add the first person

Juergen Kosel
-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Sorry,


Am 02.09.2013 21:22, schrieb Ross Gammon:
> tag 627833 +patch thanks
>
> Hi,
>
> As Version 3.4.6 of Gramps may not be packaged for Debian for some
> time, I have created a patch for v3.4.0 from the latest upstream
> that forces a UTF-8 locale to be used if available.
>
> It is done as an NMU, and requires a sponsor to upload it.

but I have no up to date description how to build a debian package:
The Debian Reference (version 1, 26 Jan 2008) says in section 13.10.1:
Use dpkg-deb -b <package>. But this seems to be totally outdated.
And dpkg-buildpackage also doesn't seem to work...


Greetings
        Juergen
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.12 (GNU/Linux)
Comment: Using GnuPG with Icedove - http://www.enigmail.net/

iD8DBQFSLfyH5JgLPmj5988RApWEAKC0RDjLhNO5FqMI7RNEkhOXmnIIoQCfXypM
LR9Em0hicilPWJxpgnA9VAs=
=VMRp
-----END PGP SIGNATURE-----


--
To UNSUBSCRIBE, email to [hidden email]
with a subject of "unsubscribe". Trouble? Contact [hidden email]

Reply | Threaded
Open this post in threaded view
|

Bug#627833: gramps crashes while trying to add the first person

Ross Gammon
-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Hi Juergen,

I am sorry about this. The patch is really set up for a Debian
Developer to review it, and upload it into the Unstable release of
Debian. I have not had time to chase someone up to sponsor it.

It would be possible for you to apply the patch locally, but there is
probably an easier way that does not involve setting up a Debian
Development environment.

First, go into Gramps and back up all your trees in Gramps XML format
to a safe place (just in case you end up reinstalling Gramps from
scratch - hopefully not necessary though).

Go to
http://sourceforge.net/p/gramps/code/23066/tree/branches/maintenance/gramps34/src/TransUtils.py
and download the TransUtils.py file. This is the file I used to create
the patch.

Go to your /usr/share/gramps directory and cp TransUtils.py
TransUtils.bak so that you have a backup of your own file.

Then copy the file you just downloaded into that directory.

Run Gramps and give it a test - then let me know how you get on.

Regards,

Ross

On 09/09/2013 06:51 PM, Juergen Kosel wrote:

> Sorry,
>
>
> Am 02.09.2013 21:22, schrieb Ross Gammon:
>> tag 627833 +patch thanks
>
>> Hi,
>
>> As Version 3.4.6 of Gramps may not be packaged for Debian for
>> some time, I have created a patch for v3.4.0 from the latest
>> upstream that forces a UTF-8 locale to be used if available.
>
>> It is done as an NMU, and requires a sponsor to upload it.
>
> but I have no up to date description how to build a debian
> package: The Debian Reference (version 1, 26 Jan 2008) says in
> section 13.10.1: Use dpkg-deb -b <package>. But this seems to be
> totally outdated. And dpkg-buildpackage also doesn't seem to
> work...
>
>
> Greetings Juergen
>

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.12 (GNU/Linux)
Comment: Using GnuPG with undefined - http://www.enigmail.net/

iQIcBAEBAgAGBQJSLgjiAAoJEFP+e72miRD8/n8P/iwBddZhNRJiQeaRMf8HasAA
o5Y3mVjYc52J1c3BqJcrqH+7QbAwqqXXz6u9QpFGNd9MAIBU7U7tCDEr1XoIfLpK
T+W8YTo0qvmjX2nL8QyDL+Is/aCuj1m+25y1wzuPx1fEMhNH+Ak1Z+BS92IpPXJZ
JQqK6v16LBBtUE6noGarLwCfiv43TlRdb8TSYJuv8E9zVnEM4oJNe8FSlHbpVa1B
4JR8bmlN2OVOtshJhiuwXpl9sx1ofXq8p6DGAaTc5/0ssTFdyWapv2asqschy2hm
kQOr2SALDXBefoB8N5JLPmtR+af0ix9J75YiUZL6zoGuCjcnxTvnxFINIKjfFU9T
IF4pn5wAp1hCPsQNL6GkgODgDZ4J667CiReH8xz2HMAsesJkbMJgS8wPdKPObhpz
tDnxXoJcAT9Zmajg0hp3zr7TEoy0Ah3PRYsozvpbBmqGMCbwJPS/EA+gPLF5fT0t
P/2ptHPi5dN/ESYqotnRyttxCKLOgDNlCnTytdcRAQQHaSuZ/SG7IwGmkSk97hCa
LGpzhcZYCwmJm+kQFgJ9pcApXBZXF+5YxuXZecDpxRDeZkiyFWWAgSM+dGQeZniA
61qofoeCFMCT4ZD3PEG/KSkO4x/Z7SPnZqwQXcSJKN7hce9JGA3aq+RYmcZrK9gj
tFvXWVFgZQleRpDZqPWv
=98mG
-----END PGP SIGNATURE-----


--
To UNSUBSCRIBE, email to [hidden email]
with a subject of "unsubscribe". Trouble? Contact [hidden email]