Bug#709114: marked as done (cmus crashes on external command)

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

Bug#709114: marked as done (cmus crashes on external command)

Debian Bug Tracking System
Your message dated Sat, 24 Aug 2019 22:16:12 -0400
with message-id <[hidden email]>
and subject line Re: Bug#709114: cmus crashes on external command
has caused the Debian Bug report #709114,
regarding cmus crashes on external command
to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
Bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what this
message is talking about, this may indicate a serious mail system
misconfiguration somewhere. Please contact [hidden email]
immediately.)


--
709114: https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=709114
Debian Bug Tracking System
Contact [hidden email] with problems

Package: cmus
Version: 2.5.0-2
Severity: normal

I have a shell script called 'share'

#!/bin/sh

base=`basename "$1"`

cp "$1" /var/ftp/pub

chmod 644 /var/ftp/pub/"$base"

escaped="$(perl -MURI::Escape -e 'print uri_escape($ARGV[0]);' "$base")"

echo -n "ftp://example.com/pub/$escaped" | xsel -i

And the binding

:bind common w run share {}

And when I highlight a track and hit 'w' cmus crashes instantly.

Thank you.

-- System Information:
Debian Release: jessie/sid
  APT prefers unstable
  APT policy: (500, 'unstable'), (1, 'experimental')
Architecture: amd64 (x86_64)
Foreign Architectures: i386

Kernel: Linux 3.9.0 (SMP w/12 CPU cores)
Locale: LANG=en_US.UTF-8, LC_CTYPE=en_US.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/dash

Versions of packages cmus depends on:
ii  libao4          1.1.0-2
ii  libasound2      1.0.27-4
ii  libc6           2.17-3
ii  libcddb2        1.3.2-3
ii  libcdio-cdda1   0.83-4
ii  libcdio13       0.83-4
ii  libfaad2        2.7-8
ii  libflac8        1.2.1-6
ii  libmad0         0.15.1b-7
ii  libmodplug1     1:0.8.8.4-3
ii  libmpcdec6      2:0.1~r459-4
ii  libncursesw5    5.9+20130504-1
ii  libogg0         1.3.1-1
ii  libtinfo5       5.9+20130504-1
ii  libvorbis0a     1.3.2-1.3
ii  libvorbisfile3  1.3.2-1.3
ii  libwavpack1     4.60.1-3

Versions of packages cmus recommends:
ii  cmus-plugin-ffmpeg  2.5.0-2
ii  libpulse0           2.0-6.1

cmus suggests no packages.

-- no debconf information

On Sat, Aug 24, 2019 at 07:37:57PM -0400, Adam C. Emerson wrote:
> Nope! It's been fixed for a while.

Great, thanks for letting me know!

Best,
Ryan

--
|)|/  Ryan Kavanagh      | GPG: 4E46 9519 ED67 7734 268F
|\|\  https://rak.ac     |      BD95 8F7B F8FC 4A11 C97A