Bug#722451: you need to upload compiz/emerald/emerald-themes NOW

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

Bug#722451: you need to upload compiz/emerald/emerald-themes NOW

Adam Borowski-3
Hi!
I hope you're aware that, to be included in jessie, any new packages must
hit the archive by Oct 26.  And -before- that, it must clear the massively
overloaded NEW queue (to which everyone puts last-moment uploads).  So,
here's a reminder.

Also, if you'd want some testing, are the packages you're preparing same as
those on http://debian-knoppix.alioth.debian.org/packages/compiz/ ?  That
repository lacks emerald, though.  I'm using compiz (0.8.4-5.2) for years,
it wouldn't be nice if jessie lacked it or had it broken.

Also, I wonder why you're building it against metacity (depreciated) rather
than marco (actively developed fork) -- compiz tends to be used with Mate
and XFCE rather than Gnome3.

--
// If you believe in so-called "intellectual property", please immediately
// cease using counterfeit alphabets.  Instead, contact the nearest temple
// of Amon, whose priests will provide you with scribal services for all
// your writing needs, for Reasonable and Non-Discriminatory prices.


--
To UNSUBSCRIBE, email to [hidden email]
with a subject of "unsubscribe". Trouble? Contact [hidden email]
Archive: https://lists.debian.org/20141019230845.GA13184@...

Reply | Threaded
Open this post in threaded view
|

Bug#722451: you need to upload compiz/emerald/emerald-themes NOW

MENGUAL Jean-Philippe-2
Le 20/10/2014 01:08, Adam Borowski a écrit :
> Hi!

Hi,

> I hope you're aware that, to be included in jessie, any new packages must
> hit the archive by Oct 26.  And -before- that, it must clear the massively
> overloaded NEW queue (to which everyone puts last-moment uploads).  So,
> here's a reminder.
I'm aware and worry, given that my packaging skills are limited and it's
hard for me to package such complex things. But I hope, I hope, I hope!
I search help too!

> Also, if you'd want some testing, are the packages you're preparing same as
> those on http://debian-knoppix.alioth.debian.org/packages/compiz/ ?  That
> repository lacks emerald, though.

Yes, I plan to import in Debian Jessie the packaging from knoppix. But
the trial I did today resulted failures. So I try to get helped from the
Knoppix's packager. Dunno why pdebuild fails.

For Emerald, it's committed in git.debian.org/pkg-a11y/emerald.git. I'd
like to have success, but so far the build doesn't find some libs I
don't know myself, such as libdecoration. I'm not sure I'll be able to
package it before 26th.

Finally, libwnckmm, one dependency for Emerald, is waiting for
acceptation in master FTP. It's in the queue.



>    I'm using compiz (0.8.4-5.2) for years,
> it wouldn't be nice if jessie lacked it or had it broken.
It's major for me to have it in Jessie. That's why I'll try to import
it, although I need discussions with release-manager team. I'll try to
respect delays, if I can't, I'll try to argue. Otherwise I'll do an
external repo.

> Also, I wonder why you're building it against metacity (depreciated) rather
> than marco (actively developed fork) -- compiz tends to be used with Mate
> and XFCE rather than Gnome3.
>
I don't build against anything. :) And my purpose would be to build
against Emerald, Marco and MATE. That's to fix all that I need help and
support from the Knoppix's packager. One thing is sure, I don't want
Compiz in Jessie to be built against Metacity. It'll be against Marco or
Emerald.

Any help would be appreciated, but be sure I'll do all needed efforts to
get Compiz and Emerald in Jessie. I plan arguing after freeze, because
it's major!

Sincerely,

--
Jean-Philippe MENGUAL

accelibreinfo, votre partenaire en informatique adaptée aux déficients visuels

Mail: [hidden email]

Site Web: http://www.accelibreinfo.eu


--
To UNSUBSCRIBE, email to [hidden email]
with a subject of "unsubscribe". Trouble? Contact [hidden email]
Archive: https://lists.debian.org/544455B3.9080508@...