Bug#782951: Please provide a python3 module

classic Classic list List threaded Threaded
4 messages Options
Reply | Threaded
Open this post in threaded view
|

Bug#782951: Please provide a python3 module

Paul Tagliamonte-3
Package: python-pyramid-tm
Severity: wishlist
User: [hidden email]
Usertags: patchme-python3
thanks

Hello there!

This package contains a trove classifier[1] in its `setup.py` like
"Programming Language :: Python :: 3". This means that the package's upstream
developers consier this package to be ready for Python 3. This is wonderful!


As part of an ongoing process to migrate as much as we can to Python 3 to
ensure we're ready for our glorious Python 3 future, please build a Python 3
module.


If you need help doing this, please feel free to contact the Debian Python
Modules Team (DPMT), and we can help! If you would welcome a NMU, please do
let the team know ([hidden email]).

Please upload any new versions before Jessie's release to experimental, the
Release Team has been doing such great work, it'd be a shame to see unstable
out of sync before we release!



If the reason you've not built a Python 3 module is due to the dependency
chain below you, just let me know, and I can add it to our list, or feel
free to file a bug in coordination with the team!


Have a great day, and thanks for your work!
  Paul, on behalf of the Python 3 Embetterment Squad


[1]: https://pypi.python.org/pypi?%3Aaction=list_classifiers

--
 .''`.  Paul Tagliamonte <[hidden email]>  |   Proud Debian Developer
: :'  : 4096R / 8F04 9AD8 2C92 066C 7352  D28A 7B58 5B30 807C 2A87
`. `'`  http://people.debian.org/~paultag
 `-     http://people.debian.org/~paultag/conduct-statement.txt

signature.asc (968 bytes) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Bug#782951: Please provide a python3 module

Andrey Rahmatullin-3
Control: user -1 [hidden email]
Control: usertag -1 + py2removal py2leaf py3available
Control: retitle -1 Please replace with a python3 module or remove the package
Control: severity -1 important

As a part of removing Python 2 from unstable we would like to remove
python-pyramid, and python-pyramid-tm and python-pyramid-zcml block that.
If it's possible please repackage them as Python 3 modules or remove them.
Thank you.

--
WBR, wRAR

signature.asc (911 bytes) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Bug#782951: Please replace with a python3 module or remove the package

peter green-2
In reply to this post by Paul Tagliamonte-3
severity 782951 serious
thanks

This package depends on python-transaction which is no longer built by the transaction source package.

Reply | Threaded
Open this post in threaded view
|

Bug#782952: Bug #782951: Please provide a python3 module

Scott Kitterman-5
In reply to this post by Andrey Rahmatullin-3
severity 782952 serious
thanks

python-pyramid-tm depends on python-pyramid which depends on python-
zope.deprecation which has already been dropped by the zope.deprecation source
package.

Scott K