Bug#800021: ark kpart always crashes konqui when closing

classic Classic list List threaded Threaded
4 messages Options
Reply | Threaded
Open this post in threaded view
|

Bug#800021: ark kpart always crashes konqui when closing

Nick Leverton
Package: ark
Version: 4:4.14.2-2
Severity: normal
Tags: patch,fixed-upstream

When a compressed link is opened in Konqueror using the ark kpart, the
entire konqui instance will crash if the kpart is closed (by back-arrow
or by closing the tab).

To reproduce:
Go to a page like http://opencores.com/project,can,overview
Right-click on "Latest version: download" and select "open in new tab".
Confirm "Open with Ark".
When the tab is opened, close it.

Observed behaviour: konqui crashes

Expected behaviour: tab closes and konqui returns to the other tab.

This is upstream bug https://bugs.kde.org/show_bug.cgi?id=341187
Fix in upstream branch KDE/4.14 commit cd8ad276

Patch: https://quickgit.kde.org/?p=ark.git&a=commitdiff&h=cd8ad2761d41d1ec0a18cff7f4d166b53c899fc2&hp=3b981ca95d8ec10f12102e4432912d12be8233a6

-- System Information:
Debian Release: 8.2
  APT prefers stable-updates
  APT policy: (600, 'stable-updates'), (600, 'stable')
Architecture: amd64 (x86_64)

Kernel: Linux 4.1.0-0.bpo.2-amd64 (SMP w/4 CPU cores)
Locale: LANG=en_GB.UTF-8, LC_CTYPE=en_GB.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/dash
Init: systemd (via /run/systemd/system)

Versions of packages ark depends on:
ii  kde-runtime   4:4.14.2-2
ii  libarchive13  3.1.2-11
ii  libc6         2.19-18+deb8u1
ii  libkdecore5   4:4.14.2-5
ii  libkdeui5     4:4.14.2-5
ii  libkfile4     4:4.14.2-5
ii  libkhtml5     4:4.14.2-5
ii  libkio5       4:4.14.2-5
ii  libkonq5abi1  4:4.14.2-1
ii  libkparts4    4:4.14.2-5
ii  libkpty4      4:4.14.2-5
ii  libqt4-dbus   4:4.8.6+git64-g5dc8b2b+dfsg-3+deb8u1
ii  libqtcore4    4:4.8.6+git64-g5dc8b2b+dfsg-3+deb8u1
ii  libqtgui4     4:4.8.6+git64-g5dc8b2b+dfsg-3+deb8u1
ii  libstdc++6    4.9.2-10

Versions of packages ark recommends:
ii  bzip2       1.0.6-7+b3
ii  p7zip-full  9.20.1~dfsg.1-4.1+deb8u1
ii  unzip       6.0-16
ii  zip         3.0-8

Versions of packages ark suggests:
pn  rar                 <none>
pn  unrar | unrar-free  <none>

-- no debconf information

Reply | Threaded
Open this post in threaded view
|

Bug#800021: ark kpart always crashes konqui when closing

Nick Leverton
Dear Maintainer,

Any chance this bugfix could be cherry picked from upstream please ?
It is a complete pain in the backside that Konqui crashes every time
when examining archives from the www.

The same patch also seems to fix #770840 concerning nested archives.

Patch: https://quickgit.kde.org/?p=ark.git&a=commitdiff&h=cd8ad2761d41d1ec0a18cff7f4d166b53c899fc2

Reply | Threaded
Open this post in threaded view
|

Bug#800021: marked as done (ark kpart always crashes konqui when closing)

Debian Bug Tracking System
In reply to this post by Nick Leverton
Your message dated Fri, 21 Oct 2016 19:43:38 +0200
with message-id <[hidden email]>
and subject line Re: Bug#800021: ark kpart always crashes konqui when closing
has caused the Debian Bug report #800021,
regarding ark kpart always crashes konqui when closing
to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
Bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what this
message is talking about, this may indicate a serious mail system
misconfiguration somewhere. Please contact [hidden email]
immediately.)


--
800021: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=800021
Debian Bug Tracking System
Contact [hidden email] with problems

Package: ark
Version: 4:4.14.2-2
Severity: normal
Tags: patch,fixed-upstream

When a compressed link is opened in Konqueror using the ark kpart, the
entire konqui instance will crash if the kpart is closed (by back-arrow
or by closing the tab).

To reproduce:
Go to a page like http://opencores.com/project,can,overview
Right-click on "Latest version: download" and select "open in new tab".
Confirm "Open with Ark".
When the tab is opened, close it.

Observed behaviour: konqui crashes

Expected behaviour: tab closes and konqui returns to the other tab.

This is upstream bug https://bugs.kde.org/show_bug.cgi?id=341187
Fix in upstream branch KDE/4.14 commit cd8ad276

Patch: https://quickgit.kde.org/?p=ark.git&a=commitdiff&h=cd8ad2761d41d1ec0a18cff7f4d166b53c899fc2&hp=3b981ca95d8ec10f12102e4432912d12be8233a6

-- System Information:
Debian Release: 8.2
  APT prefers stable-updates
  APT policy: (600, 'stable-updates'), (600, 'stable')
Architecture: amd64 (x86_64)

Kernel: Linux 4.1.0-0.bpo.2-amd64 (SMP w/4 CPU cores)
Locale: LANG=en_GB.UTF-8, LC_CTYPE=en_GB.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/dash
Init: systemd (via /run/systemd/system)

Versions of packages ark depends on:
ii  kde-runtime   4:4.14.2-2
ii  libarchive13  3.1.2-11
ii  libc6         2.19-18+deb8u1
ii  libkdecore5   4:4.14.2-5
ii  libkdeui5     4:4.14.2-5
ii  libkfile4     4:4.14.2-5
ii  libkhtml5     4:4.14.2-5
ii  libkio5       4:4.14.2-5
ii  libkonq5abi1  4:4.14.2-1
ii  libkparts4    4:4.14.2-5
ii  libkpty4      4:4.14.2-5
ii  libqt4-dbus   4:4.8.6+git64-g5dc8b2b+dfsg-3+deb8u1
ii  libqtcore4    4:4.8.6+git64-g5dc8b2b+dfsg-3+deb8u1
ii  libqtgui4     4:4.8.6+git64-g5dc8b2b+dfsg-3+deb8u1
ii  libstdc++6    4.9.2-10

Versions of packages ark recommends:
ii  bzip2       1.0.6-7+b3
ii  p7zip-full  9.20.1~dfsg.1-4.1+deb8u1
ii  unzip       6.0-16
ii  zip         3.0-8

Versions of packages ark suggests:
pn  rar                 <none>
pn  unrar | unrar-free  <none>

-- no debconf information

Version: 4:14.12.2-1

¬°Hola Nick!

El 2015-11-17 a las 11:26 +0000, Nick Leverton escribió:
> Any chance this bugfix could be cherry picked from upstream please ?
> It is a complete pain in the backside that Konqui crashes every time
> when examining archives from the www.

> The same patch also seems to fix #770840 concerning nested archives.

> Patch: https://quickgit.kde.org/?p=ark.git&a=commitdiff&h=cd8ad2761d41d1ec0a18cff7f4d166b53c899fc2

Tagging the version that includes the fix. I'll prepare the stable upload
afterwards.

Happy hacking,
--
"If it ain't broke, don't fix it" -- Bert Lance

"If we can't fix it, it ain't broke" -- Lieutenant Colonel Walt Weir
 Saludos /\/\ /\ >< `/

signature.asc (817 bytes) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Bug#800021: marked as done (ark kpart always crashes konqui when closing)

Debian Bug Tracking System
In reply to this post by Nick Leverton
Your message dated Mon, 24 Oct 2016 22:32:07 +0000
with message-id <[hidden email]>
and subject line Bug#800021: fixed in ark 4:4.14.2-2+deb8u1
has caused the Debian Bug report #800021,
regarding ark kpart always crashes konqui when closing
to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
Bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what this
message is talking about, this may indicate a serious mail system
misconfiguration somewhere. Please contact [hidden email]
immediately.)


--
800021: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=800021
Debian Bug Tracking System
Contact [hidden email] with problems

Package: ark
Version: 4:4.14.2-2
Severity: normal
Tags: patch,fixed-upstream

When a compressed link is opened in Konqueror using the ark kpart, the
entire konqui instance will crash if the kpart is closed (by back-arrow
or by closing the tab).

To reproduce:
Go to a page like http://opencores.com/project,can,overview
Right-click on "Latest version: download" and select "open in new tab".
Confirm "Open with Ark".
When the tab is opened, close it.

Observed behaviour: konqui crashes

Expected behaviour: tab closes and konqui returns to the other tab.

This is upstream bug https://bugs.kde.org/show_bug.cgi?id=341187
Fix in upstream branch KDE/4.14 commit cd8ad276

Patch: https://quickgit.kde.org/?p=ark.git&a=commitdiff&h=cd8ad2761d41d1ec0a18cff7f4d166b53c899fc2&hp=3b981ca95d8ec10f12102e4432912d12be8233a6

-- System Information:
Debian Release: 8.2
  APT prefers stable-updates
  APT policy: (600, 'stable-updates'), (600, 'stable')
Architecture: amd64 (x86_64)

Kernel: Linux 4.1.0-0.bpo.2-amd64 (SMP w/4 CPU cores)
Locale: LANG=en_GB.UTF-8, LC_CTYPE=en_GB.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/dash
Init: systemd (via /run/systemd/system)

Versions of packages ark depends on:
ii  kde-runtime   4:4.14.2-2
ii  libarchive13  3.1.2-11
ii  libc6         2.19-18+deb8u1
ii  libkdecore5   4:4.14.2-5
ii  libkdeui5     4:4.14.2-5
ii  libkfile4     4:4.14.2-5
ii  libkhtml5     4:4.14.2-5
ii  libkio5       4:4.14.2-5
ii  libkonq5abi1  4:4.14.2-1
ii  libkparts4    4:4.14.2-5
ii  libkpty4      4:4.14.2-5
ii  libqt4-dbus   4:4.8.6+git64-g5dc8b2b+dfsg-3+deb8u1
ii  libqtcore4    4:4.8.6+git64-g5dc8b2b+dfsg-3+deb8u1
ii  libqtgui4     4:4.8.6+git64-g5dc8b2b+dfsg-3+deb8u1
ii  libstdc++6    4.9.2-10

Versions of packages ark recommends:
ii  bzip2       1.0.6-7+b3
ii  p7zip-full  9.20.1~dfsg.1-4.1+deb8u1
ii  unzip       6.0-16
ii  zip         3.0-8

Versions of packages ark suggests:
pn  rar                 <none>
pn  unrar | unrar-free  <none>

-- no debconf information

Source: ark
Source-Version: 4:4.14.2-2+deb8u1

We believe that the bug you reported is fixed in the latest version of
ark, which is due to be installed in the Debian FTP archive.

A summary of the changes between this version and the previous one is
attached.

Thank you for reporting the bug, which will now be closed.  If you
have further comments please address them to [hidden email],
and the maintainer will reopen the bug report if appropriate.

Debian distribution maintenance software
pp.
Maximiliano Curia <[hidden email]> (supplier of updated ark package)

(This message was generated automatically at their request; if you
believe that there is a problem with it please contact the archive
administrators by mailing [hidden email])


-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA512

Format: 1.8
Date: Fri, 21 Oct 2016 20:52:52 +0200
Source: ark
Binary: ark ark-dbg
Architecture: source
Version: 4:4.14.2-2+deb8u1
Distribution: jessie
Urgency: medium
Maintainer: Debian Qt/KDE Maintainers <[hidden email]>
Changed-By: Maximiliano Curia <[hidden email]>
Description:
 ark        - archive utility
 ark-dbg    - debugging symbols for ark
Closes: 770840 800021
Changes:
 ark (4:4.14.2-2+deb8u1) jessie; urgency=medium
 .
   * Add new upstream patch:
     Stop-crashing-on-exit-when-being-used-solely-as-a-KPart.patch.
     Thanks to Nick Leverton for reporting (Closes: 800021, 770840)
Checksums-Sha1:
 af1aa7e143b8b12807dcad8fc9ada9bcada3bca5 2318 ark_4.14.2-2+deb8u1.dsc
 cb603fd56d71f7614ae014eacfac92cf9e1b1d40 8436 ark_4.14.2-2+deb8u1.debian.tar.xz
Checksums-Sha256:
 a2e6447e78649b16c202ee7dfd6db4152b65e48334e7533c22a3e344c6aefc22 2318 ark_4.14.2-2+deb8u1.dsc
 3df9ad447bff2740f18602fab3739c1cac0566156da9103958206acd2a58c730 8436 ark_4.14.2-2+deb8u1.debian.tar.xz
Files:
 55185c11e0d74b1a740a353a81160669 2318 kde optional ark_4.14.2-2+deb8u1.dsc
 708403673762189463ae9ded1ca79585 8436 kde optional ark_4.14.2-2+deb8u1.debian.tar.xz

-----BEGIN PGP SIGNATURE-----

iQIcBAEBCgAGBQJYC00CAAoJEMcZdpmymyMqn1gP/2WHLr+v7nXQ0CfMNLDEmwuL
0Db8EbUzcicHqtl92IhfP3cyb2mka/btjiT9b8ubaQaRUF/ekYZQ21PWLVMdigLt
E2SeAgXHP6JD4/baVvFohY+IUUnFG4mzOtf1ASWO6EdY0av3fPggp7r9NlP1d2qz
D+KxPmHMge/ZIsbmSPjL3Bi5bVI/FZ61S0osInCGteYQQB+ddYcPl2Vv92bqwhH7
SqJ2LM4RXXxWOauVoMGejSM7TjOErSjgskF82m3iXeYYbvxZDAh8ByVCgx9evLj9
mCNZT016+e9KDtzq51g+VQNH/drpLhhNMYnzB0uYe85BEMFLdZaURqaO+UbzLDuD
zMZ2u8IBK+B66IUcD60EVPxXn3dvga2VOkZtgP8VPh6xIXAh3fv1Hys493TA9BlX
E6KITn7HPqicNrvmWHPcHoA6Hlm3H2FjSflRKdBrXGXNPum4Axr5fX+Th/eAuQ3i
bqwm5FRRqpqx19MxBGyx4zAODW9Y4LtaF+bxZJ70BasG0L07jWPsuOaP11BfJoYG
ZgWQ5tTwIJWp1JE8sjX9yHu3JFTGTuVd8XPbCWivmDrYrpZ6j1iv4bL8kNE+GTpz
fz72epZRDkxbr5XTlfO8bSrLy/XP2gGetT8WXykvyV8Cnw47Eh9fliKnKvZlkS1l
vtEUrKhXA5rNxus27rV3
=g3d+
-----END PGP SIGNATURE-----