Bug#804327: caml-crush: FTBFS: OCaml package ssl not found

classic Classic list List threaded Threaded
5 messages Options
Reply | Threaded
Open this post in threaded view
|

Bug#804327: caml-crush: FTBFS: OCaml package ssl not found

Kurt Roeckx
Source: caml-crush
Version: 1.0.6-1
Severity: serious
Control: block 797926 by -1

Hi,

Your package is failing to build with the following error:
configure:4778: Using OCaml RPC over ssl for server side ...
configure:4782: checking OCaml package ssl
configure:4789: error: not found



Kurt

Reply | Threaded
Open this post in threaded view
|

Bug#804327: caml-crush: FTBFS: OCaml package ssl not found

Thomas Calderon

Hello Kurt,

Do you know if the ocaml SSL library has changed or been removed has a consequence of your cleanup?
That could explain why the configure script does not find it any longer.

In any case I will look into that this week.

Cheers,

Thomas

On 7 Nov 2015 12:33, "Kurt Roeckx" <[hidden email]> wrote:
Source: caml-crush
Version: 1.0.6-1
Severity: serious
Control: block 797926 by -1

Hi,

Your package is failing to build with the following error:
configure:4778: Using OCaml RPC over ssl for server side ...
configure:4782: checking OCaml package ssl
configure:4789: error: not found



Kurt
Reply | Threaded
Open this post in threaded view
|

Bug#804327: caml-crush: FTBFS: OCaml package ssl not found

Kurt Roeckx
On Sun, Nov 08, 2015 at 09:33:03PM +0000, Thomas Calderon wrote:
> Hello Kurt,
>
> Do you know if the ocaml SSL library has changed or been removed has a
> consequence of your cleanup?
> That could explain why the configure script does not find it any longer.

I'm not sure what the ocaml ssl package is.  From the brief look
at the configure script it looked the support multiple things, but
I have no idea what it's really searching for.

But I couldn't find any reference to the SSLv3_* functions in your
package, so it might not be related to my change.


Kurt

Reply | Threaded
Open this post in threaded view
|

Bug#804327: caml-crush: FTBFS: OCaml package ssl not found

Thomas Calderon
Hello,

This issue was tracked down and is linked to the following:
  - Source package had no direct dependency on libocaml-ssl/libocaml-ssl-net which was pulled by Ocamlnet
  - OCamlnet was bumped to 4.x in Sid, switching to GnuTLS which breaks their TLS API and do not require Ocaml-ssl any longer

Anyway the upstream Caml Crush is being worked on to support both older and newer 4.x Ocamlnet and a release should be made this week.
Once this is done, I will push an updated Debian package.

Cheers,

Thomas


On Sun, Nov 8, 2015 at 9:43 PM, Kurt Roeckx <[hidden email]> wrote:
On Sun, Nov 08, 2015 at 09:33:03PM +0000, Thomas Calderon wrote:
> Hello Kurt,
>
> Do you know if the ocaml SSL library has changed or been removed has a
> consequence of your cleanup?
> That could explain why the configure script does not find it any longer.

I'm not sure what the ocaml ssl package is.  From the brief look
at the configure script it looked the support multiple things, but
I have no idea what it's really searching for.

But I couldn't find any reference to the SSLv3_* functions in your
package, so it might not be related to my change.


Kurt


Reply | Threaded
Open this post in threaded view
|

Bug#804327: caml-crush: FTBFS: OCaml package ssl not found

Thomas Calderon
Just to let you know that a new release was made and the package is now up on http://mentors.debian.net/package/caml-crush.

Cheers,

Thomas

On Mon, Nov 9, 2015 at 8:37 PM, Thomas Calderon <[hidden email]> wrote:
Hello,

This issue was tracked down and is linked to the following:
  - Source package had no direct dependency on libocaml-ssl/libocaml-ssl-net which was pulled by Ocamlnet
  - OCamlnet was bumped to 4.x in Sid, switching to GnuTLS which breaks their TLS API and do not require Ocaml-ssl any longer

Anyway the upstream Caml Crush is being worked on to support both older and newer 4.x Ocamlnet and a release should be made this week.
Once this is done, I will push an updated Debian package.

Cheers,

Thomas


On Sun, Nov 8, 2015 at 9:43 PM, Kurt Roeckx <[hidden email]> wrote:
On Sun, Nov 08, 2015 at 09:33:03PM +0000, Thomas Calderon wrote:
> Hello Kurt,
>
> Do you know if the ocaml SSL library has changed or been removed has a
> consequence of your cleanup?
> That could explain why the configure script does not find it any longer.

I'm not sure what the ocaml ssl package is.  From the brief look
at the configure script it looked the support multiple things, but
I have no idea what it's really searching for.

But I couldn't find any reference to the SSLv3_* functions in your
package, so it might not be related to my change.


Kurt