Bug#807233: gpiv: Update build dependencies for GSL 2.x

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

Bug#807233: gpiv: Update build dependencies for GSL 2.x

Sebastiaan Couwenberg
Source: gpiv
Version: 0.6.1-2.3
Severity: normal
Tags: patch

Dear Maintainer,

Please update your package for the ongoing gsl transition (#804246).

The attached patch updates the build dependencies to use libgsl-dev.

This change is required to not pull in GSL 1.x via libgsl0-dev.

Please note that libgpiv (#807207) needs to be updated for GSL 2,
before gpiv can be rebuilt with GSL 2.

Kind Regards,

Bas

gpiv_0.6.1-2.4.debdiff (1K) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Bug#807233: gpiv: Update build dependencies for GSL 2.x

Gerber van der Graaf-3
Hi Bas,
Thanks for the patches for gpivtools and gpiv. Actually, I am not using
this software at the moment and noticed very few usage by other users.
So, more or less I left the development and debianizing of this
software. Gpiv has already been removed from Sid and I do not have much
time to dedicate to it. In case you are interested in this software, I
will have a look at it. Else, I wonder if it makes sense to keep this
software in Debian.

Hartelijke groet, Gerber van der Graaf


On Sun, 2015-12-06 at 16:17 +0100, Bas Couwenberg wrote:

> Source: gpiv
> Version: 0.6.1-2.3
> Severity: normal
> Tags: patch
>
> Dear Maintainer,
>
> Please update your package for the ongoing gsl transition (#804246).
>
> The attached patch updates the build dependencies to use libgsl-dev.
>
> This change is required to not pull in GSL 1.x via libgsl0-dev.
>
> Please note that libgpiv (#807207) needs to be updated for GSL 2,
> before gpiv can be rebuilt with GSL 2.
>
> Kind Regards,
>
> Bas

Reply | Threaded
Open this post in threaded view
|

Bug#807233: gpiv: Update build dependencies for GSL 2.x

Sebastiaan Couwenberg
Hi Gerber,

On 06-12-15 18:55, Gerber van der Graaf wrote:
> Thanks for the patches for gpivtools and gpiv. Actually, I am not using
> this software at the moment and noticed very few usage by other users.
> So, more or less I left the development and debianizing of this
> software. Gpiv has already been removed from Sid and I do not have much
> time to dedicate to it. In case you are interested in this software, I
> will have a look at it. Else, I wonder if it makes sense to keep this
> software in Debian.

I'm not using gpiv either, I'm just helping out with the gsl transition
because it was uncoordinated and affected some of my packages.

libgpiv, gpiv & gpivtools are still in unstable, the latter two have
only been removed from testing.

Since you are not using these packages any more, and very few others do,
it makes sense to remove these three packages from unstable via RM bugs [0].

Instead of removing these packages, you can also choose to orphan [1]
them to keep them available for the its few users.

[0]
https://www.debian.org/doc/manuals/developers-reference/ch05.en.html#removing-pkgs
[1]
https://www.debian.org/doc/manuals/developers-reference/ch05.en.html#orphaning

Kind Regards,

Bas

--
 GPG Key ID: 4096R/6750F10AE88D4AF1
Fingerprint: 8182 DE41 7056 408D 6146  50D1 6750 F10A E88D 4AF1