Bug#809541: devscripts: [uscan] please provide a quiet/no-verbose option

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

Bug#809541: devscripts: [uscan] please provide a quiet/no-verbose option

Vincent Cheng-2
Package: devscripts
Version: 2.15.10
Severity: wishlist

Dear Maintainer,

Please consider providing an option to suppress uscan output, specifically to
emulate the behaviour of "uscan --report" in previous versions of devscripts
(<= 2.15.9), where only errors or new upstream releases get printed out to
console.

Regards,
Vincent

-- Package-specific info:

--- /etc/devscripts.conf ---

--- ~/.devscripts ---
DEBSIGN_KEYID="AA1F32FF"
DEBUILD_LINTIAN=no

-- System Information:
Debian Release: stretch/sid
  APT prefers testing
  APT policy: (700, 'testing'), (500, 'unstable'), (200, 'experimental')
Architecture: amd64 (x86_64)
Foreign Architectures: i386

Kernel: Linux 4.3-3-vclaptop-amd64 (SMP w/8 CPU cores; PREEMPT)
Locale: LANG=en_CA.UTF-8, LC_CTYPE=en_CA.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/dash
Init: systemd (via /run/systemd/system)

Versions of packages devscripts depends on:
ii  dpkg-dev     1.18.3
ii  libc6        2.21-6
ii  perl         5.20.2-6
pn  python3:any  <none>

Versions of packages devscripts recommends:
ii  apt                         1.1.5
ii  at                          3.1.18-2
ii  curl                        7.45.0-1+b1
ii  dctrl-tools                 2.24-1
ii  debian-keyring              2015.11.30
ii  dput                        0.9.6.4
ii  dupload                     2.7.0
ii  equivs                      2.0.9+nmu1
ii  fakeroot                    1.20.2-1
ii  file                        1:5.25-2
ii  gnupg                       1.4.20-1
ii  gnupg2                      2.0.28-3
ii  libdistro-info-perl         0.14
ii  libencode-locale-perl       1.05-1
ii  libjson-perl                2.90-1
ii  liblwp-protocol-https-perl  6.06-2
ii  libsoap-lite-perl           1.19-1
ii  liburi-perl                 1.69-1
ii  libwww-perl                 6.15-1
ii  lintian                     2.5.39.1
ii  man-db                      2.7.5-1
ii  patch                       2.7.5-1
ii  patchutils                  0.3.4-1
ii  python3-debian              0.1.27
ii  python3-magic               1:5.25-2
ii  sensible-utils              0.0.9
ii  strace                      4.10-3
ii  unzip                       6.0-20
ii  wdiff                       1.2.2-1+b1
ii  wget                        1.17.1-1
ii  xz-utils                    5.1.1alpha+20120614-2.1

Versions of packages devscripts suggests:
ii  build-essential              11.7
pn  cvs-buildpackage             <none>
pn  debbindiff                   <none>
pn  devscripts-el                <none>
ii  gnuplot                      4.6.6-3
ii  gpgv                         1.4.20-1
ii  libauthen-sasl-perl          2.1600-1
ii  libfile-desktopentry-perl    0.22-1
ii  libnet-smtp-ssl-perl         1.03-1
pn  libterm-size-perl            <none>
ii  libtimedate-perl             2.3000-2
pn  libyaml-syck-perl            <none>
pn  mozilla-devscripts           <none>
ii  mutt                         1.5.24-1
ii  openssh-client [ssh-client]  1:7.1p1-5
ii  s-nail [mailx]               14.8.5-4
ii  svn-buildpackage             0.8.5+nmu1
ii  w3m                          0.5.3-26

-- no debconf information