Bug#818510: upgrade-reports: excellent upgrade experience on Lenovo E431

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

Bug#818510: upgrade-reports: excellent upgrade experience on Lenovo E431

Antoine Beaupre-8
Package: upgrade-reports
Severity: minor

I just upgraded my friend's laptop from the latest Wheezy to the latest Jessie
without a hitch!

Things went really smoothly. I changed the sources.list by hand, ran apt-get
upgrade; apt-get dist-upgrade and everything went almost perfectly.

For some reason, db5.1-util and unoconv were not correctly upgraded on
dist-upgrade. Running dist-upgrade fixed the latter, but not the former. I
eneded up just purging db5.1-util.

autoremove didn't catch everything: a bunch of packages were "obsolete"
according to aptitude and I had to remove those by hand. it would be nice if
the upgrade process would cover those as well. this includes python 2.6, the
older kernel, openjdk 6, gcc 4.6 and a bunch more random libs that clutter the
system.

otherwise everything seems to be going well so far. the user's only complaint
so far is that the minimize button is gone from gnome, but she figured out she
can click on the window in the window list to achieve the same result.

mission accomplished! although ideally, *she* would have been able to do the
upgrade herself. maybe next time!

a.

PS: this is not really a bug report, more of a "good job" to whoever is
receiving those messages. :) of course if you think some bug reports should be
open for specific issues, I'll be glad to follow any pointer!

-- System Information:
Debian Release: 8.3
  APT prefers stable-updates
  APT policy: (500, 'stable-updates'), (500, 'stable')
Architecture: amd64 (x86_64)
Foreign Architectures: i386

Kernel: Linux 3.16.0-4-amd64 (SMP w/4 CPU cores)
Locale: LANG=fr_CA.UTF-8, LC_CTYPE=fr_CA.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/dash
Init: systemd (via /run/systemd/system)

Reply | Threaded
Open this post in threaded view
|

Bug#818510: upgrade-reports: excellent upgrade experience on Lenovo E431

Bill Allombert-4
On Thu, Mar 17, 2016 at 01:59:58PM -0400, anarcat wrote:
> autoremove didn't catch everything: a bunch of packages were "obsolete"
> according to aptitude and I had to remove those by hand. it would be nice if
> the upgrade process would cover those as well. this includes python 2.6, the
> older kernel, openjdk 6, gcc 4.6 and a bunch more random libs that clutter the
> system.

It is dangerous to remove them since some users might still have
non-dpkg-installed software depending on them.

Cheers,
--
Bill. <[hidden email]>

Imagine a large red swirl here.

Reply | Threaded
Open this post in threaded view
|

Re: Bug#818510: upgrade-reports: excellent upgrade experience on Lenovo E431

haricophile@aranha.fr
In reply to this post by Antoine Beaupre-8
Le Thu, 17 Mar 2016 13:59:58 -0400,
anarcat <[hidden email]> a écrit :

> otherwise everything seems to be going well so far. the user's only
> complaint so far is that the minimize button is gone from gnome, but
> she figured out she can click on the window in the window list to
> achieve the same result.

You can set that with dconf-editor | gsettings but is it required...

--
[hidden email]