Bug#832255: python3-ipykernel: Can't use %pylab in jupyter qtconsole

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

Bug#832255: python3-ipykernel: Can't use %pylab in jupyter qtconsole

Yannick Roehlly
Package: python3-ipykernel
Version: 4.3.1-2
Severity: normal
Tags: upstream

Hi,

Using %pylab in jupyter qtconsole does not allow to display matplotlib graphics.
Launching the qtconsole from command line exhibits this problem:

ERROR:tornado.application:Exception in callback functools.partial(<function wrap.<locals>.null_wrapper at 0x7fedb27dc9d8>)
Traceback (most recent call last):
  File "/usr/lib/python3/dist-packages/tornado/ioloop.py", line 600, in _run_callback
    ret = callback()
  File "/usr/lib/python3/dist-packages/tornado/stack_context.py", line 275, in null_wrapper
    return fn(*args, **kwargs)
  File "/usr/lib/python3/dist-packages/ipykernel/kernelbase.py", line 258, in enter_eventloop
    self.eventloop(self)
  File "/usr/lib/python3/dist-packages/ipykernel/eventloops.py", line 73, in loop_qt4
    _notify_stream_qt(kernel, s)
  File "/usr/lib/python3/dist-packages/ipykernel/eventloops.py", line 23, in _notify_stream_qt
    from IPython.core.interactiveshell import NoOpContext as context
ImportError: cannot import name 'NoOpContext'

This problem was identified upstream and corrected in this commit:

https://github.com/ipython/ipython/commit/7cda39691852c19d516f30c4e59e161be05a7b33

Cheers,

Yannick

-- System Information:
Debian Release: stretch/sid
  APT prefers unstable
  APT policy: (500, 'unstable'), (1, 'experimental')
Architecture: amd64 (x86_64)
Foreign Architectures: i386, x32

Kernel: Linux 4.6.0-1-amd64 (SMP w/8 CPU cores)
Locale: LANG=fr_FR.UTF-8, LC_CTYPE=fr_FR.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/dash
Init: systemd (via /run/systemd/system)

Versions of packages python3-ipykernel depends on:
ii  ipython3                5.0.0-1
ii  python3-jupyter-client  4.3.0-1
ii  python3-tornado         4.3.0-2
ii  python3-traitlets       4.2.2-2
pn  python3:any             <none>

python3-ipykernel recommends no packages.

python3-ipykernel suggests no packages.

-- no debconf information