Bug#835764: llvm-toolchain-3.5: FTBFS: make[1]: gcc-6.1: Command not found

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

Bug#835764: llvm-toolchain-3.5: FTBFS: make[1]: gcc-6.1: Command not found

Lucas Nussbaum-4
Source: llvm-toolchain-3.5
Version: 1:3.5.2-3
Severity: serious
Tags: stretch sid
User: [hidden email]
Usertags: qa-ftbfs-20160828 qa-ftbfs
Justification: FTBFS on amd64

Hi,

During a rebuild of all packages in sid, your package failed to build on
amd64.

Relevant part (hopefully):

> make[1]: Entering directory '/<<PKGBUILDDIR>>'
> Can't exec "gcc-6.1": No such file or directory at /usr/share/perl5/Dpkg/Arch.pm line 128.
> dpkg-architecture: warning: cannot determine CC system type, falling back to default (native compilation)
> dpkg-query: no packages found matching g++-6.1
> dpkg: error: --compare-versions takes three arguments: <version> <relation> <version>
>
> Type dpkg --help for help about installing and deinstalling packages [*];
> Use 'apt' or 'aptitude' for user-friendly package management;
> Type dpkg -Dhelp for a list of dpkg debug flag values;
> Type dpkg --force-help for a list of forcing options;
> Type dpkg-deb --help for help about manipulating *.deb files;
>
> Options marked [*] produce a lot of output - pipe it through 'less' or 'more' !
> Can't exec "gcc-6.1": No such file or directory at /usr/share/perl5/Dpkg/Arch.pm line 128.
> dpkg-architecture: warning: cannot determine CC system type, falling back to default (native compilation)
> Can't exec "gcc-6.1": No such file or directory at /usr/share/perl5/Dpkg/Arch.pm line 128.
> dpkg-architecture: warning: cannot determine CC system type, falling back to default (native compilation)
> Can't exec "gcc-6.1": No such file or directory at /usr/share/perl5/Dpkg/Arch.pm line 128.
> dpkg-architecture: warning: cannot determine CC system type, falling back to default (native compilation)
> dpkg-query: no packages found matching g++-6.1
> dpkg: error: --compare-versions takes three arguments: <version> <relation> <version>
>
> Type dpkg --help for help about installing and deinstalling packages [*];
> Use 'apt' or 'aptitude' for user-friendly package management;
> Type dpkg -Dhelp for a list of dpkg debug flag values;
> Type dpkg --force-help for a list of forcing options;
> Type dpkg-deb --help for help about manipulating *.deb files;
>
> Options marked [*] produce a lot of output - pipe it through 'less' or 'more' !
> dpkg-query: no packages found matching g++-6.1
> dpkg: error: --compare-versions takes three arguments: <version> <relation> <version>
>
> Type dpkg --help for help about installing and deinstalling packages [*];
> Use 'apt' or 'aptitude' for user-friendly package management;
> Type dpkg -Dhelp for a list of dpkg debug flag values;
> Type dpkg --force-help for a list of forcing options;
> Type dpkg-deb --help for help about manipulating *.deb files;
>
> Options marked [*] produce a lot of output - pipe it through 'less' or 'more' !
> Can't exec "gcc-6.1": No such file or directory at /usr/share/perl5/Dpkg/Arch.pm line 128.
> dpkg-architecture: warning: cannot determine CC system type, falling back to default (native compilation)
> Can't exec "gcc-6.1": No such file or directory at /usr/share/perl5/Dpkg/Arch.pm line 128.
> dpkg-architecture: warning: cannot determine CC system type, falling back to default (native compilation)
> Can't exec "gcc-6.1": No such file or directory at /usr/share/perl5/Dpkg/Arch.pm line 128.
> dpkg-architecture: warning: cannot determine CC system type, falling back to default (native compilation)
> Can't exec "gcc-6.1": No such file or directory at /usr/share/perl5/Dpkg/Arch.pm line 128.
> dpkg-architecture: warning: cannot determine CC system type, falling back to default (native compilation)
> Can't exec "gcc-6.1": No such file or directory at /usr/share/perl5/Dpkg/Arch.pm line 128.
> dpkg-architecture: warning: cannot determine CC system type, falling back to default (native compilation)
> for f in debian/*.in; do \
> f2=$(echo $f | sed 's/\.in$//;s/X\.Y/3.5/'); \
> echo "$f => $f2"; \
> sed -e 's|@DEB_HOST_MULTIARCH@|x86_64-linux-gnu|g' \
> -e "s|@OCAML_STDLIB_DIR@|/usr/lib/ocaml|g" \
> -e "s|@LLVM_VERSION_FULL@|3.5.2|g" \
> -e "s|@LLVM_VERSION@|3.5|g" $f > $f2; \
> done
> Can't exec "gcc-6.1": No such file or directory at /usr/share/perl5/Dpkg/Arch.pm line 128.
> dpkg-architecture: warning: cannot determine CC system type, falling back to default (native compilation)
> Can't exec "gcc-6.1": No such file or directory at /usr/share/perl5/Dpkg/Arch.pm line 128.
> dpkg-architecture: warning: cannot determine CC system type, falling back to default (native compilation)
> Can't exec "gcc-6.1": No such file or directory at /usr/share/perl5/Dpkg/Arch.pm line 128.
> dpkg-architecture: warning: cannot determine CC system type, falling back to default (native compilation)
> Can't exec "gcc-6.1": No such file or directory at /usr/share/perl5/Dpkg/Arch.pm line 128.
> dpkg-architecture: warning: cannot determine CC system type, falling back to default (native compilation)
> debian/clang-X.Y-doc.docs.in => debian/clang-3.5-doc.docs
> debian/clang-X.Y-doc.install.in => debian/clang-3.5-doc.install
> debian/clang-X.Y-examples.examples.in => debian/clang-3.5-examples.examples
> debian/clang-X.Y.install.in => debian/clang-3.5.install
> debian/clang-X.Y.links.in => debian/clang-3.5.links
> debian/clang-X.Y.lintian-overrides.in => debian/clang-3.5.lintian-overrides
> debian/clang-X.Y.manpages.in => debian/clang-3.5.manpages
> debian/clang-format-X.Y.install.in => debian/clang-format-3.5.install
> debian/clang-format-X.Y.lintian-overrides.in => debian/clang-format-3.5.lintian-overrides
> debian/clang-format-X.Y.manpages.in => debian/clang-format-3.5.manpages
> debian/clang-modernize-X.Y.install.in => debian/clang-modernize-3.5.install
> debian/clang-modernize-X.Y.lintian-overrides.in => debian/clang-modernize-3.5.lintian-overrides
> debian/clang-modernize-X.Y.manpages.in => debian/clang-modernize-3.5.manpages
> debian/libclang-X.Y-dev.install.in => debian/libclang-3.5-dev.install
> debian/libclang-X.Y-dev.links.in => debian/libclang-3.5-dev.links
> debian/libclang-common-X.Y-dev.install.in => debian/libclang-common-3.5-dev.install
> debian/libclang-common-X.Y-dev.links.in => debian/libclang-common-3.5-dev.links
> debian/libclang1-X.Y.install.in => debian/libclang1-3.5.install
> debian/libclang1-X.Y.links.in => debian/libclang1-3.5.links
> debian/libclang1-X.Y.lintian-overrides.in => debian/libclang1-3.5.lintian-overrides
> debian/libclang1-X.Y.symbols.in => debian/libclang1-3.5.symbols
> debian/liblldb-X.Y-dev.install.in => debian/liblldb-3.5-dev.install
> debian/liblldb-X.Y.install.in => debian/liblldb-3.5.install
> debian/liblldb-X.Y.links.in => debian/liblldb-3.5.links
> debian/liblldb-X.Y.lintian-overrides.in => debian/liblldb-3.5.lintian-overrides
> debian/libllvm-X.Y-ocaml-dev.META.in => debian/libllvm-3.5-ocaml-dev.META
> debian/libllvm-X.Y-ocaml-dev.dirs.in => debian/libllvm-3.5-ocaml-dev.dirs
> debian/libllvm-X.Y-ocaml-dev.doc-base.in => debian/libllvm-3.5-ocaml-dev.doc-base
> debian/libllvm-X.Y-ocaml-dev.install.in => debian/libllvm-3.5-ocaml-dev.install
> debian/libllvm-X.Y-ocaml-dev.lintian-overrides.in => debian/libllvm-3.5-ocaml-dev.lintian-overrides
> debian/libllvmX.Y.install.in => debian/libllvm3.5.install
> debian/libllvmX.Y.links.in => debian/libllvm3.5.links
> debian/libllvmX.Y.lintian-overrides.in => debian/libllvm3.5.lintian-overrides
> debian/libllvmX.Yv5.install.in => debian/libllvm3.5v5.install
> debian/libllvmX.Yv5.links.in => debian/libllvm3.5v5.links
> debian/libllvmX.Yv5.lintian-overrides.in => debian/libllvm3.5v5.lintian-overrides
> debian/lldb-X.Y.install.in => debian/lldb-3.5.install
> debian/lldb-X.Y.lintian-overrides.in => debian/lldb-3.5.lintian-overrides
> debian/lldb-X.Y.manpages.in => debian/lldb-3.5.manpages
> debian/lldb-X.Y.postinst.in => debian/lldb-3.5.postinst
> debian/llvm-X.Y-dev.dirs.in => debian/llvm-3.5-dev.dirs
> debian/llvm-X.Y-dev.install.in => debian/llvm-3.5-dev.install
> debian/llvm-X.Y-dev.links.in => debian/llvm-3.5-dev.links
> debian/llvm-X.Y-doc.dirs.in => debian/llvm-3.5-doc.dirs
> debian/llvm-X.Y-doc.install.in => debian/llvm-3.5-doc.install
> debian/llvm-X.Y-examples.dirs.in => debian/llvm-3.5-examples.dirs
> debian/llvm-X.Y-examples.examples.in => debian/llvm-3.5-examples.examples
> debian/llvm-X.Y-examples.links.in => debian/llvm-3.5-examples.links
> debian/llvm-X.Y-runtime.binfmt.in => debian/llvm-3.5-runtime.binfmt
> debian/llvm-X.Y-runtime.install.in => debian/llvm-3.5-runtime.install
> debian/llvm-X.Y-runtime.links.in => debian/llvm-3.5-runtime.links
> debian/llvm-X.Y-runtime.lintian-overrides.in => debian/llvm-3.5-runtime.lintian-overrides
> debian/llvm-X.Y-runtime.manpages.in => debian/llvm-3.5-runtime.manpages
> debian/llvm-X.Y-runtime.postinst.in => debian/llvm-3.5-runtime.postinst
> debian/llvm-X.Y-runtime.prerm.in => debian/llvm-3.5-runtime.prerm
> debian/llvm-X.Y-tools.dirs.in => debian/llvm-3.5-tools.dirs
> debian/llvm-X.Y-tools.install.in => debian/llvm-3.5-tools.install
> debian/llvm-X.Y.dirs.in => debian/llvm-3.5.dirs
> debian/llvm-X.Y.install.in => debian/llvm-3.5.install
> debian/llvm-X.Y.links.in => debian/llvm-3.5.links
> debian/llvm-X.Y.lintian-overrides.in => debian/llvm-3.5.lintian-overrides
> debian/llvm-X.Y.manpages.in => debian/llvm-3.5.manpages
> debian/pollycc.in => debian/pollycc
> debian/python-clang-X.Y.install.in => debian/python-clang-3.5.install
> debian/python-lldb-X.Y.install.in => debian/python-lldb-3.5.install
> debian/python-lldb-X.Y.links.in => debian/python-lldb-3.5.links
> Can't exec "gcc-6.1": No such file or directory at /usr/share/perl5/Dpkg/Arch.pm line 128.
> dpkg-architecture: warning: cannot determine CC system type, falling back to default (native compilation)
> echo "Using gcc: "
> Can't exec "gcc-6.1": No such file or directory at /usr/share/perl5/Dpkg/Arch.pm line 128.
> dpkg-architecture: warning: cannot determine CC system type, falling back to default (native compilation)
> Can't exec "gcc-6.1": No such file or directory at /usr/share/perl5/Dpkg/Arch.pm line 128.
> dpkg-architecture: warning: cannot determine CC system type, falling back to default (native compilation)
> Can't exec "gcc-6.1": No such file or directory at /usr/share/perl5/Dpkg/Arch.pm line 128.
> dpkg-architecture: warning: cannot determine CC system type, falling back to default (native compilation)
> Can't exec "gcc-6.1": No such file or directory at /usr/share/perl5/Dpkg/Arch.pm line 128.
> dpkg-architecture: warning: cannot determine CC system type, falling back to default (native compilation)
> Using gcc:
> gcc-6.1 -v
> make[1]: gcc-6.1: Command not found
> debian/rules:148: recipe for target 'override_dh_auto_configure' failed
> make[1]: *** [override_dh_auto_configure] Error 127

The full build log is available from:
   http://people.debian.org/~lucas/logs/2016/08/28/llvm-toolchain-3.5_3.5.2-3_unstable.log

A list of current common problems and possible solutions is available at
http://wiki.debian.org/qa.debian.org/FTBFS . You're welcome to contribute!

About the archive rebuild: The rebuild was done on EC2 VM instances from
Amazon Web Services, using a clean, minimal and up-to-date chroot. Every
failed build was retried once to eliminate random failures.

Reply | Threaded
Open this post in threaded view
|

Bug#835764: marked as done (llvm-toolchain-3.5: FTBFS: make[1]: gcc-6.1: Command not found)

Debian Bug Tracking System
Your message dated Fri, 07 Oct 2016 12:50:28 +0000
with message-id <[hidden email]>
and subject line Bug#835764: fixed in llvm-toolchain-3.5 1:3.5.2-4
has caused the Debian Bug report #835764,
regarding llvm-toolchain-3.5: FTBFS: make[1]: gcc-6.1: Command not found
to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
Bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what this
message is talking about, this may indicate a serious mail system
misconfiguration somewhere. Please contact [hidden email]
immediately.)


--
835764: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=835764
Debian Bug Tracking System
Contact [hidden email] with problems

Source: llvm-toolchain-3.5
Version: 1:3.5.2-3
Severity: serious
Tags: stretch sid
User: [hidden email]
Usertags: qa-ftbfs-20160828 qa-ftbfs
Justification: FTBFS on amd64

Hi,

During a rebuild of all packages in sid, your package failed to build on
amd64.

Relevant part (hopefully):

> make[1]: Entering directory '/<<PKGBUILDDIR>>'
> Can't exec "gcc-6.1": No such file or directory at /usr/share/perl5/Dpkg/Arch.pm line 128.
> dpkg-architecture: warning: cannot determine CC system type, falling back to default (native compilation)
> dpkg-query: no packages found matching g++-6.1
> dpkg: error: --compare-versions takes three arguments: <version> <relation> <version>
>
> Type dpkg --help for help about installing and deinstalling packages [*];
> Use 'apt' or 'aptitude' for user-friendly package management;
> Type dpkg -Dhelp for a list of dpkg debug flag values;
> Type dpkg --force-help for a list of forcing options;
> Type dpkg-deb --help for help about manipulating *.deb files;
>
> Options marked [*] produce a lot of output - pipe it through 'less' or 'more' !
> Can't exec "gcc-6.1": No such file or directory at /usr/share/perl5/Dpkg/Arch.pm line 128.
> dpkg-architecture: warning: cannot determine CC system type, falling back to default (native compilation)
> Can't exec "gcc-6.1": No such file or directory at /usr/share/perl5/Dpkg/Arch.pm line 128.
> dpkg-architecture: warning: cannot determine CC system type, falling back to default (native compilation)
> Can't exec "gcc-6.1": No such file or directory at /usr/share/perl5/Dpkg/Arch.pm line 128.
> dpkg-architecture: warning: cannot determine CC system type, falling back to default (native compilation)
> dpkg-query: no packages found matching g++-6.1
> dpkg: error: --compare-versions takes three arguments: <version> <relation> <version>
>
> Type dpkg --help for help about installing and deinstalling packages [*];
> Use 'apt' or 'aptitude' for user-friendly package management;
> Type dpkg -Dhelp for a list of dpkg debug flag values;
> Type dpkg --force-help for a list of forcing options;
> Type dpkg-deb --help for help about manipulating *.deb files;
>
> Options marked [*] produce a lot of output - pipe it through 'less' or 'more' !
> dpkg-query: no packages found matching g++-6.1
> dpkg: error: --compare-versions takes three arguments: <version> <relation> <version>
>
> Type dpkg --help for help about installing and deinstalling packages [*];
> Use 'apt' or 'aptitude' for user-friendly package management;
> Type dpkg -Dhelp for a list of dpkg debug flag values;
> Type dpkg --force-help for a list of forcing options;
> Type dpkg-deb --help for help about manipulating *.deb files;
>
> Options marked [*] produce a lot of output - pipe it through 'less' or 'more' !
> Can't exec "gcc-6.1": No such file or directory at /usr/share/perl5/Dpkg/Arch.pm line 128.
> dpkg-architecture: warning: cannot determine CC system type, falling back to default (native compilation)
> Can't exec "gcc-6.1": No such file or directory at /usr/share/perl5/Dpkg/Arch.pm line 128.
> dpkg-architecture: warning: cannot determine CC system type, falling back to default (native compilation)
> Can't exec "gcc-6.1": No such file or directory at /usr/share/perl5/Dpkg/Arch.pm line 128.
> dpkg-architecture: warning: cannot determine CC system type, falling back to default (native compilation)
> Can't exec "gcc-6.1": No such file or directory at /usr/share/perl5/Dpkg/Arch.pm line 128.
> dpkg-architecture: warning: cannot determine CC system type, falling back to default (native compilation)
> Can't exec "gcc-6.1": No such file or directory at /usr/share/perl5/Dpkg/Arch.pm line 128.
> dpkg-architecture: warning: cannot determine CC system type, falling back to default (native compilation)
> for f in debian/*.in; do \
> f2=$(echo $f | sed 's/\.in$//;s/X\.Y/3.5/'); \
> echo "$f => $f2"; \
> sed -e 's|@DEB_HOST_MULTIARCH@|x86_64-linux-gnu|g' \
> -e "s|@OCAML_STDLIB_DIR@|/usr/lib/ocaml|g" \
> -e "s|@LLVM_VERSION_FULL@|3.5.2|g" \
> -e "s|@LLVM_VERSION@|3.5|g" $f > $f2; \
> done
> Can't exec "gcc-6.1": No such file or directory at /usr/share/perl5/Dpkg/Arch.pm line 128.
> dpkg-architecture: warning: cannot determine CC system type, falling back to default (native compilation)
> Can't exec "gcc-6.1": No such file or directory at /usr/share/perl5/Dpkg/Arch.pm line 128.
> dpkg-architecture: warning: cannot determine CC system type, falling back to default (native compilation)
> Can't exec "gcc-6.1": No such file or directory at /usr/share/perl5/Dpkg/Arch.pm line 128.
> dpkg-architecture: warning: cannot determine CC system type, falling back to default (native compilation)
> Can't exec "gcc-6.1": No such file or directory at /usr/share/perl5/Dpkg/Arch.pm line 128.
> dpkg-architecture: warning: cannot determine CC system type, falling back to default (native compilation)
> debian/clang-X.Y-doc.docs.in => debian/clang-3.5-doc.docs
> debian/clang-X.Y-doc.install.in => debian/clang-3.5-doc.install
> debian/clang-X.Y-examples.examples.in => debian/clang-3.5-examples.examples
> debian/clang-X.Y.install.in => debian/clang-3.5.install
> debian/clang-X.Y.links.in => debian/clang-3.5.links
> debian/clang-X.Y.lintian-overrides.in => debian/clang-3.5.lintian-overrides
> debian/clang-X.Y.manpages.in => debian/clang-3.5.manpages
> debian/clang-format-X.Y.install.in => debian/clang-format-3.5.install
> debian/clang-format-X.Y.lintian-overrides.in => debian/clang-format-3.5.lintian-overrides
> debian/clang-format-X.Y.manpages.in => debian/clang-format-3.5.manpages
> debian/clang-modernize-X.Y.install.in => debian/clang-modernize-3.5.install
> debian/clang-modernize-X.Y.lintian-overrides.in => debian/clang-modernize-3.5.lintian-overrides
> debian/clang-modernize-X.Y.manpages.in => debian/clang-modernize-3.5.manpages
> debian/libclang-X.Y-dev.install.in => debian/libclang-3.5-dev.install
> debian/libclang-X.Y-dev.links.in => debian/libclang-3.5-dev.links
> debian/libclang-common-X.Y-dev.install.in => debian/libclang-common-3.5-dev.install
> debian/libclang-common-X.Y-dev.links.in => debian/libclang-common-3.5-dev.links
> debian/libclang1-X.Y.install.in => debian/libclang1-3.5.install
> debian/libclang1-X.Y.links.in => debian/libclang1-3.5.links
> debian/libclang1-X.Y.lintian-overrides.in => debian/libclang1-3.5.lintian-overrides
> debian/libclang1-X.Y.symbols.in => debian/libclang1-3.5.symbols
> debian/liblldb-X.Y-dev.install.in => debian/liblldb-3.5-dev.install
> debian/liblldb-X.Y.install.in => debian/liblldb-3.5.install
> debian/liblldb-X.Y.links.in => debian/liblldb-3.5.links
> debian/liblldb-X.Y.lintian-overrides.in => debian/liblldb-3.5.lintian-overrides
> debian/libllvm-X.Y-ocaml-dev.META.in => debian/libllvm-3.5-ocaml-dev.META
> debian/libllvm-X.Y-ocaml-dev.dirs.in => debian/libllvm-3.5-ocaml-dev.dirs
> debian/libllvm-X.Y-ocaml-dev.doc-base.in => debian/libllvm-3.5-ocaml-dev.doc-base
> debian/libllvm-X.Y-ocaml-dev.install.in => debian/libllvm-3.5-ocaml-dev.install
> debian/libllvm-X.Y-ocaml-dev.lintian-overrides.in => debian/libllvm-3.5-ocaml-dev.lintian-overrides
> debian/libllvmX.Y.install.in => debian/libllvm3.5.install
> debian/libllvmX.Y.links.in => debian/libllvm3.5.links
> debian/libllvmX.Y.lintian-overrides.in => debian/libllvm3.5.lintian-overrides
> debian/libllvmX.Yv5.install.in => debian/libllvm3.5v5.install
> debian/libllvmX.Yv5.links.in => debian/libllvm3.5v5.links
> debian/libllvmX.Yv5.lintian-overrides.in => debian/libllvm3.5v5.lintian-overrides
> debian/lldb-X.Y.install.in => debian/lldb-3.5.install
> debian/lldb-X.Y.lintian-overrides.in => debian/lldb-3.5.lintian-overrides
> debian/lldb-X.Y.manpages.in => debian/lldb-3.5.manpages
> debian/lldb-X.Y.postinst.in => debian/lldb-3.5.postinst
> debian/llvm-X.Y-dev.dirs.in => debian/llvm-3.5-dev.dirs
> debian/llvm-X.Y-dev.install.in => debian/llvm-3.5-dev.install
> debian/llvm-X.Y-dev.links.in => debian/llvm-3.5-dev.links
> debian/llvm-X.Y-doc.dirs.in => debian/llvm-3.5-doc.dirs
> debian/llvm-X.Y-doc.install.in => debian/llvm-3.5-doc.install
> debian/llvm-X.Y-examples.dirs.in => debian/llvm-3.5-examples.dirs
> debian/llvm-X.Y-examples.examples.in => debian/llvm-3.5-examples.examples
> debian/llvm-X.Y-examples.links.in => debian/llvm-3.5-examples.links
> debian/llvm-X.Y-runtime.binfmt.in => debian/llvm-3.5-runtime.binfmt
> debian/llvm-X.Y-runtime.install.in => debian/llvm-3.5-runtime.install
> debian/llvm-X.Y-runtime.links.in => debian/llvm-3.5-runtime.links
> debian/llvm-X.Y-runtime.lintian-overrides.in => debian/llvm-3.5-runtime.lintian-overrides
> debian/llvm-X.Y-runtime.manpages.in => debian/llvm-3.5-runtime.manpages
> debian/llvm-X.Y-runtime.postinst.in => debian/llvm-3.5-runtime.postinst
> debian/llvm-X.Y-runtime.prerm.in => debian/llvm-3.5-runtime.prerm
> debian/llvm-X.Y-tools.dirs.in => debian/llvm-3.5-tools.dirs
> debian/llvm-X.Y-tools.install.in => debian/llvm-3.5-tools.install
> debian/llvm-X.Y.dirs.in => debian/llvm-3.5.dirs
> debian/llvm-X.Y.install.in => debian/llvm-3.5.install
> debian/llvm-X.Y.links.in => debian/llvm-3.5.links
> debian/llvm-X.Y.lintian-overrides.in => debian/llvm-3.5.lintian-overrides
> debian/llvm-X.Y.manpages.in => debian/llvm-3.5.manpages
> debian/pollycc.in => debian/pollycc
> debian/python-clang-X.Y.install.in => debian/python-clang-3.5.install
> debian/python-lldb-X.Y.install.in => debian/python-lldb-3.5.install
> debian/python-lldb-X.Y.links.in => debian/python-lldb-3.5.links
> Can't exec "gcc-6.1": No such file or directory at /usr/share/perl5/Dpkg/Arch.pm line 128.
> dpkg-architecture: warning: cannot determine CC system type, falling back to default (native compilation)
> echo "Using gcc: "
> Can't exec "gcc-6.1": No such file or directory at /usr/share/perl5/Dpkg/Arch.pm line 128.
> dpkg-architecture: warning: cannot determine CC system type, falling back to default (native compilation)
> Can't exec "gcc-6.1": No such file or directory at /usr/share/perl5/Dpkg/Arch.pm line 128.
> dpkg-architecture: warning: cannot determine CC system type, falling back to default (native compilation)
> Can't exec "gcc-6.1": No such file or directory at /usr/share/perl5/Dpkg/Arch.pm line 128.
> dpkg-architecture: warning: cannot determine CC system type, falling back to default (native compilation)
> Can't exec "gcc-6.1": No such file or directory at /usr/share/perl5/Dpkg/Arch.pm line 128.
> dpkg-architecture: warning: cannot determine CC system type, falling back to default (native compilation)
> Using gcc:
> gcc-6.1 -v
> make[1]: gcc-6.1: Command not found
> debian/rules:148: recipe for target 'override_dh_auto_configure' failed
> make[1]: *** [override_dh_auto_configure] Error 127
The full build log is available from:
   http://people.debian.org/~lucas/logs/2016/08/28/llvm-toolchain-3.5_3.5.2-3_unstable.log

A list of current common problems and possible solutions is available at
http://wiki.debian.org/qa.debian.org/FTBFS . You're welcome to contribute!

About the archive rebuild: The rebuild was done on EC2 VM instances from
Amazon Web Services, using a clean, minimal and up-to-date chroot. Every
failed build was retried once to eliminate random failures.

Source: llvm-toolchain-3.5
Source-Version: 1:3.5.2-4

We believe that the bug you reported is fixed in the latest version of
llvm-toolchain-3.5, which is due to be installed in the Debian FTP archive.

A summary of the changes between this version and the previous one is
attached.

Thank you for reporting the bug, which will now be closed.  If you
have further comments please address them to [hidden email],
and the maintainer will reopen the bug report if appropriate.

Debian distribution maintenance software
pp.
Gianfranco Costamagna <[hidden email]> (supplier of updated llvm-toolchain-3.5 package)

(This message was generated automatically at their request; if you
believe that there is a problem with it please contact the archive
administrators by mailing [hidden email])


-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA256

Format: 1.8
Date: Fri, 07 Oct 2016 08:35:35 +0200
Source: llvm-toolchain-3.5
Binary: clang-3.5 clang-format-3.5 cpp11-migrate-3.5 clang-modernize-3.5 clang-3.5-doc libclang1-3.5 libclang1-3.5-dbg libclang-3.5-dev libclang-common-3.5-dev python-clang-3.5 clang-3.5-examples libllvm3.5v5 libllvm3.5-dbg llvm-3.5 llvm-3.5-runtime llvm-3.5-dev llvm-3.5-tools libllvm-3.5-ocaml-dev llvm-3.5-doc llvm-3.5-examples lldb-3.5 liblldb-3.5 python-lldb-3.5 liblldb-3.5-dev lldb-3.5-dev
Architecture: source
Version: 1:3.5.2-4
Distribution: unstable
Urgency: medium
Maintainer: LLVM Packaging Team <[hidden email]>
Changed-By: Gianfranco Costamagna <[hidden email]>
Description:
 clang-3.5  - C, C++ and Objective-C compiler (LLVM based)
 clang-3.5-doc - C, C++ and Objective-C compiler (LLVM based) - Documentation
 clang-3.5-examples - Clang examples
 clang-format-3.5 - Tool to format C/C++/Obj-C code
 clang-modernize-3.5 - Tool to convert C++98 and C++03 code to C++11
 cpp11-migrate-3.5 - Tool to convert C++98 and C++03 code to C++11
 libclang-3.5-dev - clang library - Development package
 libclang-common-3.5-dev - clang library - Common development package
 libclang1-3.5 - C interface to the clang library
 libclang1-3.5-dbg - clang library
 liblldb-3.5 - Next generation, high-performance debugger, library
 liblldb-3.5-dev - Next generation, high-performance debugger - Header files
 libllvm-3.5-ocaml-dev - Modular compiler and toolchain technologies, OCaml bindings
 libllvm3.5-dbg - Modular compiler and toolchain technologies, debugging libraries
 libllvm3.5v5 - Modular compiler and toolchain technologies, runtime library
 lldb-3.5   - Next generation, high-performance debugger
 lldb-3.5-dev - transitional dummy package to liblldb-3.5-dev
 llvm-3.5   - Modular compiler and toolchain technologies
 llvm-3.5-dev - Modular compiler and toolchain technologies, libraries and header
 llvm-3.5-doc - Modular compiler and toolchain technologies, documentation
 llvm-3.5-examples - Modular compiler and toolchain technologies, examples
 llvm-3.5-runtime - Modular compiler and toolchain technologies, IR interpreter
 llvm-3.5-tools - Modular compiler and toolchain technologies, tools
 python-clang-3.5 - Clang Python Bindings
 python-lldb-3.5 - Next generation, high-performance debugger, python lib
Closes: 835764
Changes:
 llvm-toolchain-3.5 (1:3.5.2-4) unstable; urgency=medium
 .
   * Team upload.
 .
   [ Matthias Klose ]
   * d/p/no-version-script-for-executables.diff:
     - Do not link executables with a version script.
 .
   [ Gianfranco Costamagna ]
   * d/rules: Fix the regex for the GCC_VERSION so it takes version 6
     into account. Otherwise, this causes an FTBS (Closes: #835764)
Checksums-Sha1:
 26952d788686101cfde99d633045e600278ed285 5864 llvm-toolchain-3.5_3.5.2-4.dsc
 23a6cbf6e06fd5a838eb34d8721f0ff48c980d7d 54400 llvm-toolchain-3.5_3.5.2-4.debian.tar.xz
Checksums-Sha256:
 2dfeccdf4f8247680ca7d0aff684afe95848c5be8893ac6c58d7e57526adb3cb 5864 llvm-toolchain-3.5_3.5.2-4.dsc
 98ae0d38d8fc77feab95120018814d1f9671a75153258c91978eeeb5d451d6e1 54400 llvm-toolchain-3.5_3.5.2-4.debian.tar.xz
Files:
 040aa0d038aeb1a0d15e6b7909c048cf 5864 devel optional llvm-toolchain-3.5_3.5.2-4.dsc
 5f062a470419b436d67d7deeb8fbaf2f 54400 devel optional llvm-toolchain-3.5_3.5.2-4.debian.tar.xz

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v2

iQIcBAEBCAAGBQJX90LOAAoJEPNPCXROn13ZGnkQAKOKWNARSnAomLUrkJdA2E6s
lzfDhYKQRnklytjcL6aCAZXNtHdyeuMqVioA9n7vVb54Ucg/s6PQciSUSWZ4u4P4
4B0L8XqFFcxp93ivPXWl0DBsjzonXJap7eGY282o9q1dAWHhF/V3qubHNggFQzOf
fKMy4z5hmLYirTezvZS0Ama4DQKSgHx4k3lOEepak7HRR+pOHLpFHughNBLd7Hik
9+hluZu84UzFAF5Tvhr5C5/ASCF77Co6ESIbV6fiHbKw4wXkQSr4mVItPzkBSpNS
Hp/HXA7dEOzrWGJbi3uGUqD20G8OI4rncztYY+m1I+6gPGZODAk4mV3YM5SkvnWD
pHVSo993RveQzPHwo9l7ZGN8xUMsOV/Kw672MQ5zzjRJ7ivmKZiqSlCY+A6znPFU
m57pIIUzg16u1snWJE//bM7bqpyCowVDrDcWHgq7xryoD8TG5zmXUhiDT2y6343t
RTAQRE8lMsZf6NlVZYrEDCJsLp0rEyBFUqVq4lHv2LRMk5QWMXWaCBScgsUfrX/L
HrV9ZjBLkmztS+PISJXk7XWCkj4P9SJtZ4g0OBvz3NZrNS1amqoWiOmfJwJd7OA+
zJeJD3jewG10h/TOcvlPcLa/Sy741w5yP+fZtbLmL59VRVzhjjwJGEFA6SbmtZIT
OWVA1nl5vteg0feXisCU
=6SYI
-----END PGP SIGNATURE-----