Bug#836328: gsequencer: FTBFS on non-Linux: ALSA too old (1.0.5 vs. 1.0.25)

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

Bug#836328: gsequencer: FTBFS on non-Linux: ALSA too old (1.0.5 vs. 1.0.25)

Aaron M. Ucko-2
Source: gsequencer
Version: 0.7.62-1
Severity: important
Justification: fails to build from source

Builds of gsequencer on kFreeBSD and the Hurd failed:

  checking for LIBASOUND2... no
  configure: error: Package requirements (alsa >= 1.0.25) were not met:
 
  Requested 'alsa >= 1.0.25' but version of alsa is 1.0.5

Please either accommodate the (emulated, IIRC) version of ALSA
available there or version the build dependency on libasound2-dev
appropriately.

Thanks!

Reply | Threaded
Open this post in threaded view
|

Bug#836328: gsequencer: FTBFS on non-Linux: ALSA too old (1.0.5 vs. 1.0.25)

Joël Krähemann-2
Hi

I'm doing my best to port it. Most of the work has been fulfilled so far. I just
need to add a g_strv_length(), g_strv_contains() and snd_midi_event_decode()
replacement.

Since these functions aren't big it won't take too long. A bigger task would be
adding OSS output.

Bests,
Joël



On Thu, Sep 1, 2016 at 7:15 PM, Aaron M. Ucko <[hidden email]> wrote:

> Source: gsequencer
> Version: 0.7.62-1
> Severity: important
> Justification: fails to build from source
>
> Builds of gsequencer on kFreeBSD and the Hurd failed:
>
>   checking for LIBASOUND2... no
>   configure: error: Package requirements (alsa >= 1.0.25) were not met:
>
>   Requested 'alsa >= 1.0.25' but version of alsa is 1.0.5
>
> Please either accommodate the (emulated, IIRC) version of ALSA
> available there or version the build dependency on libasound2-dev
> appropriately.
>
> Thanks!
>
> _______________________________________________
> pkg-multimedia-maintainers mailing list
> [hidden email]
> http://lists.alioth.debian.org/cgi-bin/mailman/listinfo/pkg-multimedia-maintainers

Reply | Threaded
Open this post in threaded view
|

Bug#836328: gsequencer: FTBFS on non-Linux: ALSA too old (1.0.5 vs. 1.0.25)

Joël Krähemann-2
Hi

Upstream 0.7.64 contains now OSS support however alsa still required in order
to do DSSI and Lv2. I have replaced snd_midi_event_decode() with
ags_midi_buffer_util_decode().

Bests,
Joël


On Mon, Sep 5, 2016 at 10:35 AM, Joël Krähemann <[hidden email]> wrote:

> Hi
>
> I'm doing my best to port it. Most of the work has been fulfilled so far. I just
> need to add a g_strv_length(), g_strv_contains() and snd_midi_event_decode()
> replacement.
>
> Since these functions aren't big it won't take too long. A bigger task would be
> adding OSS output.
>
> Bests,
> Joël
>
>
>
> On Thu, Sep 1, 2016 at 7:15 PM, Aaron M. Ucko <[hidden email]> wrote:
>> Source: gsequencer
>> Version: 0.7.62-1
>> Severity: important
>> Justification: fails to build from source
>>
>> Builds of gsequencer on kFreeBSD and the Hurd failed:
>>
>>   checking for LIBASOUND2... no
>>   configure: error: Package requirements (alsa >= 1.0.25) were not met:
>>
>>   Requested 'alsa >= 1.0.25' but version of alsa is 1.0.5
>>
>> Please either accommodate the (emulated, IIRC) version of ALSA
>> available there or version the build dependency on libasound2-dev
>> appropriately.
>>
>> Thanks!
>>
>> _______________________________________________
>> pkg-multimedia-maintainers mailing list
>> [hidden email]
>> http://lists.alioth.debian.org/cgi-bin/mailman/listinfo/pkg-multimedia-maintainers