Bug#838499: wsjt: 9.7.r3639+dfsg-1 depends on numeric module which has been replaced by numpy

classic Classic list List threaded Threaded
4 messages Options
Reply | Threaded
Open this post in threaded view
|

Bug#838499: wsjt: 9.7.r3639+dfsg-1 depends on numeric module which has been replaced by numpy

Benoit Panizzon-3
Package: wsjt
Version: 9.7.r3639+dfsg-1
Severity: grave
Justification: renders package unusable

Dear Maintainer,

I just installed wsjt from the actual 'sid' releade. Unfortunately the package
is broken because, as I understand, it is depending from the numeric module
which has been replaced by numpy in sid.

$ wsjt
Traceback (most recent call last):
  File "/usr/share/wsjt/wsjt.py", line 17, in <module>
    from Numeric import zeros
ImportError: No module named Numeric


Thank for looking into this.

-Benoit-

-- System Information:
Debian Release: stretch/sid
  APT prefers testing
  APT policy: (500, 'testing'), (500, 'stable')
Architecture: amd64 (x86_64)

Kernel: Linux 4.6.0-1-amd64 (SMP w/2 CPU cores)
Locale: LANG=de_CH.UTF-8, LC_CTYPE=de_CH.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/dash
Init: systemd (via /run/systemd/system)

Versions of packages wsjt depends on:
ii  libc6                                   2.23-5
ii  libfftw3-single3                        3.3.4-2+b1
ii  libgcc1                                 1:6.1.1-11
ii  libgfortran3                            6.1.1-11
ii  libportaudio2                           19+svn20140130-1
ii  libquadmath0                            6.1.1-11
ii  libsamplerate0                          0.1.8-8
ii  lxterminal [x-terminal-emulator]        0.2.0-1
ii  python                                  2.7.11-2
ii  python-imaging                          3.3.1-1
ii  python-imaging-tk                       2.6.1-2+deb8u2
ii  python-numpy                            1:1.11.1~rc1-1
ii  python-pil.imagetk [python-imaging-tk]  3.3.1-1
ii  python-support                          1.0.15
ii  python-tk                               2.7.11-2

wsjt recommends no packages.

wsjt suggests no packages.

-- no debconf information

Reply | Threaded
Open this post in threaded view
|

Re: Bug#838499: wsjt: 9.7.r3639+dfsg-1 depends on numeric module which has been replaced by numpy

Hibby
Hey there - I was going to say I'm sure I'd seen discussion on this already, but that was from you!

I'm fine with that - I think wsjtx supersedes most of the functionality as you highlighted, and if this is going to become more onerous to maintain it's not worth the effort!

Cheers,
DH

--
  Hibby
  [hidden email]
  MM3ZRZ

On Sat, 12 Jan 2019, at 3:09 PM, Christoph Berg wrote:
> Instead of trying to fix wsjt, I think we should remove it from
> Debian, given there is wsjtx. Or is wsjt still useful?
>
> https://lists.debian.org/debian-hams/2019/01/msg00000.html
>
> Christoph
>

Reply | Threaded
Open this post in threaded view
|

Re: Bug#838499: wsjt: 9.7.r3639+dfsg-1 depends on numeric module which has been replaced by numpy

Christoph Berg-2
Re: Hibby 2019-01-15 <[hidden email]>
> Hey there - I was going to say I'm sure I'd seen discussion on this already, but that was from you!
>
> I'm fine with that - I think wsjtx supersedes most of the functionality as you highlighted, and if this is going to become more onerous to maintain it's not worth the effort!

Let's remove wsjt. Thanks!

Christoph

Reply | Threaded
Open this post in threaded view
|

Bug#838499: marked as done (wsjt: 9.7.r3639+dfsg-1 depends on numeric module which has been replaced by numpy)

Debian Bug Tracking System
In reply to this post by Benoit Panizzon-3
Your message dated Wed, 23 Jan 2019 10:09:34 +0000
with message-id <[hidden email]>
and subject line Bug#920196: Removed package(s) from unstable
has caused the Debian Bug report #838499,
regarding wsjt: 9.7.r3639+dfsg-1 depends on numeric module which has been replaced by numpy
to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
Bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what this
message is talking about, this may indicate a serious mail system
misconfiguration somewhere. Please contact [hidden email]
immediately.)


--
838499: https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=838499
Debian Bug Tracking System
Contact [hidden email] with problems

Package: wsjt
Version: 9.7.r3639+dfsg-1
Severity: grave
Justification: renders package unusable

Dear Maintainer,

I just installed wsjt from the actual 'sid' releade. Unfortunately the package
is broken because, as I understand, it is depending from the numeric module
which has been replaced by numpy in sid.

$ wsjt
Traceback (most recent call last):
  File "/usr/share/wsjt/wsjt.py", line 17, in <module>
    from Numeric import zeros
ImportError: No module named Numeric


Thank for looking into this.

-Benoit-

-- System Information:
Debian Release: stretch/sid
  APT prefers testing
  APT policy: (500, 'testing'), (500, 'stable')
Architecture: amd64 (x86_64)

Kernel: Linux 4.6.0-1-amd64 (SMP w/2 CPU cores)
Locale: LANG=de_CH.UTF-8, LC_CTYPE=de_CH.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/dash
Init: systemd (via /run/systemd/system)

Versions of packages wsjt depends on:
ii  libc6                                   2.23-5
ii  libfftw3-single3                        3.3.4-2+b1
ii  libgcc1                                 1:6.1.1-11
ii  libgfortran3                            6.1.1-11
ii  libportaudio2                           19+svn20140130-1
ii  libquadmath0                            6.1.1-11
ii  libsamplerate0                          0.1.8-8
ii  lxterminal [x-terminal-emulator]        0.2.0-1
ii  python                                  2.7.11-2
ii  python-imaging                          3.3.1-1
ii  python-imaging-tk                       2.6.1-2+deb8u2
ii  python-numpy                            1:1.11.1~rc1-1
ii  python-pil.imagetk [python-imaging-tk]  3.3.1-1
ii  python-support                          1.0.15
ii  python-tk                               2.7.11-2

wsjt recommends no packages.

wsjt suggests no packages.

-- no debconf information

Version: 9.7.r3639+dfsg-1.1+rm

Dear submitter,

as the package wsjt has just been removed from the Debian archive
unstable we hereby close the associated bug reports.  We are sorry
that we couldn't deal with your issue properly.

For details on the removal, please see https://bugs.debian.org/920196

The version of this package that was in Debian prior to this removal
can still be found using http://snapshot.debian.org/.

This message was generated automatically; if you believe that there is
a problem with it please contact the archive administrators by mailing
[hidden email].

Debian distribution maintenance software
pp.
Scott Kitterman (the ftpmaster behind the curtain)