Bug#841896: glueviz: Does not work correctly if PyQt5 is installed

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

Bug#841896: glueviz: Does not work correctly if PyQt5 is installed

Yannick Roehlly
Package: glueviz
Version: 0.9.0+dfsg-1
Severity: normal

Hi,

>From version 0.9.0 glue uses QtPy for the GUI.  This one selects the appropriate
PyQt backend among those available, PyQt5 having the highest ranking.  But glue
seems to have problem with Qt5: one can load a dataset but the visualisation
window can't be moved or update (I talked about this with Thomas Robitaille at
ADASS).  One solution is to force the use of PyQt4; this can be done using the
QT_API environment variable, for instance adding this to the glue script:

import os
os.environ['QT_API'] = 'pyqt4'

Regards,

Yannick

-- System Information:
Debian Release: stretch/sid
  APT prefers unstable
  APT policy: (500, 'unstable'), (1, 'experimental')
Architecture: amd64 (x86_64)
Foreign Architectures: i386, x32

Kernel: Linux 4.7.0-1-amd64 (SMP w/8 CPU cores)
Locale: LANG=fr_FR.UTF-8, LC_CTYPE=fr_FR.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/dash
Init: systemd (via /run/systemd/system)

Versions of packages glueviz depends on:
ii  ipython3            2.4.1-1
ii  ipython3-qtconsole  2.4.1-1
ii  python3-glue        0.9.0+dfsg-1
ii  python3-pandas      0.19.0+git14-ga40e185-1
ii  python3-pyqt4       4.11.4+dfsg-2
pn  python3:any         <none>

glueviz recommends no packages.

glueviz suggests no packages.

-- no debconf information