Bug#843341: lxde: installing lxde doesn't give me an LXDE session

classic Classic list List threaded Threaded
4 messages Options
Reply | Threaded
Open this post in threaded view
|

Bug#843341: lxde: installing lxde doesn't give me an LXDE session

Mike Kupfer
Package: lxde
Version: 7
Severity: normal

Dear Maintainer,

Using Synaptic in an XFCE session, I installed the "lxde" package.
After logging out, I expected to be able to select the LXDE session in
the lightdm controls, but LXDE was not listed.  I had to install
lxde-common as well to get an LXDE session.  Also, when installing
lxde-common, I noticed that it, not lxde, pulled in openbox.

I guess lxde-common was not pulled in because I already had a package
installed that provides x-session-manager.  I think that for most
users, this does not provide the right behavior.  And the current
behavior doesn't align with the documentation in
https://wiki.debian.org/LXDE.



-- System Information:
Debian Release: stretch/sid
  APT prefers testing
  APT policy: (500, 'testing')
Architecture: amd64 (x86_64)

Kernel: Linux 4.7.0-1-amd64 (SMP w/1 CPU core)
Locale: LANG=en_US.UTF-8, LC_CTYPE=en_US.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/dash
Init: systemd (via /run/systemd/system)

Versions of packages lxde depends on:
ii  galculator                         2.1.4-1
ii  gpicview                           0.2.5-2
ii  leafpad                            0.8.18.1-5
ii  lxappearance                       0.6.2-1
ii  lxappearance-obconf                0.2.3-1
ii  lxde-common [x-session-manager]    0.99.1-1
ii  lxde-core                          7
ii  lxde-icon-theme                    0.5.1-1
ii  lxinput                            0.3.5-1
ii  lxrandr                            0.3.1-1
ii  lxsession [x-session-manager]      0.5.1-2
pn  lxsession-edit                     <none>
ii  lxterminal                         0.2.0-1
ii  openbox [x-session-manager]        3.6.1-3
ii  xarchiver                          1:0.5.4-5
ii  xfce4-session [x-session-manager]  4.12.1-4

Versions of packages lxde recommends:
pn  alsamixergui                 <none>
pn  clipit                       <none>
pn  deluge | transmission-gtk    <none>
pn  evince-gtk | pdf-viewer      <none>
pn  gnome-disk-utility           <none>
pn  gnome-mplayer                <none>
pn  gnome-system-tools           <none>
ii  gucharmap                    1:9.0.1-1
ii  i3-wm [x-window-manager]     4.12-2
ii  lightdm [x-display-manager]  1.18.2-2
pn  lxmusic | audacious          <none>
ii  lxsession [lxpolkit]         0.5.1-2
pn  menu-xdg                     <none>
ii  network-manager-gnome        1.4.2-1
ii  openbox [x-window-manager]   3.6.1-3
pn  usermode                     <none>
ii  w3m [www-browser]            0.5.3-31
ii  xfwm4 [x-window-manager]     4.12.3-3
ii  xserver-xorg                 1:7.7+16

Versions of packages lxde suggests:
pn  gimp                                <none>
ii  gnome-packagekit [update-notifier]  3.20.0-1
pn  libreoffice                         <none>
pn  lxlauncher                          <none>
pn  lxtask                              <none>
pn  pidgin                              <none>
ii  xfce4-power-manager                 1.4.4-4

-- no debconf information

Reply | Threaded
Open this post in threaded view
|

Bug#843341: lxde: installing lxde doesn't give me an LXDE session

Andriy Grytsenko
control: reassign -1 lxde-common

Thank you very much for reporting this. Apparently this issue is coming
from the fact there is no lxde-session package which is named lxde-common
and therefore many are confused because lxde package is just metapackage
with components but session files itself.

Reply | Threaded
Open this post in threaded view
|

Bug#843341: lxde: installing lxde doesn't give me an LXDE session

Mike Kupfer
Hi Andriy, thanks for the prompt response.

Andriy Grytsenko wrote:

> Thank you very much for reporting this. Apparently this issue is coming
> from the fact there is no lxde-session package which is named lxde-common
> and therefore many are confused because lxde package is just metapackage
> with components but session files itself.

Well, the dependencies in Jessie are set up so that task-lxde-desktop
pulls in lxde; lxde pulls in lxde-core; and lxde-core pulls in
lxde-common; lxde-common contains the xsession file.

This makes it convenient for users:

- if they want a full LXDE desktop with all the standard Debian
  applications, they just install task-lxde-desktop

- if they want a "standard" LXDE desktop, they just install lxde

- if they want a minimal LXDE desktop, they install lxde-core

I think that's the way things should work in Stretch, too.

I'm not sure what fix you have in mind, but I'm guessing that you're
thinking about renaming lxde-common.  If you require users to install
that package in addition to one of the metapackages, you'll make LXDE
more work to install compared to how things are in Jessie.

warm regards,
mike

Reply | Threaded
Open this post in threaded view
|

Bug#843341: lxde: installing lxde doesn't give me an LXDE session

Andriy Grytsenko
Thank you very much for sharing thoughts, I will keep that in mind.