Bug#845772: libconfig-jfdi-perl: uses deprecated Any::Moose

classic Classic list List threaded Threaded
4 messages Options
Reply | Threaded
Open this post in threaded view
|

Bug#845772: libconfig-jfdi-perl: uses deprecated Any::Moose

Niko Tyni-3
Package: libconfig-jfdi-perl
Version: 0.065-1
Severity: normal
User: [hidden email]
Usertags: any-moose autopkgtest

This package uses Any::Moose, which is deprecated. Since
libany-moose-perl_0.27-1, a deprecation warning is issued on usage.

 $ perl -we 'use Config::JFDI'
 Any::Moose is deprecated. Please use Moo instead at /usr/share/perl5/Config/JFDI.pm line 11.

This makes the package fail its autopkgtest checks, see

  http://ci.debian.net/packages/libc/libconfig-jfdi-perl/unstable/amd64/

There's a related thread around

 https://lists.debian.org/debian-perl/2016/11/msg00035.html 

and it's not clear yet if the deprecation warning should be disabled
one way or another. The primary bug of using Any::Moose still remains
of course.
--
Niko Tyni   [hidden email]

Reply | Threaded
Open this post in threaded view
|

Bug#845772: libconfig-jfdi-perl: uses deprecated Any::Moose

intrigeri-4
Control: forwarded -1 https://rt.cpan.org/Ticket/Display.html?id=120987

Hi,

given:

 - Very low popcon

 - Upstream never replied in 3 years on the corresponding bug report.

 - The only reverse-dependency is libmojomojo-perl, which is itself
   low popcon, no upstream release since 3 years, and has a PR open
   since 2 years to migrate it away from Config::JDFI for this exact
   same reason (https://github.com/mojomojo/mojomojo/pull/155),
   with no answer from upstream so far.

I propose we remove both libconfig-jfdi-perl and libmojomojo-perl
from the archive.

Reply | Threaded
Open this post in threaded view
|

Bug#845772: libconfig-jfdi-perl: uses deprecated Any::Moose

gregor herrmann-3
On Sun, 17 May 2020 14:03:42 +0200, intrigeri wrote:

> I propose we remove both libconfig-jfdi-perl and libmojomojo-perl
> from the archive.

Given the popcon values of the packages, I see no problem with
removing them.


Cheers,
gregor

--
 .''`.  https://info.comodo.priv.at -- Debian Developer https://www.debian.org
 : :' : OpenPGP fingerprint D1E1 316E 93A7 60A8 104D  85FA BB3A 6801 8649 AA06
 `. `'  Member VIBE!AT & SPI Inc. -- Supporter Free Software Foundation Europe
   `-   NP: Simon and Garfunkel: Homeward Bound

signature.asc (981 bytes) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Bug#845772: libconfig-jfdi-perl: uses deprecated Any::Moose

intrigeri-4
gregor herrmann (2020-05-17):
> On Sun, 17 May 2020 14:03:42 +0200, intrigeri wrote:
>> I propose we remove both libconfig-jfdi-perl and libmojomojo-perl
>> from the archive.
>
> Given the popcon values of the packages, I see no problem with
> removing them.

RM bugs:

 - #960999 for libmojomojo-perl
 - #961000 for libconfig-jfdi-perl