Bug#845809: libtext-clip-perl: uses deprecated Any::Moose

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

Bug#845809: libtext-clip-perl: uses deprecated Any::Moose

Niko Tyni-3
Package: libtext-clip-perl
Version: 0.14-1
Severity: normal
User: [hidden email]
Usertags: any-moose autopkgtest
Forwarded: https://rt.cpan.org/Public/Bug/Display.html?id=105101

This package uses Any::Moose, which is deprecated. Since
libany-moose-perl_0.27-1, a deprecation warning is issued on usage.

 $ perl -we 'use Text::Clip'
 Any::Moose is deprecated. Please use Moo instead at /usr/share/perl5/Text/Clip.pm line 8.

The package fails its autopkgtest checks due to this; see

  https://ci.debian.net/packages/libt/libtext-clip-perl/unstable/amd64/

The only reverse dependency is libterm-editoredit-perl, which also
use Any::Moose (see #845807).

The upstream ticket has had no comment from the maintainer in 1.5 years.

There's a thread related to Any::Moose around

 https://lists.debian.org/debian-perl/2016/11/msg00035.html 

and it's not clear yet if the deprecation warning should be disabled
one way or another. The primary bug of using Any::Moose still remains
of course.
--
Niko Tyni   [hidden email]

Reply | Threaded
Open this post in threaded view
|

Bug#845809: libtext-clip-perl: uses deprecated Any::Moose

intrigeri-4
Hi,

Niko Tyni (2016-11-26):
> The only reverse dependency is libterm-editoredit-perl, which also
> use Any::Moose (see #845807).

On #845807 I've proposed a way forward to remove
libterm-editoredit-perl.

> The upstream ticket has had no comment from the maintainer in 1.5 years.

… make that 5 years.

Upstream is inactive and popcon is very low.

I propose we remove libtext-clip-perl once libterm-editoredit-perl
is gone.

Reply | Threaded
Open this post in threaded view
|

Bug#845809: libtext-clip-perl: uses deprecated Any::Moose

intrigeri-4
intrigeri (2020-05-17):
> I propose we remove libtext-clip-perl once libterm-editoredit-perl
> is gone.

RM bug: https://bugs.debian.org/961003