Bug#851856: gnome-software: Support for standalone Debian packages still broken on version 3.22.5-1, proposed patch

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

Bug#851856: gnome-software: Support for standalone Debian packages still broken on version 3.22.5-1, proposed patch

Andrea Vettorello
Package: gnome-software
Version: 3.22.5-1
Followup-For: Bug #851856

Hi,

support for local packages installation is still broken on 3.22.5-1.

Looking in the sources, gnome-software uses the wrong MIME type for Debian packages, changing from 'application/x-deb' to 'application/vnd.debian.binary-package' seems to fix installation of standalone debs.

The patch is trivial:

--- gnome-software-3.22.5/src/plugins/gs-plugin-packagekit-local.c 2017-01-16 16:17:50.000000000 +0100
+++ gnome-software-3.22.5-fixed/src/plugins/gs-plugin-packagekit-local.c 2017-06-22 14:23:12.139521525 +0200
@@ -190,7 +190,7 @@
  g_autoptr(GsApp) app = NULL;
  const gchar *mimetypes[] = {
  "application/x-app-package",
- "application/x-deb",
+ "application/vnd.debian.binary-package",
  "application/x-redhat-package-manager",
  "application/x-rpm",
  NULL };


Cheers,

Andrea


-- System Information:
Debian Release: 9.0
  APT prefers stable
  APT policy: (500, 'stable')
Architecture: amd64 (x86_64)

Kernel: Linux 4.9.0-3-amd64 (SMP w/4 CPU cores)
Locale: LANG=en_US.UTF-8, LC_CTYPE=en_US.UTF-8 (charmap=UTF-8), LANGUAGE=en_US.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/dash
Init: systemd (via /run/systemd/system)

Versions of packages gnome-software depends on:
ii  appstream                                    0.10.6-2
ii  dconf-gsettings-backend [gsettings-backend]  0.26.0-2+b1
ii  gnome-software-common                        3.22.5-1
ii  gsettings-desktop-schemas                    3.22.0-1
ii  libappstream-glib8                           0.6.8-1
ii  libatk1.0-0                                  2.22.0-1
ii  libc6                                        2.24-11+deb9u1
ii  libcairo-gobject2                            1.14.8-1
ii  libcairo2                                    1.14.8-1
ii  libenchant1c2a                               1.6.0-11+b1
ii  libfwupd1                                    0.7.4-2
ii  libgdk-pixbuf2.0-0                           2.36.5-2
ii  libglib2.0-0                                 2.50.3-2
ii  libgnome-desktop-3-12                        3.22.2-1
ii  libgtk-3-0                                   3.22.11-1
ii  libgtkspell3-3-0                             3.0.9-1
ii  libgudev-1.0-0                               230-3
ii  libjson-glib-1.0-0                           1.2.6-1
ii  libpackagekit-glib2-18                       1.1.5-2
ii  libpango-1.0-0                               1.40.5-1
ii  libpangocairo-1.0-0                          1.40.5-1
ii  libpolkit-gobject-1-0                        0.105-18
ii  libsecret-1-0                                0.18.5-3.1
ii  libsoup2.4-1                                 2.56.0-2
ii  libsqlite3-0                                 3.16.2-5
ii  packagekit                                   1.1.5-2
ii  software-properties-gtk                      0.96.20.2-1

gnome-software recommends no packages.

Versions of packages gnome-software suggests:
ii  fwupd                          0.7.4-2
ii  gnome-software-plugin-flatpak  3.22.5-1
pn  gnome-software-plugin-limba    <none>

-- no debconf information