Bug#858275: android-platform-system-core: dependency problem

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

Bug#858275: android-platform-system-core: dependency problem

gpe92
Source: android-platform-system-core
Version: 1:7.0.0+r1-3
Severity: normal

Dear Maintainer,

I'm trying to build this package on stable but it complains that android-libext4-utils-dev (>= 7.0.0+r1~) and  android-libf2fs-utils-dev (>= 7.0.0+r1~) dependencies are not present.
So I've tried to build these dependencies from
android-platform-system-extras-7.0.0+r1 but it complains that android-libsparse-dev (>= 1:7.0.0+r1~) and android-platform-system-core-headers (>= 1:7.0.0+r1~) are lacking. But these two package come from android-platform-system-core ...
How can I have resolved this loop dependency?

Best regards.

-- System Information:
Debian Release: 8.7
  APT prefers stable
  APT policy: (1000, 'stable'), (999, 'stable'), (500, 'stable-updates')
Architecture: amd64 (x86_64)
Foreign Architectures: i386

Kernel: Linux 4.9.0-0.bpo.2-amd64 (SMP w/8 CPU cores)
Locale: LANG=fr_FR.utf8, LC_CTYPE=fr_FR.utf8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/bash
Init: systemd (via /run/systemd/system)

Reply | Threaded
Open this post in threaded view
|

Bug#858275: staged builds

Hans-Christoph Steiner

You have to do staged builds to eliminate the circular dependency. See
https://wiki.debian.org/AndroidTools