Bug#859784: Bug #859784: validns: Please migrate to openssl1.1 in Buster

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

Bug#859784: Bug #859784: validns: Please migrate to openssl1.1 in Buster

Joost van Baal-Ilić-77
Hi,

FWIW, this work:

> validns (0.8+git20170804-1) unstable; urgency=medium
>
>   * Upstream fix for https://github.com/tobez/validns/issues/66 RSIG(CAA).
>
>  -- Casper Gielen                             Fri, 04 Aug 2017 10:52:03 +0200
>
> validns (0.8+git20170801-2) unstable; urgency=medium
>
>   * Switch to openssl1.1, patch by Sebastian Andrzej Siewior (Closes: 859784).
>
>  -- Casper Gielen <[hidden email]>  Wed, 02 Aug 2017 17:46:03 +0200
>
> validns (0.8+git20170801-1) unstable; urgency=medium
>
>   * New upstream with support for AAC, CDS, CDNSKEY, SMIMEA resource records.
>   * debian/control Allow both ssl1.0 and ssl1.1 for backwards compatibiltiy.
>   * debian/control Upgrade to Standards-Version 4.0.0 (no changes).
>
>  -- Casper Gielen <[hidden email]>  Tue, 01 Aug 2017 16:52:23 +0200
>
> validns (0.8+git20160720-3) unstable; urgency=medium
>
>   * debian/copyright Add License: statement.
>   * debian/control Upgrade to Standards-Version 3.9.8 (no changes).
>
>  -- Casper Gielen <[hidden email]>  Wed, 14 Dec 2016 16:01:55 +0100
>
> validns (0.8+git20160720-2) unstable; urgency=medium
>
>   * Depend on OpenSSL 1.0 (Closes: #828591)
>
>  -- Casper Gielen <[hidden email]>  Thu, 01 Dec 2016 14:51:30 +0100
>
> validns (0.8+git20160720-1) stable; urgency=medium
>
>   * New upstream with support for INCLUDE.
>
>  -- Casper Gielen <[hidden email]>  Wed, 20 Jul 2016 11:27:36 +0200

is available from
https://non-gnu.uvt.nl/debian/stretch/validns/validns_0.8+git20170804-1.dsc .
I _*might*_ have time to merge this back with what's in the Debian archive,
before the freeze.

HTH, Bye,

Joost

Reply | Threaded
Open this post in threaded view
|

Bug#859784: Bug #859784: validns: Please migrate to openssl1.1 in Buster

Moritz Mühlenhoff-2
On Mon, Nov 05, 2018 at 03:13:08PM +0100, Joost van Baal-Ilić wrote:
> Hi,
>
> FWIW, this work:
>
> > validns (0.8+git20170804-1) unstable; urgency=medium

[..]

> is available from
> https://non-gnu.uvt.nl/debian/stretch/validns/validns_0.8+git20170804-1.dsc .
> I _*might*_ have time to merge this back with what's in the Debian archive,
> before the freeze.

What's the status?

Cheers,
        Moritz

Reply | Threaded
Open this post in threaded view
|

Bug#859784: Bug #859784: validns: Please migrate to openssl1.1 in Buster

Moritz Mühlenhoff-2
On Thu, Jan 10, 2019 at 08:39:36PM +0100, Joost van Baal-Ilić wrote:

> Hi Moritz,
>
> On Thu, Jan 10, 2019 at 08:33:05PM +0100, Moritz Mühlenhoff wrote:
> > On Mon, Nov 05, 2018 at 03:13:08PM +0100, Joost van Baal-Ilić wrote:
> > >
> > > FWIW, this work:
> > >
> > > > validns (0.8+git20170804-1) unstable; urgency=medium
> >
> > [..]
> >
> > > is available from
> > > https://non-gnu.uvt.nl/debian/stretch/validns/validns_0.8+git20170804-1.dsc .
> > > I _*might*_ have time to merge this back with what's in the Debian archive,
> > > before the freeze.
> >
> > What's the status?
>
> Thanks for your interest.  Haven't done any work on it yet.
>
> I'll visit https://wiki.debian.org/BSP/2019/01/nl/Venlo and might get to doing
> some work on it, this weekend.  However, if _you're_ interested in working on
> it: don't wait for me; go for it.

JFTR, there's now only four packages left which depend on OpenSSL 1.0 (and
thus block it's removal, I'll file an RM bug against validns next week),
so there's still time to safe it (or simply reintroduce it later).

Cheers,
        Moritz