Bug#866414: apitrace: depends on obsolete python-imaging (replace with python3-pil or python-pil)

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

Bug#866414: apitrace: depends on obsolete python-imaging (replace with python3-pil or python-pil)

Matthias Klose
Package: src:apitrace
Version: 7.1+git20170623.d38a69d6+repack-1
Severity: important
Tags: sid buster
User: [hidden email]
Usertags: imaging-pillow

One or more binary packages built from this source depends on or
recommends python-imaging, which is obsolete for some years now.
Please build the source using the python-pil package. If your
package doesn't need to be built with Python2, please consider using
Python3 and depend on python3-pil.

Planning to remove python-imaging for the buster release, so the
severity of this issues might be raised.

Reply | Threaded
Open this post in threaded view
|

Bug#866414: marked as done (apitrace: depends on obsolete python-imaging (replace with python3-pil or python-pil))

Debian Bug Tracking System
Your message dated Mon, 08 Jan 2018 10:24:32 +0000
with message-id <[hidden email]>
and subject line Bug#866414: fixed in apitrace 7.1+git20170623.d38a69d6+repack-3
has caused the Debian Bug report #866414,
regarding apitrace: depends on obsolete python-imaging (replace with python3-pil or python-pil)
to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
Bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what this
message is talking about, this may indicate a serious mail system
misconfiguration somewhere. Please contact [hidden email]
immediately.)


--
866414: https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=866414
Debian Bug Tracking System
Contact [hidden email] with problems

Package: src:apitrace
Version: 7.1+git20170623.d38a69d6+repack-1
Severity: important
Tags: sid buster
User: [hidden email]
Usertags: imaging-pillow

One or more binary packages built from this source depends on or
recommends python-imaging, which is obsolete for some years now.
Please build the source using the python-pil package. If your
package doesn't need to be built with Python2, please consider using
Python3 and depend on python3-pil.

Planning to remove python-imaging for the buster release, so the
severity of this issues might be raised.

Source: apitrace
Source-Version: 7.1+git20170623.d38a69d6+repack-3

We believe that the bug you reported is fixed in the latest version of
apitrace, which is due to be installed in the Debian FTP archive.

A summary of the changes between this version and the previous one is
attached.

Thank you for reporting the bug, which will now be closed.  If you
have further comments please address them to [hidden email],
and the maintainer will reopen the bug report if appropriate.

Debian distribution maintenance software
pp.
Timo Aaltonen <[hidden email]> (supplier of updated apitrace package)

(This message was generated automatically at their request; if you
believe that there is a problem with it please contact the archive
administrators by mailing [hidden email])


-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA256

Format: 1.8
Date: Mon, 08 Jan 2018 10:00:54 +0200
Source: apitrace
Binary: apitrace apitrace-gui apitrace-tracers
Architecture: source
Version: 7.1+git20170623.d38a69d6+repack-3
Distribution: unstable
Urgency: medium
Maintainer: Debian X Strike Force <[hidden email]>
Changed-By: Timo Aaltonen <[hidden email]>
Description:
 apitrace   - tools for debugging OpenGL applications and drivers - cli fronten
 apitrace-gui - tools for debugging OpenGL applications and drivers - graphical f
 apitrace-tracers - tools for debugging OpenGL applications and drivers - application
Closes: 866414
Changes:
 apitrace (7.1+git20170623.d38a69d6+repack-3) unstable; urgency=medium
 .
   * control: Migrate to python-pil. (Closes: #866414)
Checksums-Sha1:
 956907dd563fae7bedeaf8276e679b41bb5fcd67 2413 apitrace_7.1+git20170623.d38a69d6+repack-3.dsc
 d03a15557bf1d3b31dba457565abd4cc3de4ebe9 6648 apitrace_7.1+git20170623.d38a69d6+repack-3.debian.tar.xz
Checksums-Sha256:
 2872faaf4dbdd0b7a5529577df35d7b5be72e9e5f1e33d0dc0aa8775605d85d4 2413 apitrace_7.1+git20170623.d38a69d6+repack-3.dsc
 6368ff84f39812bdf0740046687e215c09410fdc3283504f2888797a7f472483 6648 apitrace_7.1+git20170623.d38a69d6+repack-3.debian.tar.xz
Files:
 9565b9ee9fb1be56bd7c781b985de9ab 2413 graphics optional apitrace_7.1+git20170623.d38a69d6+repack-3.dsc
 1b1049fbb69dd8195c33fedea0b3c584 6648 graphics optional apitrace_7.1+git20170623.d38a69d6+repack-3.debian.tar.xz

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1

iQIcBAEBCAAGBQJaUz8kAAoJEMtwMWWoiYTcirYP/j99EKIgz2BwMT9u2f7T04XL
xvo4a1HQ1kSFUisrw8zEBU5veIvCffTAVyKuLZNatCmLr06rwa3Pv79xZ/UXXQ3w
zad553KVgtk3zB/oFomA8BYWjSiNtLxWNWBGSmRpKweviDDnG362w6sEzYZ559fF
2tKYea/Fh1Tjcjdw1HTShKPpppLcOBOH0cW1CDWRnY0PE7vnwe7RVGoj7mrUH5Nn
t+HlDbSMnqC13nRwk+cddFcWGayrqzltG2bAN0NX3OS6G6WLrjhZw4zBchWJkavV
A8ycKdgRzup1F0dKCPk81Chv8+2cs+X+AOMfdu3j95PGvWYQrmyo4h3+rlS7bXXH
mtJp3/66vIfkYxVOAGYIsOLSKL15G7T7m5d6ptkcQGN5qzIbbhYWP2Bb+BNRdr/s
D6vt33zsbS/eTamgT7ULy7WCYKeUPeRYgOaK7HGqCH47et6WFaIKAD4nswfTVap2
Mf2r5uBgVsFWgQffAn1o0nGwZ2q95iRBA2EB/R/SPH/Ci+RVxkB7To08Nsobwicw
mH6VmXqUyYrs50oPxDEZzEuLMGLLFYk9ca2RF2gUQ/VIJ+KPl1xFL/njjH4+PkPT
kMzlEs09CN+tGjkoaOglcavGhma2f/lsInyVzHxCxhTgvpuxmKDRgi9nCArnfbIO
CIWLSxzg3VMYKxmTrR35
=ptEk
-----END PGP SIGNATURE-----