Bug#869186: mutt: Install missing required dependencies (libxapian30)

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

Bug#869186: mutt: Install missing required dependencies (libxapian30)

Boruch Baum
Subject: mutt: Install missing required dependencies (libxapian30)
Package: mutt
Version: 1.7.2-1
Severity: serious

Dear Maintainer,

Upon upgrading `mutt' from the stable to testing repositories, mutt
ceased to function, offering the following error message:

   #+BEGIN_SRC conf
   mutt: symbol lookup error:  /usr/lib/x86_64-linux-gnu/libnotmuch.so.4:
   undefined symbol:
_ZN6Xapian9Compactor26resolve_duplicate_metadataERKNSt7__cxx1112basic_stringIcSt11char_traitsIcESaIcEEEmPS7_
   #+End_SRC

Performing the following fixed the problem for me:

   #+BEGIN_SRC conf
   apt-get install libxapian30

   The following packages will be upgraded:
     libxapian-dev libxapian30 xapian-tools
   #+END_SRC


-- Package-specific info:
NeoMutt 20170113 (1.7.2)
Copyright (C) 1996-2016 Michael R. Elkins and others.
Mutt comes with ABSOLUTELY NO WARRANTY; for details type `mutt -vv'.
Mutt is free software, and you are welcome to redistribute it
under certain conditions; type `mutt -vv' for details.

System: Linux 4.9.0-2-grsec-amd64 (x86_64)
libidn: 1.29 (compiled with 1.33)
hcache backends: tokyocabinet

Compiler:
Using built-in specs.
COLLECT_GCC=gcc
COLLECT_LTO_WRAPPER=/usr/lib/gcc/x86_64-linux-gnu/6/lto-wrapper
Target: x86_64-linux-gnu
Configured with: ../src/configure -v --with-pkgversion='Debian 6.3.0-2' --with-bugurl=file:///usr/share/doc/gcc-6/README.Bugs --enable-languages=c,ada,c++,java,go,d,fortran,objc,obj-c++ --prefix=/usr --program-suffix=-6 --program-prefix=x86_64-linux-gnu- --enable-shared --enable-linker-build-id --libexecdir=/usr/lib --without-included-gettext --enable-threads=posix --libdir=/usr/lib --enable-nls --with-sysroot=/ --enable-clocale=gnu --enable-libstdcxx-debug --enable-libstdcxx-time=yes --with-default-libstdcxx-abi=new --enable-gnu-unique-object --disable-vtable-verify --enable-libmpx --enable-plugin --enable-default-pie --with-system-zlib --disable-browser-plugin --enable-java-awt=gtk --enable-gtk-cairo --with-java-home=/usr/lib/jvm/java-1.5.0-gcj-6-amd64/jre --enable-java-home --with-jvm-root-dir=/usr/lib/jvm/java-1.5.0-gcj-6-amd64 --with-jvm-jar-dir=/usr/lib/jvm-exports/java-1.5.0-gcj-6-amd64 --with-arch-directory=amd64 --with-ecj-jar=/usr/share/java/eclipse-ecj.jar --with-target-system-zlib --enable-objc-gc=auto --enable-multiarch --with-arch-32=i686 --with-abi=m64 --with-multilib-list=m32,m64,mx32 --enable-multilib --with-tune=generic --enable-checking=release --build=x86_64-linux-gnu --host=x86_64-linux-gnu --target=x86_64-linux-gnu
Thread model: posix
gcc version 6.3.0 20161229 (Debian 6.3.0-2)

Configure options: '--build=x86_64-linux-gnu' '--prefix=/usr' '--includedir=\${prefix}/include' '--mandir=\${prefix}/share/man' '--infodir=\${prefix}/share/info' '--sysconfdir=/etc' '--localstatedir=/var' '--disable-silent-rules' '--libdir=\${prefix}/lib/x86_64-linux-gnu' '--libexecdir=\${prefix}/lib/x86_64-linux-gnu' '--disable-maintainer-mode' '--disable-dependency-tracking' '--with-mailpath=/var/mail' '--enable-compressed' '--enable-debug' '--enable-fcntl' '--enable-hcache' '--enable-gpgme' '--enable-imap' '--enable-smtp' '--enable-pop' '--enable-sidebar' '--enable-nntp' '--enable-notmuch' '--disable-fmemopen' '--with-curses' '--with-gnutls' '--with-gss' '--with-idn' '--with-mixmaster' '--with-sasl' '--without-gdbm' '--without-bdb' '--without-qdbm' '--with-tokyocabinet' 'build_alias=x86_64-linux-gnu' 'CFLAGS=-g -O2 -fdebug-prefix-map=/build/mutt-K2ak0h/mutt-1.7.2=. -fstack-protector-strong -Wformat -Werror=format-security' 'LDFLAGS=-Wl,-z,relro -Wl,-z,now' 'CPPFLAGS=-Wdate-time -D_FORTIFY_SOURCE=2'

Compilation CFLAGS: -Wall -pedantic -Wno-long-long -g -O2 -fdebug-prefix-map=/build/mutt-K2ak0h/mutt-1.7.2=. -fstack-protector-strong -Wformat -Werror=format-security -fno-delete-null-pointer-checks

Compile options:
+CRYPT_BACKEND_CLASSIC_PGP +CRYPT_BACKEND_CLASSIC_SMIME +CRYPT_BACKEND_GPGME
+DEBUG +DL_STANDALONE +ENABLE_NLS -EXACT_ADDRESS -HOMESPOOL -LOCALES_HACK
-SUN_ATTACHMENT +HAVE_BKGDSET +HAVE_COLOR +HAVE_CURS_SET +HAVE_FUTIMENS
+HAVE_GETADDRINFO +HAVE_GETSID +HAVE_ICONV +HAVE_LANGINFO_CODESET
+HAVE_LANGINFO_YESEXPR +HAVE_LIBIDN +HAVE_META +HAVE_REGCOMP +HAVE_RESIZETERM
+HAVE_START_COLOR +HAVE_TYPEAHEAD +HAVE_WC_FUNCS +ICONV_NONTRANS
+USE_COMPRESSED +USE_DOTLOCK +USE_FCNTL -USE_FLOCK -USE_FMEMOPEN -USE_GNU_REGEX
+USE_GSS +USE_HCACHE +USE_IMAP +USE_NOTMUCH +USE_NNTP +USE_POP +USE_SASL
+USE_SETGID +USE_SIDEBAR +USE_SMTP +USE_SSL_GNUTLS -USE_SSL_OPENSSL
-DOMAIN
MIXMASTER="mixmaster"
-ISPELL
SENDMAIL="/usr/sbin/sendmail"
MAILPATH="/var/mail"
PKGDATADIR="/usr/share/mutt"
SYSCONFDIR="/etc"
EXECSHELL="/bin/sh"

patch-attach-headers-color-neomutt
patch-compose-to-sender-neomutt
patch-compress-neomutt
patch-cond-date-neomutt
patch-encrypt-to-self-neomutt
patch-fmemopen-neomutt
patch-forgotten-attachments-neomutt
patch-forwref-neomutt
patch-ifdef-neomutt
patch-index-color-neomutt
patch-initials-neomutt
patch-keywords-neomutt
patch-kyoto-neomutt
patch-limit-current-thread-neomutt
patch-lmdb-neomutt
patch-multiple-fcc-neomutt
patch-nested-if-neomutt
patch-new-mail-neomutt
patch-nntp-neomutt
patch-notmuch-neomutt
patch-progress-neomutt
patch-quasi-delete-neomutt
patch-reply-with-xorig-neomutt
patch-sensible-browser-neomutt
patch-sidebar-neomutt
patch-skip-quoted-neomutt
patch-status-color-neomutt
patch-timeout-neomutt
patch-tls-sni-neomutt
patch-trash-neomutt

To learn more about NeoMutt, visit: http://www.neomutt.org/
If you find a bug in NeoMutt, please raise an issue at:
    https://github.com/neomutt/neomutt/issues
or send an email to: <[hidden email]>


-- System Information:
Distributor ID: Devuan
Description: Devuan GNU/Linux 1.0 (jessie)
Release: 1.0
Codename: jessie
Architecture: x86_64

Kernel: Linux 4.9.0-2-grsec-amd64 (SMP w/4 CPU cores)
Locale: LANG=en_US.UTF-8, LC_CTYPE=en_US.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/dash
Init: sysvinit (via /sbin/init)

Versions of packages mutt depends on:
ii  libassuan0        2.4.3-2~bpo8+1
ii  libc6             2.24-11
ii  libcomerr2        1.43.3-1~bpo8+1
ii  libgnutls30       3.5.8-6
ii  libgpg-error0     1.26-2
ii  libgpgme11        1.5.1-6
ii  libgssapi-krb5-2  1.15-1
ii  libidn11          1.29-1+deb8u2
ii  libk5crypto3      1.15-1
ii  libkrb5-3         1.15-1
ii  libncursesw5      6.0+20161126-1
ii  libnotmuch4       0.23.7-3
ii  libsasl2-2        2.1.26.dfsg1-13+deb8u1
ii  libtinfo5         6.0+20161126-1
ii  libtokyocabinet9  1.4.48-3

Versions of packages mutt recommends:
ii  libsasl2-modules  2.1.26.dfsg1-13+deb8u1
ii  locales           2.24-12
ii  mime-support      3.58

Versions of packages mutt suggests:
ii  aspell                                     0.60.7~20110707-1.3
ii  ca-certificates                            20141019+deb8u3
ii  exim4-daemon-light [mail-transport-agent]  4.89-2+deb9u1~bpo8+1
ii  gnupg                                      2.1.18-6
ii  ispell                                     3.3.02-6
pn  mixmaster                                  <none>
ii  openssl                                    1.0.2l-1~bpo8+1
ii  urlview                                    0.9-20+b1

Versions of packages mutt is related to:
ii  mutt  1.7.2-1

-- debconf information:
Unescaped left brace in regex is deprecated, passed through in regex; marked by <-- HERE in m/^(.*?)(\\)?\${ <-- HERE ([^{}]+)}(.*)$/ at /usr/share/perl5/Debconf/Question.pm line 72.
Unescaped left brace in regex is deprecated, passed through in regex; marked by <-- HERE in m/\${ <-- HERE ([^}]+)}/ at /usr/share/perl5/Debconf/Config.pm line 30.

--
hkp://keys.gnupg.net
CA45 09B5 5351 7C11 A9D1  7286 0036 9E45 1595 8BC0

Reply | Threaded
Open this post in threaded view
|

Bug#869186: [Pkg-mutt-maintainers] Bug#869186: mutt: Install missing required dependencies (libxapian30)

Evgeni Golov-2
Hi,

On Fri, Jul 21, 2017 at 07:02:50AM -0400, Boruch Baum wrote:
> Upon upgrading `mutt' from the stable to testing repositories, mutt
> ceased to function, offering the following error message:

There is no mutt 1.7.2-1 in testing. Did you mean upgrading
jessie→stretch?

>    #+BEGIN_SRC conf
>    mutt: symbol lookup error:  /usr/lib/x86_64-linux-gnu/libnotmuch.so.4:
>    undefined symbol:
> _ZN6Xapian9Compactor26resolve_duplicate_metadataERKNSt7__cxx1112basic_stringIcSt11char_traitsIcESaIcEEEmPS7_
>    #+End_SRC
>
> Performing the following fixed the problem for me:
>
>    #+BEGIN_SRC conf
>    apt-get install libxapian30
>
>    The following packages will be upgraded:
>      libxapian-dev libxapian30 xapian-tools
>    #+END_SRC

¯\_(ツ)_/¯

mutt has a dependency on libnotmuch4, libnotmuch4 has a dependency on
libxapian30, mutt is not using any xapian directly AFAIK.

so we might discuss this as being a not-strong-enough dep between
libnotmuch4 and libxapian30, but not a serios bug in mutt.

> -- System Information:
> Distributor ID: Devuan
> Description: Devuan GNU/Linux 1.0 (jessie)
> Release: 1.0
> Codename: jessie
> Architecture: x86_64

Why do you have mutt from stretch on a jessie(-derived) system?