Bug#872553: synaptic: Segmentation fault

classic Classic list List threaded Threaded
9 messages Options
Reply | Threaded
Open this post in threaded view
|

Bug#872553: synaptic: Segmentation fault

zaoqi
Package: synaptic
Version: 0.84.2
Severity: grave
Tags: security
Justification: renders package unusable

Segmentation fault



-- System Information:
Debian Release: buster/sid
  APT prefers unstable
  APT policy: (500, 'unstable')
Architecture: amd64 (x86_64)

Kernel: Linux 4.12.0-1-amd64 (SMP w/4 CPU cores)
Locale: LANG=zh_CN.UTF-8, LC_CTYPE=zh_CN.UTF-8 (charmap=UTF-8), LANGUAGE=zh_CN:zh (charmap=UTF-8)
Shell: /bin/sh linked to /bin/dash
Init: systemd (via /run/systemd/system)

Versions of packages synaptic depends on:
ii  hicolor-icon-theme   0.15-1
ii  libapt-inst2.0       1.5~beta2
ii  libapt-pkg5.0        1.5~beta2
ii  libatk1.0-0          2.24.0-1
ii  libc6                2.24-14
ii  libcairo-gobject2    1.14.10-1
ii  libcairo2            1.14.10-1
ii  libept1.5.0          1.1+nmu3+b1
ii  libgcc1              1:7.1.0-13
ii  libgdk-pixbuf2.0-0   2.36.5-2
ii  libglib2.0-0         2.53.4-3
ii  libgnutls30          3.5.14-2
ii  libgtk-3-0           3.22.18-1
ii  libpango-1.0-0       1.40.9-1
ii  libpangocairo-1.0-0  1.40.9-1
ii  libpcre2-8-0         10.22-3
ii  libstdc++6           7.1.0-13
ii  libvte-2.91-0        0.46.2-1
ii  libx11-6             2:1.6.4-3
ii  libxapian30          1.4.4-2
ii  policykit-1          0.105-18
ii  zlib1g               1:1.2.8.dfsg-5

Versions of packages synaptic recommends:
ii  libgtk2-perl   2:1.24992-1+b1
ii  rarian-compat  0.8.1-6+b1
ii  xdg-utils      1.1.1-1

Versions of packages synaptic suggests:
pn  apt-xapian-index         <none>
pn  deborphan                <none>
pn  dwww                     <none>
pn  menu                     <none>
ii  software-properties-gtk  0.96.20.2-1
ii  tasksel                  3.39

-- no debconf information

Reply | Threaded
Open this post in threaded view
|

Bug#872553: synaptic: Segmentation fault

Schmidt Cristian Hernan
Package: synaptic
Version: 0.84.2
Followup-For: Bug #872553

Segmentation fault when it is executed



-- System Information:
Debian Release: buster/sid
  APT prefers proposed-updates
  APT policy: (500, 'proposed-updates'), (500, 'testing'), (500, 'stable')
Architecture: amd64 (x86_64)
Foreign Architectures: i386

Kernel: Linux 4.11.0-1-amd64 (SMP w/4 CPU cores)
Locale: LANG=es_AR.UTF-8, LC_CTYPE=es_AR.UTF-8 (charmap=UTF-8), LANGUAGE=es_AR:es (charmap=UTF-8)
Shell: /bin/sh linked to /bin/dash
Init: systemd (via /run/systemd/system)

Versions of packages synaptic depends on:
ii  hicolor-icon-theme   0.15-1
ii  libapt-inst2.0       1.5~beta1
ii  libapt-pkg5.0        1.5~beta1
ii  libatk1.0-0          2.24.0-1
ii  libc6                2.24-14
ii  libcairo-gobject2    1.14.10-1
ii  libcairo2            1.14.10-1
ii  libept1.5.0          1.1+nmu3+b1
ii  libgcc1              1:7.1.0-13
ii  libgdk-pixbuf2.0-0   2.36.5-2
ii  libglib2.0-0         2.53.4-3
ii  libgnutls30          3.5.14-2
ii  libgtk-3-0           3.22.18-1
ii  libpango-1.0-0       1.40.6-1
ii  libpangocairo-1.0-0  1.40.6-1
ii  libpcre2-8-0         10.22-3
ii  libstdc++6           7.1.0-13
ii  libvte-2.91-0        0.46.2-1
ii  libx11-6             2:1.6.4-3
ii  libxapian30          1.4.4-2
ii  policykit-1          0.105-18
ii  zlib1g               1:1.2.8.dfsg-5

Versions of packages synaptic recommends:
ii  libgtk2-perl   2:1.24992-1+b1
ii  rarian-compat  0.8.1-6+b1
ii  xdg-utils      1.1.1-1

Versions of packages synaptic suggests:
pn  apt-xapian-index         <none>
ii  deborphan                1.7.28.8-0.3+b1
pn  dwww                     <none>
ii  menu                     2.1.47+b1
ii  software-properties-gtk  0.96.20.2-1
ii  tasksel                  3.39

-- no debconf information

Reply | Threaded
Open this post in threaded view
|

Processed: Re: synaptic: Segmentation fault when program starts

Debian Bug Tracking System
In reply to this post by zaoqi
Processing control commands:

> retitle -1 synaptic: Segmentation fault when program starts
Bug #872553 [synaptic] synaptic: Segmentation fault
Changed Bug title to 'synaptic: Segmentation fault when program starts' from 'synaptic: Segmentation fault'.

--
872553: https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=872553
Debian Bug Tracking System
Contact [hidden email] with problems

Reply | Threaded
Open this post in threaded view
|

Bug#872553: RC bugs in synaptic

Paul Gevers-4
In reply to this post by zaoqi
Hi Michael, all,

On Fri, 18 Aug 2017 21:02:21 +0800 zaoqi <[hidden email]> wrote:
> Segmentation fault

Can you please update us on the status of the two RC bugs that are filed
against synaptic? Has there been any progress? Do you believe that this
is still happening? Do these bugs actually have the same root cause (as
a noted solution is the same)?

Paul


signature.asc (499 bytes) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Bug#872553: RC bugs in synaptic

Paul Gevers-4
In reply to this post by zaoqi
forcemerge 818366 872553 897348
severity 818366 serious
clone 818366 -1
reassign -1 release-notes
retitle -1 synaptic and other apps don't work on Wayland
severity -1 normal
thanks

Hi Jeremy,

On 05-03-2019 08:04, Jeremy Bicha wrote:
> These bugs are almost certainly duplicate of https://bugs.debian.org/818366
>
> Could you handle marking them as duplicates? (Sorry, I find it tedious
> to do that in Debian.)

Done per above with the first command to [hidden email]

> I don't think Synaptic is going to work on Wayland in time for Buster
> regardless of how many RC bugs we file against it. Maybe severity:
> important is good enough

If synaptic isn't working at all in the default desktop with the default
way of logging in, is it a service to our users if we ship synaptic at
all with buster? I'm not convinced of that, so I left the bug at RC
level. Or am I missing something from your explanation?

> with a mention in the Release Notes that
> Debian GNOME uses Wayland by default and you'll need to log in to
> "GNOME on Xorg" if you want to use certain apps like Synaptic or most
> screen recording apps.

And cloned the bug against the release-notes to have that end up there.

Paul


signature.asc (499 bytes) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Processed (with 4 errors): Re: RC bugs in synaptic

Debian Bug Tracking System
Processing commands for [hidden email]:

> forcemerge 818366 872553 897348
Bug #818366 [synaptic] synaptic: fails to start under Wayland
Bug #824122 [synaptic] synaptic: can't open synaptic when using gnome-wayland
Bug #818366 [synaptic] synaptic: fails to start under Wayland
Marked as found in versions synaptic/0.84.2.
Marked as found in versions synaptic/0.84.2 and synaptic/0.84.3.
Bug #872553 [synaptic] synaptic: Segmentation fault when program starts
Severity set to 'important' from 'grave'
Marked as found in versions synaptic/0.83 and synaptic/0.84.3.
Bug #897348 [synaptic] synaptic: Unable to init server: Could not connect: Connection refused
Severity set to 'important' from 'grave'
Marked as found in versions synaptic/0.83 and synaptic/0.84.2.
Bug #824122 [synaptic] synaptic: can't open synaptic when using gnome-wayland
Merged 818366 824122 872553 897348
> severity 818366 serious
Bug #818366 [synaptic] synaptic: fails to start under Wayland
Bug #824122 [synaptic] synaptic: can't open synaptic when using gnome-wayland
Bug #872553 [synaptic] synaptic: Segmentation fault when program starts
Bug #897348 [synaptic] synaptic: Unable to init server: Could not connect: Connection refused
Severity set to 'serious' from 'important'
Severity set to 'serious' from 'important'
Severity set to 'serious' from 'important'
Severity set to 'serious' from 'important'
> clone 818366 -1
Bug #818366 [synaptic] synaptic: fails to start under Wayland
Bug #824122 [synaptic] synaptic: can't open synaptic when using gnome-wayland
Bug #872553 [synaptic] synaptic: Segmentation fault when program starts
Bug #897348 [synaptic] synaptic: Unable to init server: Could not connect: Connection refused
Failed to clone 818366: Bug is marked as being merged with others. Use an existing clone.

> reassign -1 release-notes
Failed to clear fixed versions and reopen on -1: The 'bug' parameter ("-1") to Debbugs::Control::set_package did not pass regex check
.

> retitle -1 synaptic and other apps don't work on Wayland
Failed to set the title of -1: The 'bug' parameter ("-1") to Debbugs::Control::set_title did not pass regex check
.

> severity -1 normal
Failed to set severity of Bug -1 to normal: The 'bug' parameter ("-1") to Debbugs::Control::set_severity did not pass regex check
.

> thanks
Stopping processing here.

Please contact me if you need assistance.
--
818366: https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=818366
824122: https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=824122
872553: https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=872553
897348: https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=897348
Debian Bug Tracking System
Contact [hidden email] with problems

Reply | Threaded
Open this post in threaded view
|

Bug#872553: RC bugs in synaptic

Jeremy Bicha-5
In reply to this post by Paul Gevers-4
On Tue, Mar 5, 2019 at 5:06 AM Paul Gevers <[hidden email]> wrote:
> If synaptic isn't working at all in the default desktop with the default
> way of logging in, is it a service to our users if we ship synaptic at
> all with buster? I'm not convinced of that, so I left the bug at RC
> level. Or am I missing something from your explanation?

synaptic isn't installed by default in new Debian GNOME Buster
installs. I don't think it's necessary to remove software that doesn't
work in GNOME on Wayland. (For example, vino only works with GNOME on
Xorg but it's a very useful feature there. GNOME on Wayland has
gnome-remote-desktop but it's a bit immature still.) synaptic is a
very popular Debian-specific app among certain users.

As a workaround, I think it would be helpful if synaptic could report
a more helpful error message so that people can understand that they
can't use Synaptic in a Wayland session.

Please check your clone commands. I don't think they worked here.

Thanks,
Jeremy Bicha

Reply | Threaded
Open this post in threaded view
|

Bug#872553: RC bugs in synaptic

Paul Gevers-4
Hi,

On 05-03-2019 13:08, Jeremy Bicha wrote:
> synaptic isn't installed by default in new Debian GNOME Buster
> installs. I don't think it's necessary to remove software that doesn't
> work in GNOME on Wayland.

How do users find out that Wayland is the cause, and that they can run
the program in other environments? This strikes me as very user
unfriendly in the default environment that we ship for programs that
have worked properly in the default for a long time.

> (For example, vino only works with GNOME on
> Xorg but it's a very useful feature there. GNOME on Wayland has
> gnome-remote-desktop but it's a bit immature still.) synaptic is a
> very popular Debian-specific app among certain users.

I used to use synaptic myself long time ago. I would find it very weird
from Debian standards if it would fail with the errors I have seen in
the bug reports.

> As a workaround, I think it would be helpful if synaptic could report
> a more helpful error message so that people can understand that they
> can't use Synaptic in a Wayland session.

Personally I would really want to see this happening if we want to ship
synaptic in buster.

> Please check your clone commands. I don't think they worked here.

I noticed. Thanks for the reminder though.

Paul


signature.asc (499 bytes) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Bug#872553: marked as done (synaptic: Segmentation fault when program starts)

Debian Bug Tracking System
In reply to this post by zaoqi
Your message dated Mon, 15 Apr 2019 20:25:29 +0800
with message-id <CAFyCLW_vXG+1RF0US5isSBh=[hidden email]>
and subject line Re: Bug#818366: synaptic: fails to start under Wayland
has caused the Debian Bug report #818366,
regarding synaptic: Segmentation fault when program starts
to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
Bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what this
message is talking about, this may indicate a serious mail system
misconfiguration somewhere. Please contact [hidden email]
immediately.)


--
818366: https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=818366
Debian Bug Tracking System
Contact [hidden email] with problems

Package: synaptic
Version: 0.84.2
Severity: grave
Tags: security
Justification: renders package unusable

Segmentation fault



-- System Information:
Debian Release: buster/sid
  APT prefers unstable
  APT policy: (500, 'unstable')
Architecture: amd64 (x86_64)

Kernel: Linux 4.12.0-1-amd64 (SMP w/4 CPU cores)
Locale: LANG=zh_CN.UTF-8, LC_CTYPE=zh_CN.UTF-8 (charmap=UTF-8), LANGUAGE=zh_CN:zh (charmap=UTF-8)
Shell: /bin/sh linked to /bin/dash
Init: systemd (via /run/systemd/system)

Versions of packages synaptic depends on:
ii  hicolor-icon-theme   0.15-1
ii  libapt-inst2.0       1.5~beta2
ii  libapt-pkg5.0        1.5~beta2
ii  libatk1.0-0          2.24.0-1
ii  libc6                2.24-14
ii  libcairo-gobject2    1.14.10-1
ii  libcairo2            1.14.10-1
ii  libept1.5.0          1.1+nmu3+b1
ii  libgcc1              1:7.1.0-13
ii  libgdk-pixbuf2.0-0   2.36.5-2
ii  libglib2.0-0         2.53.4-3
ii  libgnutls30          3.5.14-2
ii  libgtk-3-0           3.22.18-1
ii  libpango-1.0-0       1.40.9-1
ii  libpangocairo-1.0-0  1.40.9-1
ii  libpcre2-8-0         10.22-3
ii  libstdc++6           7.1.0-13
ii  libvte-2.91-0        0.46.2-1
ii  libx11-6             2:1.6.4-3
ii  libxapian30          1.4.4-2
ii  policykit-1          0.105-18
ii  zlib1g               1:1.2.8.dfsg-5

Versions of packages synaptic recommends:
ii  libgtk2-perl   2:1.24992-1+b1
ii  rarian-compat  0.8.1-6+b1
ii  xdg-utils      1.1.1-1

Versions of packages synaptic suggests:
pn  apt-xapian-index         <none>
pn  deborphan                <none>
pn  dwww                     <none>
pn  menu                     <none>
ii  software-properties-gtk  0.96.20.2-1
ii  tasksel                  3.39

-- no debconf information

Source: synaptic
Source-Version: 0.84.6

Forget to mention in Changelog, synaptic/0.84.6 can start on wayland
now, but without administrative privileges, which means you can start
synaptic in a read-only mode on wayland.

Although it's not a perfect solution, but "fails to start under
Wayland" is fixed.

Changes:
 synaptic (0.84.6) unstable; urgency=medium
 .
   [ sajolida ]
   * Give visual feedback while starting
 .
   [ Shengjing Zhu ]
   * configure.in: Miss bumping version str to 0.84.5
   * synaptic-pkexec: Do not use pkexec under Wayland; warn users instead
   * gsynaptic: Show possible reason when failed to init gtk
 .
   [ Michael Vogt ]
   * configure.in: Bump version to 0.84.6