Bug#886949: xfce4-indicator-plugin: Not all indicator icons are being shown (steam, qjoypad, caffeine, ...). Please, help to debug.

classic Classic list List threaded Threaded
6 messages Options
Reply | Threaded
Open this post in threaded view
|

Bug#886949: xfce4-indicator-plugin: Not all indicator icons are being shown (steam, qjoypad, caffeine, ...). Please, help to debug.

Sophoklis Goumas-2
Package: xfce4-indicator-plugin
Version: 2.3.3-1
Severity: important

Hello.

I've been missing some of my regular indicator icons
while others still show OK. I would appreciate any tips
and guidance on how to debug this.

Indicator icons shown:
thunar, transmission-gtk, discord, audacious, ...
Indicator icons NOT shown:
caffeine, qjoypad [1] , caffeine, ...

Thanks in advance,
Sophoklis

[1] Please not I'm using a github fork not the packaged one:
    https://github.com/panzi/qjoypad

-- System Information:
Debian Release: buster/sid
  APT prefers stable-updates
  APT policy: (500, 'stable-updates'), (500, 'unstable'), (500, 'testing'), (500, 'stable'), (500, 'oldstable')
Architecture: amd64 (x86_64)
Foreign Architectures: i386

Kernel: Linux 4.9.0-4-amd64 (SMP w/8 CPU cores)
Locale: LANG=en_US.utf8, LC_CTYPE=en_US.utf8 (charmap=UTF-8), LANGUAGE=en_US:en (charmap=UTF-8)
Shell: /bin/sh linked to /bin/dash
Init: systemd (via /run/systemd/system)

Versions of packages xfce4-indicator-plugin depends on:
ii  libatk1.0-0              2.26.1-1
ii  libayatana-ido3-0.4-0    0.4.1-1
ii  libayatana-indicator3-7  0.6.1-1
ii  libc6                    2.25-2
ii  libcairo-gobject2        1.15.8-2
ii  libcairo2                1.15.8-2
ii  libdbus-1-3              1.12.2-1
ii  libdbus-glib-1-2         0.108-3
ii  libgdk-pixbuf2.0-0       2.36.11-1
ii  libglib2.0-0             2.54.2-1
ii  libgtk-3-0               3.22.26-2
ii  libpango-1.0-0           1.40.13-2
ii  libpangocairo-1.0-0      1.40.13-2
ii  libxfce4panel-2.0-4      4.12.1-2
ii  libxfce4ui-2-0           4.12.1-2
ii  libxfce4util7            4.12.1-3
ii  libxfconf-0-2            4.12.1-1

Versions of packages xfce4-indicator-plugin recommends:
ii  ayatana-indicator-application  0.5.2-1

xfce4-indicator-plugin suggests no packages.

-- no debconf information

Reply | Threaded
Open this post in threaded view
|

Bug#886949: xfce4-indicator-plugin: Not all indicator icons are being shown (steam, qjoypad, caffeine, ...). Please, help to debug.

Mike Gabriel-4
Hi,

this bug will very likely be fixed after the patch in #893639 has been  
applied.

@ Sophoklis: Maybe you can test-build xfce4-indicator-plugin and test  
the patch as found in #893639?

Thanks,
Mike
--

DAS-NETZWERKTEAM
mike gabriel, herweg 7, 24357 fleckeby
mobile: +49 (1520) 1976 148
landline: +49 (4354) 8390 139

GnuPG Fingerprint: 9BFB AEE8 6C0A A5FF BF22  0782 9AF4 6B30 2577 1B31
mail: [hidden email], http://das-netzwerkteam.de


attachment0 (868 bytes) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Bug#886949: xfce4-indicator-plugin: Not all indicator icons are being shown. Please, help to debug.

Sophoklis Goumas-2
In reply to this post by Sophoklis Goumas-2
Package: xfce4-indicator-plugin
Version: 2.3.3-1.1
Followup-For: Bug #886949

Mike, I applied the mentioned patch to the package but unfortunately
the problem still remains, no improvements done. Did it resolve this for you?

Sophoklis

Reply | Threaded
Open this post in threaded view
|

Bug#886949: xfce4-indicator-plugin: Not all indicator icons are being shown. Please, help to debug.

Mike Gabriel-4
Hi,

On  Mo 26 Mär 2018 19:21:46 CEST, Sophoklis Goumas wrote:

> Package: xfce4-indicator-plugin
> Version: 2.3.3-1.1
> Followup-For: Bug #886949
>
> Mike, I applied the mentioned patch to the package but unfortunately
> the problem still remains, no improvements done. Did it resolve this for you?
>
> Sophoklis

maybe the issue is of a different source. See  
https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=891927

For Qt4 applications, try installing sni-qt. Also, I have heard about  
Python / gir1.2 related packages that fail, if they use the old  
gir1.2-appindicator package.

Can you please provide a more precise list of what works and what not?  
Could you possibly test other applications, that you don't use  
regularly?

Thanks!
Mike
--

DAS-NETZWERKTEAM
mike gabriel, herweg 7, 24357 fleckeby
mobile: +49 (1520) 1976 148
landline: +49 (4354) 8390 139

GnuPG Fingerprint: 9BFB AEE8 6C0A A5FF BF22  0782 9AF4 6B30 2577 1B31
mail: [hidden email], http://das-netzwerkteam.de


attachment0 (868 bytes) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Bug#886949: xfce4-indicator-plugin: Not all indicator icons are being shown. Please, help to debug.

Mike Gabriel-4
In reply to this post by Sophoklis Goumas-2
Hi once more,

On  Mo 26 Mär 2018 19:21:46 CEST, Sophoklis Goumas wrote:

> Package: xfce4-indicator-plugin
> Version: 2.3.3-1.1
> Followup-For: Bug #886949
>
> Mike, I applied the mentioned patch to the package but unfortunately
> the problem still remains, no improvements done. Did it resolve this for you?
>
> Sophoklis

for the new xfce4-indicator-applet implementation, make sure that  
indicator-application is not installed (or rather, does not start on  
XFCE session startup). Also check, that ayatana-indicator-application  
_is_ running after the session has come up.

Thanks,
Mike
--

DAS-NETZWERKTEAM
mike gabriel, herweg 7, 24357 fleckeby
mobile: +49 (1520) 1976 148
landline: +49 (4354) 8390 139

GnuPG Fingerprint: 9BFB AEE8 6C0A A5FF BF22  0782 9AF4 6B30 2577 1B31
mail: [hidden email], http://das-netzwerkteam.de


attachment0 (868 bytes) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Bug#886949: xfce4-indicator-plugin: Not all indicator icons are being shown (steam, qjoypad, caffeine, ...). Please, help to debug.

Dmitry Mikhirev
In reply to this post by Sophoklis Goumas-2
Package: xfce4-indicator-plugin
Version: 2.3.4-2
Followup-For: Bug #886949

Hi!

I faced the same issue after upgrade to buster from stretch. All Qt5 and some
GTK apps were affected (in particular, psi-plus, hp-systray, NUT-monitor, ario
and others). It has resolved after removal of ayatana-indicator-application. It
seems to be broken in buster (or, maybe, leaved misconfigured after upgrade).

Earlier I reported this issue against libqt5widgets5:
https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=927033

--
Regards,
        Dmitry Mikhirev



-- System Information:
Debian Release: buster/sid
  APT prefers testing-proposed-updates
  APT policy: (500, 'testing-proposed-updates'), (500, 'testing')
Architecture: amd64 (x86_64)
Foreign Architectures: i386

Kernel: Linux 4.19.0-4-amd64 (SMP w/2 CPU cores)
Kernel taint flags: TAINT_PROPRIETARY_MODULE, TAINT_OOT_MODULE, TAINT_UNSIGNED_MODULE
Locale: LANG=ru_RU.utf8, LC_CTYPE=ru_RU.utf8 (charmap=UTF-8), LANGUAGE=ru_RU.utf8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/dash
Init: systemd (via /run/systemd/system)

Versions of packages xfce4-indicator-plugin depends on:
ii  libatk1.0-0              2.30.0-2
ii  libayatana-ido3-0.4-0    0.4.4-1
ii  libayatana-indicator3-7  0.6.2-3
ii  libc6                    2.28-8
ii  libcairo-gobject2        1.16.0-4
ii  libcairo2                1.16.0-4
ii  libdbus-1-3              1.12.12-1
ii  libdbus-glib-1-2         0.110-4
ii  libgdk-pixbuf2.0-0       2.38.1+dfsg-1
ii  libglib2.0-0             2.58.3-1
ii  libgtk-3-0               3.24.5-1
ii  libpango-1.0-0           1.42.4-6
ii  libpangocairo-1.0-0      1.42.4-6
ii  libxfce4panel-2.0-4      4.12.2-1
ii  libxfce4ui-2-0           4.12.1-3
ii  libxfce4util7            4.12.1-3
ii  libxfconf-0-2            4.12.1-1

Versions of packages xfce4-indicator-plugin recommends:
pn  ayatana-indicator-application  <none>

xfce4-indicator-plugin suggests no packages.

-- no debconf information