Bug#903532: /opt/google/earth/pro/googleearth: crash when searching

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

Bug#903532: /opt/google/earth/pro/googleearth: crash when searching

gpe92
Package: google-earth-pro-stable
Version: 7.3.2.5487-r0
Severity: important
File: /opt/google/earth/pro/googleearth

Dear Maintainer,

   * What led up to the situation?

search a location

   * What exactly did you do (or not do) that was effective (or
     ineffective)?

enter a location in the search field and then validate

   * What was the outcome of this action?

google-earth-pro crashes

   * What outcome did you expect instead?

move to the location without crash

Here is the log:

Major Version 7
Minor Version 3
Build Number 0002
Build Date Jul 10 2018
Build Time 12:22:04
OS Type 3
OS Major Version 4
OS Minor Version 16
OS Build Version 0
OS Patch Version 0
Crash Signal 11
Crash Time 1531264308
Up Time 19,0199

Stacktrace from glibc:
/opt/google/earth/pro/libgoogleearth_pro.so(+0x1bdfed)[0x7f6c79c31fed]
/opt/google/earth/pro/libgoogleearth_pro.so(+0x1f32ac)[0x7f6c79c672ac]
/lib/x86_64-linux-gnu/libc.so.6(+0x34f00)[0x7f6c796eef00]
/usr/lib/x86_64-linux-gnu/libgdk-x11-2.0.so.0(gdk_display_open+0x5c)[0x7f6b8c18c88c]
/usr/lib/x86_64-linux-gnu/libgdk-x11-2.0.so.0(gdk_display_open_default_libgtk_only+0x52)[0x7f6b8c15bee2]
/usr/lib/x86_64-linux-gnu/libgdk-x11-2.0.so.0(gdk_init_check+0xe)[0x7f6b8c15bf5e]
/opt/google/earth/pro/libQt5WebKit.so.5(+0xa11981)[0x7f6c703f5981]
/opt/google/earth/pro/libQt5WebKit.so.5(+0x93f18b)[0x7f6c7032318b]
/opt/google/earth/pro/libQt5WebKit.so.5(+0x93f503)[0x7f6c70323503]
/opt/google/earth/pro/libQt5WebKit.so.5(+0x924676)[0x7f6c70308676]
/opt/google/earth/pro/libQt5WebKit.so.5(+0x1460fc4)[0x7f6c70e44fc4]
/opt/google/earth/pro/libQt5WebKit.so.5(+0x14c5ac6)[0x7f6c70ea9ac6]
/opt/google/earth/pro/libQt5WebKit.so.5(+0x14c5bc7)[0x7f6c70ea9bc7]
/opt/google/earth/pro/libQt5WebKit.so.5(+0x7f1685)[0x7f6c701d5685]
/opt/google/earth/pro/libQt5WebKit.so.5(+0x7f1a39)[0x7f6c701d5a39]
/opt/google/earth/pro/libQt5WebKit.so.5(+0x13048a8)[0x7f6c70ce88a8]
/opt/google/earth/pro/libQt5WebKit.so.5(+0x85e2d9)[0x7f6c702422d9]
/opt/google/earth/pro/libQt5WebKit.so.5(+0x862648)[0x7f6c70246648]
/opt/google/earth/pro/libQt5WebKit.so.5(+0x862913)[0x7f6c70246913]
/opt/google/earth/pro/libQt5WebKit.so.5(+0x865615)[0x7f6c70249615]
/opt/google/earth/pro/libQt5WebKit.so.5(+0x15f83d4)[0x7f6c70fdc3d4]
/opt/google/earth/pro/libQt5WebKit.so.5(+0x12d3e28)[0x7f6c70cb7e28]
/opt/google/earth/pro/libQt5WebKit.so.5(+0x12d7c13)[0x7f6c70cbbc13]
/opt/google/earth/pro/libQt5WebKit.so.5(+0x162769e)[0x7f6c7100b69e]
/opt/google/earth/pro/libQt5WebKit.so.5(+0x163386f)[0x7f6c7101786f]
/opt/google/earth/pro/libQt5WebKit.so.5(+0x163396e)[0x7f6c7101796e]
/opt/google/earth/pro/libQt5WebKit.so.5(+0xdc444b)[0x7f6c707a844b]
/opt/google/earth/pro/libQt5WebKit.so.5(+0x1629aa2)[0x7f6c7100daa2]
/opt/google/earth/pro/libQt5WebKit.so.5(+0x19063ec)[0x7f6c712ea3ec]
/opt/google/earth/pro/libQt5WebKit.so.5(+0x1910205)[0x7f6c712f4205]

Best regards.

-- System Information:
Debian Release: buster/sid
  APT prefers testing
  APT policy: (990, 'testing'), (500, 'unstable')
Architecture: amd64 (x86_64)
Foreign Architectures: i386

Kernel: Linux 4.16.0-2-amd64 (SMP w/4 CPU cores)
Locale: LANG=fr_FR.utf8, LC_CTYPE=fr_FR.utf8 (charmap=UTF-8), LANGUAGE=fr_FR.utf8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/dash
Init: systemd (via /run/systemd/system)
LSM: AppArmor: enabled

Versions of packages google-earth-pro-stable depends on:
ii  dpkg                            1.19.0.5+b1
ii  libasound2                      1.1.6-1
ii  libc6                           2.27-3
ii  libcups2                        2.2.8-4
ii  libdbus-1-3                     1.12.8-3
ii  libfontconfig1                  2.13.0-5
ii  libfreetype6                    2.8.1-2
ii  libgcc1                         1:8.1.0-9
ii  libglib2.0-0                    2.56.1-2
ii  libglu1-mesa                    9.0.0-2.1
ii  libgstreamer-plugins-base1.0-0  1.14.1-dmo1
ii  libgstreamer1.0-0               1.14.1-1
ii  libproxy1v5                     0.4.15-1
ii  libsm6                          2:1.2.2-1+b3
ii  libstdc++6                      8.1.0-9
ii  libx11-6                        2:1.6.5-1
ii  libx11-xcb1                     2:1.6.5-1
ii  libxcb1                         1.13-1
ii  libxext6                        2:1.3.3-1+b2
ii  libxml2                         2.9.4+dfsg1-7+b1
ii  libxrender1                     1:0.9.10-1
ii  libxtst6                        2:1.2.3-1

google-earth-pro-stable recommends no packages.

google-earth-pro-stable suggests no packages.

-- no debconf information