Bug#909195: openshot-qt crashes during export

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

Bug#909195: openshot-qt crashes during export

Joël Krähemann-2
Package: openshot-qt
Version: 2.4.2+dfsg1-1
Severity: normal

Dear Maintainer,

Openshot-qt crashes during export. I use a screencast captured with `ffmpeg` and webcam `guvcview`. Audio is provided by gsequencer-2.0.13 as signed 16 bit WAV PCM.

Thought I can export using:

https://github.com/OpenShot/openshot-qt/releases/download/daily/OpenShot-v2.4.2-dev1-1537088579-688c6b75-d0e70dd3-x86_64.AppImage

But can't tell about the result because it is still exporting. I could provide you the media files. I have provided a stack-trace as attachment.

Best regards,
Joël


*** Reporter, please consider answering these questions, where appropriate ***

   * What led up to the situation?
   * What exactly did you do (or not do) that was effective (or
     ineffective)?
   * What was the outcome of this action?
   * What outcome did you expect instead?

*** End of the template - remove these template lines ***


-- System Information:
Debian Release: buster/sid
  APT prefers unstable
  APT policy: (500, 'unstable')
Architecture: amd64 (x86_64)

Kernel: Linux 4.18.0-1-amd64 (SMP w/24 CPU cores)
Locale: LANG=C.UTF-8, LC_CTYPE=C.UTF-8 (charmap=UTF-8), LANGUAGE=C.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/dash
Init: systemd (via /run/systemd/system)
LSM: AppArmor: enabled

Versions of packages openshot-qt depends on:
ii  fonts-cantarell         0.111-2
ii  libjs-jquery            3.2.1-1
ii  python3                 3.6.6-1
ii  python3-openshot        0.2.0+dfsg1-1
ii  python3-pkg-resources   40.2.0-1
ii  python3-pyqt5           5.11.2+dfsg-1+b1
ii  python3-pyqt5.qtsvg     5.11.2+dfsg-1+b1
ii  python3-pyqt5.qtwebkit  5.11.2+dfsg-1+b1
ii  python3-requests        2.18.4-2
ii  python3-zmq             17.1.0-1

Versions of packages openshot-qt recommends:
ii  blender   2.79.b+dfsg0-4
ii  inkscape  0.92.3-3

Versions of packages openshot-qt suggests:
ii  openshot-qt-doc  2.4.2+dfsg1-1

-- no debconf information

openshot-stacktrace.txt (62K) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Bug#909195: openshot-qt crashes during export

Joël Krähemann-2
Hi,

The media files are available here:
http://krähemann.com/reportbug/openshot-qt/

Good luck,
Joël
On Wed, Sep 19, 2018 at 4:54 PM Joël Krähemann <[hidden email]> wrote:

>
> Package: openshot-qt
> Version: 2.4.2+dfsg1-1
> Severity: normal
>
> Dear Maintainer,
>
> Openshot-qt crashes during export. I use a screencast captured with `ffmpeg` and webcam `guvcview`. Audio is provided by gsequencer-2.0.13 as signed 16 bit WAV PCM.
>
> Thought I can export using:
>
> https://github.com/OpenShot/openshot-qt/releases/download/daily/OpenShot-v2.4.2-dev1-1537088579-688c6b75-d0e70dd3-x86_64.AppImage
>
> But can't tell about the result because it is still exporting. I could provide you the media files. I have provided a stack-trace as attachment.
>
> Best regards,
> Joël
>
>
> *** Reporter, please consider answering these questions, where appropriate ***
>
>    * What led up to the situation?
>    * What exactly did you do (or not do) that was effective (or
>      ineffective)?
>    * What was the outcome of this action?
>    * What outcome did you expect instead?
>
> *** End of the template - remove these template lines ***
>
>
> -- System Information:
> Debian Release: buster/sid
>   APT prefers unstable
>   APT policy: (500, 'unstable')
> Architecture: amd64 (x86_64)
>
> Kernel: Linux 4.18.0-1-amd64 (SMP w/24 CPU cores)
> Locale: LANG=C.UTF-8, LC_CTYPE=C.UTF-8 (charmap=UTF-8), LANGUAGE=C.UTF-8 (charmap=UTF-8)
> Shell: /bin/sh linked to /bin/dash
> Init: systemd (via /run/systemd/system)
> LSM: AppArmor: enabled
>
> Versions of packages openshot-qt depends on:
> ii  fonts-cantarell         0.111-2
> ii  libjs-jquery            3.2.1-1
> ii  python3                 3.6.6-1
> ii  python3-openshot        0.2.0+dfsg1-1
> ii  python3-pkg-resources   40.2.0-1
> ii  python3-pyqt5           5.11.2+dfsg-1+b1
> ii  python3-pyqt5.qtsvg     5.11.2+dfsg-1+b1
> ii  python3-pyqt5.qtwebkit  5.11.2+dfsg-1+b1
> ii  python3-requests        2.18.4-2
> ii  python3-zmq             17.1.0-1
>
> Versions of packages openshot-qt recommends:
> ii  blender   2.79.b+dfsg0-4
> ii  inkscape  0.92.3-3
>
> Versions of packages openshot-qt suggests:
> ii  openshot-qt-doc  2.4.2+dfsg1-1
>
> -- no debconf information