Bug#914153: Update to version 2.3.0-3 breaks Megaglest

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

Bug#914153: Update to version 2.3.0-3 breaks Megaglest

Frank Heckenbach-4
> I checked and everything looks all right, but I've been fighting for
> 1+ hours because it cannot generate the ftgl.pdf documentation.

Hmm, simply "./autogen.sh && ./configure && make -j" does build it
for me (though with some warnings), using stretch. Does that work
for you? If so, it must be something in the Debian rules; otherwise
it seems to be difference between stable and testing which may be
worth investigating as it may affect others too. What errors do you
get?

Cheers,
Frank

Reply | Threaded
Open this post in threaded view
|

Bug#914153: Update to version 2.3.0-3 breaks Megaglest

Manuel A. Fernandez Montecelo-2
Em sex, 8 de fev de 2019 às 02:09, Manuel A. Fernandez Montecelo
<[hidden email]> escreveu:

>
> Em sex, 8 de fev de 2019 às 01:35, Frank Heckenbach
> <[hidden email]> escreveu:
> >
> > > I checked and everything looks all right, but I've been fighting for
> > > 1+ hours because it cannot generate the ftgl.pdf documentation.
> >
> > Hmm, simply "./autogen.sh && ./configure && make -j" does build it
> > for me (though with some warnings), using stretch. Does that work
> > for you? If so, it must be something in the Debian rules; otherwise
> > it seems to be difference between stable and testing which may be
> > worth investigating as it may affect others too. What errors do you
> > get?
>
> The compilation doesn't exercise some options if you don't have all
> packages installed, like doxygen-gen.
>
> Most of the build is OK, but pdflatex chokes when genereting the .pdf.
> You can see the failure here:
>   http://debomatic-amd64.debian.net/distribution#unstable/ftgl/2.3.0-3/buildlog
>
> Note that the above is for the previous version, so it must have
> happened due to changes in other Debian packages.  The problem might
> be in the doc though, that now fails due to more strict tools that are
> not going to be changed -- not sure.
>
> In any case, I need to get the package built even if these tools fails
> in order to get it into buster.  Dropping the .pdf is the most
> straightforward option to achieve it at this point, unless we can find
> the real problem in the next hours, and I cannot look at it until the
> weekend...

OK, pushed that version.  If we get around to fix the problem and in
time to include it in Buster, great, if not it's a lesser problem I'd
say.

BTW I included a patch that I noticed, fixing a duplicated entry in
projects_using_ftgl.txt, please try to apply it.


Cheers.
--
Manuel A. Fernandez Montecelo <[hidden email]>

Reply | Threaded
Open this post in threaded view
|

Bug#914153: Update to version 2.3.0-3 breaks Megaglest

Frank Heckenbach-4
> > > Hmm, simply "./autogen.sh && ./configure && make -j" does build it
> > > for me (though with some warnings), using stretch. Does that work
> > > for you? If so, it must be something in the Debian rules; otherwise
> > > it seems to be difference between stable and testing which may be
> > > worth investigating as it may affect others too. What errors do you
> > > get?
> >
> > The compilation doesn't exercise some options if you don't have all
> > packages installed, like doxygen-gen.

Do you mean doxygen-doc? (I don't see any doxygen-gen.) I installed
this now (and had installed doxygen and doxygen-latex before) and it
still works for me.

> > Most of the build is OK, but pdflatex chokes when genereting the .pdf.
> > You can see the failure here:
> >   http://debomatic-amd64.debian.net/distribution#unstable/ftgl/2.3.0-3/buildlog
> >
> > Note that the above is for the previous version, so it must have
> > happened due to changes in other Debian packages.  The problem might
> > be in the doc though, that now fails due to more strict tools that are
> > not going to be changed -- not sure.

To narrow it down, does it work if you build it manually (see
above)?

> BTW I included a patch that I noticed, fixing a duplicated entry in
> projects_using_ftgl.txt, please try to apply it.

Done.

Cheers,
Frank