Bug#915337: rr: baseline violation on i386

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

Bug#915337: rr: baseline violation on i386

Adrian Bunk-3
Source: rr
Version: 5.2.0-2
Severity: serious

MMX and SSE are not part of the i386 baseline.

Reply | Threaded
Open this post in threaded view
|

Bug#915337: rr: baseline violation on i386

Stephen Kitt-3
Hi Adrian,

On Sun, 02 Dec 2018 23:01:23 +0200, Adrian Bunk <[hidden email]> wrote:
> MMX and SSE are not part of the i386 baseline.

From the package description:

 rr is incompatible with ptrace hardening, and currently only supports
 Intel CPUs with Nehalem or later microarchitectures.

All supported CPUs support MMX and SSE. The package is useful on i386, but I
can drop it if you think I shouldn’t ship it there.

Regards,

Stephen

attachment0 (849 bytes) Download Attachment