Bug#915354: RFA: sent -- simple plaintext presentation tool

classic Classic list List threaded Threaded
14 messages Options
Reply | Threaded
Open this post in threaded view
|

Bug#915354: RFA: sent -- simple plaintext presentation tool

Dmitry Bogatov-3

Package: wnpp
Severity: normal

I do not do many presentation lately, and would like someone to take
over `sent'. Package is rather small, uses recent debhelper and upstream
does not make frequent releases.

The package description is:
 sent does not need LaTeX, libreoffice or any other fancy file format,
 it uses plaintext files to describe the slides and can include images
 via farbfeld.  Every paragraph represents a slide in the
 presentation.
 .
 The presentation is displayed in a simple X11 window. The content of
 each slide is automatically scaled to fit the window and centered so
 you also don't have to worry about alignment. Instead you can really
 concentrate on the content.

Reply | Threaded
Open this post in threaded view
|

Bug#915354: RFA: sent -- simple plaintext presentation tool

Emmanuel Arias
Control: retitle -1 ITA:  sent -- simple plaintext presentation tool
Control: owner -1 [hidden email]

Hello Dmitry!,

I would like adopt this package.


Cheers!


--
Arias Emmanuel
Github/Gitlab; @eamanu
Debian: @eamanu-guest
Reply | Threaded
Open this post in threaded view
|

Bug#915354: ITA: sent -- simple plaintext presentation tool

Emmanuel Arias
In reply to this post by Dmitry Bogatov-3
Hi!

ping Dmitry :-)

I uploaded sent to mentors.d.o, but sent does not appear on m.d.o =(

And I need permissions on salsa.

Cheers!

--
Arias Emmanuel
Github/Gitlab; @eamanu
Debian: @eamanu-guest
Reply | Threaded
Open this post in threaded view
|

Bug#915354: ITA: sent -- simple plaintext presentation tool

Dmitry Bogatov-3

[2018-12-19 07:10] eamanu15 <[hidden email]>
> *ping Dmitry :-)*
>
> I uploaded *sent* to mentors.d.o, but *sent* does not appear on m.d.o =(

mentors.debian.net, you mean?

> And I need permissions on salsa.

I see. Could you please resolve issue with mentors? I'd like to sponsor
at least one upload before transfering ownership. It would help to have
repository, that is fast-forwardable from salsa:debian/sent.

Nothing personal, we just never worked together.

Reply | Threaded
Open this post in threaded view
|

Bug#915354: ITA: sent -- simple plaintext presentation tool

Emmanuel Arias
Hi Dmitry!

Sorry for the delay (holidays issues :-) )

I've just upload `sent` to mentors


Please, when you have time review it.

Thanks!
Regards!


El jue., 20 de dic. de 2018 a la(s) 15:03, Dmitry Bogatov ([hidden email]) escribió:

[2018-12-19 07:10] eamanu15 <[hidden email]>
> *ping Dmitry :-)*
>
> I uploaded *sent* to mentors.d.o, but *sent* does not appear on m.d.o =(

mentors.debian.net, you mean?

> And I need permissions on salsa.

I see. Could you please resolve issue with mentors? I'd like to sponsor
at least one upload before transfering ownership. It would help to have
repository, that is fast-forwardable from salsa:debian/sent.

Nothing personal, we just never worked together.


--
Arias Emmanuel
Github/Gitlab; @eamanu
Debian: @eamanu-guest
Reply | Threaded
Open this post in threaded view
|

Bug#915354: ITA: sent -- simple plaintext presentation tool

Dmitry Bogatov-3

[2018-12-24 02:48] eamanu15 <[hidden email]>
> Sorry for the delay (holidays issues :-) )
>
> I've just upload `sent` to mentors
>
> https://mentors.debian.net/package/sent
>
> Please, when you have time review it.

 * Since version 1-2 was rejected and I did not re-uploaded it, your
   version will become 1-2, not 1-3.

 * Why do you replace debhelper-compat with debhelper? It is step
   backward.

 * There must be newline after signature line in `debian/changelog'.

All-in-all, I see little improvement in your revision.

Probably, we could just leave things as-is, and make new revision when
need arise (bugs reported/new upstream version released).  I am sorry,
if it feels as wasted time.

Reply | Threaded
Open this post in threaded view
|

Bug#915354: ITA: sent -- simple plaintext presentation tool

Emmanuel Arias
Hi!

El mar., 25 de dic. de 2018 a la(s) 10:39, Dmitry Bogatov <[hidden email]> escribió:

[2018-12-24 02:48] eamanu15 <[hidden email]>
> Sorry for the delay (holidays issues :-) )
>
> I've just upload `sent` to mentors
>
> https://mentors.debian.net/package/sent
>
> Please, when you have time review it.

 * Since version 1-2 was rejected and I did not re-uploaded it, your 
   version will become 1-2, not 1-3.

okas!

 * Why do you replace debhelper-compat with debhelper? It is step
   backward.

To avoid this Litian warning: " Buildsystem: Package uses debhelper with an old compatibility level" I try to use debhelper-compat (>= 11) ont d/control, but I have error on packaging

 * There must be newline after signature line in `debian/changelog'.
Okas thanks! 

All-in-all, I see little improvement in your revision.

Probably, we could just leave things as-is, and make new revision when
need arise (bugs reported/new upstream version released). 

So, do you consider better waiting for a bug report or new upstream to upload this version with the "intent to adopt"?

What do you think about upload sent 1-2 to close #915354?
 
I am sorry, if it feels as wasted time.
No :-) I am learning and this reviews are  good for me.  

Regards!
Reply | Threaded
Open this post in threaded view
|

Bug#915354: ITA: sent -- simple plaintext presentation tool

Dmitry Bogatov-3

[2018-12-25 11:19] eamanu15 <[hidden email]>
> El mar., 25 de dic. de 2018 a la(s) 10:39, Dmitry Bogatov <
> [hidden email]> escribió:
> >  * Why do you replace debhelper-compat with debhelper? It is step
> >    backward.
> >
>
> To avoid this Litian warning: " Buildsystem: Package uses debhelper with an
> old compatibility level" I try to use debhelper-compat (>= 11) ont
> d/control, but I have error on packaging

Oh, it seems that mentors.debian.net (or lintian.debian.org?) have too
old version of lintian installed. Since generally DSA use stable
release, I am not sure, whether it could be fixed before release.

Remember, Lintian, even its last version, could be wrong.

> So, do you consider better waiting for a bug report or new upstream to
> upload this version with the "intent to adopt"?
>
> What do you think about upload sent 1-2 to close #915354?

I do not think it worth it. RFA is not end of world, it does not mean
danger of removal. You may wish to subscribe to package via PTS
(pts-subscribe(1)).

Reply | Threaded
Open this post in threaded view
|

Bug#915354: ITA: sent -- simple plaintext presentation tool

Emmanuel Arias
HI!

El jue., 27 de dic. de 2018 a la(s) 06:36, Dmitry Bogatov ([hidden email]) escribió:

[2018-12-25 11:19] eamanu15 <[hidden email]>
> El mar., 25 de dic. de 2018 a la(s) 10:39, Dmitry Bogatov <
> [hidden email]> escribió:
> >  * Why do you replace debhelper-compat with debhelper? It is step
> >    backward.
> >
>
> To avoid this Litian warning: " Buildsystem: Package uses debhelper with an
> old compatibility level" I try to use debhelper-compat (>= 11) ont
> d/control, but I have error on packaging

Oh, it seems that mentors.debian.net (or lintian.debian.org?) have too
old version of lintian installed. Since generally DSA use stable
release, I am not sure, whether it could be fixed before release.

Remember, Lintian, even its last version, could be wrong.

So, just with run lintian in my laptop will be ok, right?

> So, do you consider better waiting for a bug report or new upstream to
> upload this version with the "intent to adopt"?
>
> What do you think about upload sent 1-2 to close #915354?

I do not think it worth it. RFA is not end of world, it does not mean
danger of removal. You may wish to subscribe to package via PTS
(pts-subscribe(1)).

I understand. Great thanks!

So, we will wait for news!

Thanks for your help
Regards!

--
Arias Emmanuel
Github/Gitlab; @eamanu
Debian: @eamanu-guest
Reply | Threaded
Open this post in threaded view
|

Bug#915354: Bug#921482: RFS: note/1.3.26-3 +help

Emmanuel Arias
In reply to this post by Dmitry Bogatov-3
control: tags -1 +help

I add @bugs.d.o with the tag.



El sáb., 9 de feb. de 2019 a la(s) 13:36, Dmitry Bogatov ([hidden email]) escribió:

control: tags -1 +help

[2019-02-07 14:39] eamanu15 <[hidden email]>
> > >
> > > * Add me to Maintainer Field on d/control:
> > >   - For some reason that I ignore the Maintainer field
> > >   on d/control was not updated.
> >
> > Sorry, I do not understand this sentense. Mind to simplify explaination
> > what changed?
> >
> In the middle of my ITA, I have the "little" problem that
> the unstable version was different with the salsa. I contacted
> with the maintainer to push the last version on salsa, but I did not
> have response. So, I download the orig.tar.gz and debian.tz file.
> Then, and replace the files and
> I forgot change the Maintainer field d/control.
>
> Because of that I write: "For some reason that I ignore the Maintainer field
> on d/control was not updated."

Still do not understand. You either updated Maintainer field, in which
case you should write something like "Set myself as maintainer", maybe
with "(Closes: #O-Bug-Number)", or you did not. It is changelog.


you will see that I set myself as maintainer. The Version of note on salsa was: 1.3.22
But on unstable was 1.3.26

For this reason, I download the files from package.debian

I forgot set myself as maintainer. Was my foul.

For this reason In this new package version 1.3.26-3 I add me
on Maintainer field.

 

Added tag +help. Fellow developers, I need help reviewing this entry.

> > > * Delete NOTEDB folder and NOTEDB.pm because they are
> > >   not on upstream from ad6cb95 commit (Github).
> >
> > What is ad6cb95 commit? For person who do not follow upstream
> > development, this changelog entry brings more questions, then
> > explainations.
> >
>
> Ok I will write
> * Delete NOTEDB folder and NOTEDB.pm because they
>   are not necessary.
>
> What about it?

In this case I understand "what" is done, but still do not understand
"why". You package some specific release. What is the purpose of
backporting changes from upstream HEAD?

> No, but I want to have the package as close as possible to the upstream.

In general, we at Debian package releases, we do not follow upstream
development commit-after-commit.  Usually, we backport patches only to
fix some bug.

Ok I will delete that patch.

Thanks for the review.
Regards

 
--
        Note, that I send and fetch email in batch, once every 24 hours.
                 If matter is urgent, try https://t.me/kaction
                                                                             --


--
Arias Emmanuel
Github/Gitlab; @eamanu
Debian: @eamanu-guest
Reply | Threaded
Open this post in threaded view
|

Bug#915354: Bug#921482: RFS: note/1.3.26-3 +help

Dmitry Bogatov-3

[2019-02-11 22:00] eamanu15 <[hidden email]>

> If you look
> https://salsa.debian.org/eamanu-guest/note/commit/b2fbec0443dd078dfbcf05efab7729ee3b2e6e3e
> you will see that I set myself as maintainer. The Version of note on salsa
> was: 1.3.22
> But on unstable was 1.3.26
>
> For this reason, I download the files from package.debian
> the 1.3.26 and updated it on salsa:
> https://salsa.debian.org/eamanu-guest/note/commit/0bb88562fd7c3b2a2035bd0d0f5b919b4a24af15
>
> But, when I continue working on the package on
> https://salsa.debian.org/eamanu-guest/note/commit/5bc4330c7f174713549f4bf4e1839d669e637551
> I forgot set myself as maintainer. Was my foul.
>
> For this reason In this new package version 1.3.26-3 I add me
> on Maintainer field.

So I believe simple "Set myself as Maintainer" would do. Or am I missing
something again?
--
        Note, that I send and fetch email in batch, once every 24 hours.
                 If matter is urgent, try https://t.me/kaction
                                                                             --

Reply | Threaded
Open this post in threaded view
|

Bug#915354: Bug#921482: RFS: note/1.3.26-3 +help

Emmanuel Arias
Hi,


El vie., 15 de feb. de 2019 a la(s) 14:27, Dmitry Bogatov ([hidden email]) escribió:

[2019-02-11 22:00] eamanu15 <[hidden email]>
> If you look
> https://salsa.debian.org/eamanu-guest/note/commit/b2fbec0443dd078dfbcf05efab7729ee3b2e6e3e
> you will see that I set myself as maintainer. The Version of note on salsa
> was: 1.3.22
> But on unstable was 1.3.26
>
> For this reason, I download the files from package.debian
> the 1.3.26 and updated it on salsa:
> https://salsa.debian.org/eamanu-guest/note/commit/0bb88562fd7c3b2a2035bd0d0f5b919b4a24af15
>
> But, when I continue working on the package on
> https://salsa.debian.org/eamanu-guest/note/commit/5bc4330c7f174713549f4bf4e1839d669e637551
> I forgot set myself as maintainer. Was my foul.
>
> For this reason In this new package version 1.3.26-3 I add me
> on Maintainer field.

So I believe simple "Set myself as Maintainer" would do. Or am I missing
something again?

Nope, you are right. I will write that

Thanks
--
        Note, that I send and fetch email in batch, once every 24 hours.
                 If matter is urgent, try https://t.me/kaction
                                                                             --


--
Arias Emmanuel
Github/Gitlab; @eamanu
Debian: @eamanu-guest
Reply | Threaded
Open this post in threaded view
|

Bug#915354: Bug#921482: RFS: note/1.3.26-3 +help

Emmanuel Arias

El vie., 15 de feb. de 2019 a la(s) 15:06, eamanu15 ([hidden email]) escribió:
Hi,


El vie., 15 de feb. de 2019 a la(s) 14:27, Dmitry Bogatov ([hidden email]) escribió:

[2019-02-11 22:00] eamanu15 <[hidden email]>
> If you look
> https://salsa.debian.org/eamanu-guest/note/commit/b2fbec0443dd078dfbcf05efab7729ee3b2e6e3e
> you will see that I set myself as maintainer. The Version of note on salsa
> was: 1.3.22
> But on unstable was 1.3.26
>
> For this reason, I download the files from package.debian
> the 1.3.26 and updated it on salsa:
> https://salsa.debian.org/eamanu-guest/note/commit/0bb88562fd7c3b2a2035bd0d0f5b919b4a24af15
>
> But, when I continue working on the package on
> https://salsa.debian.org/eamanu-guest/note/commit/5bc4330c7f174713549f4bf4e1839d669e637551
> I forgot set myself as maintainer. Was my foul.
>
> For this reason In this new package version 1.3.26-3 I add me
> on Maintainer field.

So I believe simple "Set myself as Maintainer" would do. Or am I missing
something again?

Nope, you are right. I will write that

Thanks
--
        Note, that I send and fetch email in batch, once every 24 hours.
                 If matter is urgent, try https://t.me/kaction
                                                                             --


--
Arias Emmanuel
Github/Gitlab; @eamanu
Debian: @eamanu-guest


--
Arias Emmanuel
Github/Gitlab; @eamanu
Debian: @eamanu-guest
Reply | Threaded
Open this post in threaded view
|

Bug#915354: Bug#921482: RFS: note/1.3.26-3 +help

Dmitry Bogatov-3

[2019-02-15 23:21] eamanu15 <[hidden email]>
> I've just upload to m.d.n the update.
>
> https://mentors.debian.net/debian/pool/main/n/note/note_1.3.26-3.dsc

Let's see. Here is commented debdiff (difference between note=1.3.26-2
and proposed note=1.3.26-3)

> > diff -Nru note-1.3.26/debian/changelog note-1.3.26/debian/changelog
> > --- note-1.3.26/debian/changelog 2019-01-16 17:26:39.000000000 +0000
> > +++ note-1.3.26/debian/changelog 2019-01-30 01:31:36.000000000 +0000
> > @@ -1,3 +1,14 @@
> > +note (1.3.26-3) unstable; urgency=medium
> > +
> > +  * Set myself as Maintainer.

There is no change of `debian/control'. I do not fully understand what
happened in git, but there is no such change between source packages.

> > +  * Update fix-spelling.patch because is old.

Please, reword as "Refresh fix-spelling.patch". More conventional.

> > +  * Update d/watch file to download the upstream version
> > +    from CPAN repository.
> > +  * Adding on d/rules a sentence to delete README from
> > +    /usr/share/perl5/NOTEDB/

I am not language expert, but last entry seems overly complicated. What
about "Do not install README into /usr/share/perl5."?

If you disagree, we can call l10n-english@ for advice of language
experts.

> > +
> > + -- Emmanuel Arias <[hidden email]>  Wed, 30 Jan 2019 01:31:36 +0000
> > +
> >  note (1.3.26-2) unstable; urgency=medium
> >  
> >    * New Maintainer (Closes: 900663).
> > diff -Nru note-1.3.26/debian/patches/fix-spelling.patch note-1.3.26/debian/patches/fix-spelling.patch
> > --- note-1.3.26/debian/patches/fix-spelling.patch 2018-12-24 06:42:23.000000000 +0000
> > +++ note-1.3.26/debian/patches/fix-spelling.patch 2019-01-30 01:31:36.000000000 +0000
> > @@ -1,39 +1,36 @@
> > -Description: Fix spelling problems detected by Lintian.
> > -Author: Alexandre De Dommelin <[hidden email]>
> > -Forwarded: yes
> > -Last-Updated: 2017-08-16
> > ---- a/note.pod
> > -+++ b/note.pod
> > -@@ -316,7 +316,7 @@ You can achieve the same result by simpl
> > - You can create a new note by simply pressing B<N> or B<n>. You favorite
> > - editor will be started and you can enter your note text. If you are already
> > - under a topic then this new note will automatically go to this topic.
> > --note adds an aditional line to the top of the note with the topic. But
> > -+note adds an additional line to the top of the note with the topic. But
> > - you can of course specify your own topic.
> > -
> > - Note will tell you which number it has assigned to the newly created note.
> > -@@ -393,7 +393,7 @@ Quit note.
> > -
> > - You can also dump the contents of your note-database into a
> > - ASCII-textfile(I<-D>). You can use this file later to import it into
> > --your note-database(-I). This is usefull, if you want quickly trans-
> > -+your note-database(-I). This is useful, if you want quickly trans-
> > - fer your notes from one host to another (i.e. you could mail
> > - your note-dump form your office to home and import it there
> > - for further use).
> > -@@ -467,7 +467,7 @@ character. Here are the available things
> > - The text will be formatted using the actually note-color.
> > -
> > - The hidden formatting will use blue forground and blue background
> > --to hide a string from the terminal, which is usefull for passwords.
> > -+to hide a string from the terminal, which is useful for passwords.
> > -
> > - If you set "FormatText" to I<simple> then the formatting can be
> > - done this way instead:
> > ---- a/lib/NOTEDB/mysql.pm
> > -+++ b/lib/NOTEDB/mysql.pm
> > -@@ -382,7 +382,7 @@ NOTEDB::mysql - module lib for accessing
> > +Fix spelling on several filesIndex: note/lib/NOTEDB/README
> > +===================================================================
> > +Index: note/lib/NOTEDB/README
> > +===================================================================
> > +--- note.orig/lib/NOTEDB/README
> > ++++ note/lib/NOTEDB/README
> > +@@ -1,7 +1,7 @@
> > + perl modules for note used as database backends.
> > + the install.sh script will install both of them,
> > + although you may only need one backend. Perhaps
> > +-other users on your system have oter ideas in mind...
> > ++other users on your system have other ideas in mind...
> > +
> > + Therefore, please ignore these file. There is nothing
> > + to edit or to do. Simply leave this directory :-)
> > +Index: note/lib/NOTEDB/binary.pm
> > +===================================================================
> > +--- note.orig/lib/NOTEDB/binary.pm
> > ++++ note/lib/NOTEDB/binary.pm
> > +@@ -481,7 +481,7 @@ However, both versions provides identica
> > + not need to change your code, if you want to switch to another database format.
> > +
> > + Currently, NOTEDB module is only used by note itself. But feel free to use it
> > +-within your own project! Perhaps someone want to implement a webinterface to
> > ++within your own project! Perhaps someone want to implement a web interface to
> > + note...
> > +
> > + =head1 USAGE
> > +Index: note/lib/NOTEDB/dbm.pm
> > +===================================================================
> > +--- note.orig/lib/NOTEDB/dbm.pm
> > ++++ note/lib/NOTEDB/dbm.pm
> > +@@ -235,7 +235,7 @@ NOTEDB::dbm - module lib for accessing a
> >   # get the next noteid available
> >   $next_num = $db->get_nextnum();
> >  
> > @@ -42,9 +39,46 @@
> >   $db->set_recountnums();
> >  
> >   # modify a certain note
> > ---- a/lib/NOTEDB/dbm.pm
> > -+++ b/lib/NOTEDB/dbm.pm
> > -@@ -235,7 +235,7 @@ NOTEDB::dbm - module lib for accessing a
> > +@@ -253,7 +253,7 @@ You can use this module for accessing a
> > + It uses the DB_FILE module to store it's data and it uses DBM files for tis purpose.
> > +
> > + Currently, NOTEDB module is only used by note itself. But feel free to use it
> > +-within your own project! Perhaps someone want to implement a webinterface to
> > ++within your own project! Perhaps someone want to implement a web interface to
> > + note...
> > +
> > + =head1 USAGE
> > +Index: note/lib/NOTEDB/dumper.pm
> > +===================================================================
> > +--- note.orig/lib/NOTEDB/dumper.pm
> > ++++ note/lib/NOTEDB/dumper.pm
> > +@@ -356,7 +356,7 @@ You can use this module for accessing a
> > + a text file for storage and Storable for accessing the file.
> > +
> > + Currently, NOTEDB module is only used by note itself. But feel free to use it
> > +-within your own project! Perhaps someone want to implement a webinterface to
> > ++within your own project! Perhaps someone want to implement a web interface to
> > + note...
> > +
> > + =head1 USAGE
> > +Index: note/lib/NOTEDB/general.pm
> > +===================================================================
> > +--- note.orig/lib/NOTEDB/general.pm
> > ++++ note/lib/NOTEDB/general.pm
> > +@@ -397,7 +397,7 @@ You can use this module for accessing a
> > + a text file for storage and Config::General for accessing the file.
> > +
> > + Currently, NOTEDB module is only used by note itself. But feel free to use it
> > +-within your own project! Perhaps someone want to implement a webinterface to
> > ++within your own project! Perhaps someone want to implement a web interface to
> > + note...
> > +
> > + =head1 USAGE
> > +Index: note/lib/NOTEDB/mysql.pm
> > +===================================================================
> > +--- note.orig/lib/NOTEDB/mysql.pm
> > ++++ note/lib/NOTEDB/mysql.pm
> > +@@ -382,7 +382,7 @@ NOTEDB::mysql - module lib for accessing
> >   # get the next noteid available
> >   $next_num = $db->get_nextnum();
> >  
> > @@ -53,3 +87,87 @@
> >   $db->set_recountnums();
> >  
> >   # modify a certain note
> > +@@ -409,7 +409,7 @@ However, both versions provides identica
> > + not need to change your code, if you want to switch to another database format.
> > +
> > + Currently, NOTEDB module is only used by note itself. But feel free to use it
> > +-within your own project! Perhaps someone want to implement a webinterface to
> > ++within your own project! Perhaps someone want to implement a web interface to
> > + note...
> > +
> > + =head1 USAGE
> > +Index: note/lib/NOTEDB/pwsafe3.pm
> > +===================================================================
> > +--- note.orig/lib/NOTEDB/pwsafe3.pm
> > ++++ note/lib/NOTEDB/pwsafe3.pm
> > +@@ -595,7 +595,7 @@ You can use this module for accessing a
> > + a text file for storage and Config::General for accessing the file.
> > +
> > + Currently, NOTEDB module is only used by note itself. But feel free to use it
> > +-within your own project! Perhaps someone want to implement a webinterface to
> > ++within your own project! Perhaps someone want to implement a web interface to
> > + note...
> > +
> > + =head1 USAGE
> > +Index: note/lib/NOTEDB/text.pm
> > +===================================================================
> > +--- note.orig/lib/NOTEDB/text.pm
> > ++++ note/lib/NOTEDB/text.pm
> > +@@ -337,7 +337,7 @@ You can use this module for accessing a
> > + a text file for storage and Storable for accessing the file.
> > +
> > + Currently, NOTEDB module is only used by note itself. But feel free to use it
> > +-within your own project! Perhaps someone want to implement a webinterface to
> > ++within your own project! Perhaps someone want to implement a web interface to
> > + note...
> > +
> > + =head1 USAGE
> > +Index: note/note.pod
> > +===================================================================
> > +--- note.orig/note.pod
> > ++++ note/note.pod
> > +@@ -14,7 +14,7 @@ note [options] [ number [,number...]]
> > +
> > + B<note> is a small console program written in perl, which allows
> > + you to manage notes similar to programs like "knotes" but from
> > +-the commandline. Note can use different database-backends for
> > ++the command line. Note can use different database-backends for
> > + notes-storage. It ships with a DBI-based mysql-module(which
> > + can also be used for other by DBI supported DBMS), another
> > + module, which uses a binary file for storage and a DBM module.
> > +@@ -108,7 +108,7 @@ for details on this mode.
> > + =item I<--encrypt cleartext>
> > +
> > + Encrypt the given clear text string. You would need that if you want to
> > +-store the mysql password not in cleartext in the config(if you are using
> > ++store the mysql password not in cleartext in the config (if you are using
> > + the mysql backend!).
> > +
> > +
> > +@@ -140,7 +140,7 @@ note from STDIN until EOF. This makes it
> > + =head2 GENERAL USAGE
> > +
> > + If you don't know, how to run note, try "note -h" first.
> > +-It will tell you all available commandline options.
> > ++It will tell you all available command line options.
> > +
> > + To create a new note, simply run "note". You can enter
> > + the note (the length is by default limited to 4096 bytes,
> > +@@ -288,7 +288,7 @@ topic.  You will get strange results wit
> > +
> > + =head2 INTERACTIVE MODE
> > +
> > +-If you start note with the commandline flag B<-i>, then it starts
> > ++If you start note with the command line flag B<-i>, then it starts
> > + with an interactive interface.
> > + It will start with a listing under the default top-topic ("/").
> > + You can enter the name of a topic to change to that topic. This works
> > +@@ -507,7 +507,7 @@ You can use a configuration file with no
> > + Note will use default values if there is no config.
> > +
> > + The default config file is B<~/.noterc>. You may specify another
> > +-one with the commandline flag I<--config>.
> > ++one with the command line flag I<--config>.
> > +
> > + Comments start with #, empty lines will be ignored.
> > +
> > diff -Nru note-1.3.26/debian/.pc/.quilt_patches note-1.3.26/debian/.pc/.quilt_patches
> > --- note-1.3.26/debian/.pc/.quilt_patches 1970-01-01 00:00:00.000000000 +0000
> > +++ note-1.3.26/debian/.pc/.quilt_patches 2019-01-30 01:31:36.000000000 +0000
> > @@ -0,0 +1 @@
> > +patches
> > diff -Nru note-1.3.26/debian/.pc/.quilt_series note-1.3.26/debian/.pc/.quilt_series
> > --- note-1.3.26/debian/.pc/.quilt_series 1970-01-01 00:00:00.000000000 +0000
> > +++ note-1.3.26/debian/.pc/.quilt_series 2019-01-30 01:31:36.000000000 +0000
> > @@ -0,0 +1 @@
> > +series
> > diff -Nru note-1.3.26/debian/.pc/.version note-1.3.26/debian/.pc/.version
> > --- note-1.3.26/debian/.pc/.version 1970-01-01 00:00:00.000000000 +0000
> > +++ note-1.3.26/debian/.pc/.version 2019-01-30 01:31:36.000000000 +0000
> > @@ -0,0 +1 @@
> > +2
> > diff -Nru note-1.3.26/debian/rules note-1.3.26/debian/rules
> > --- note-1.3.26/debian/rules 2018-12-24 06:00:01.000000000 +0000
> > +++ note-1.3.26/debian/rules 2019-01-30 01:31:36.000000000 +0000
> > @@ -1,4 +1,10 @@
> >  #!/usr/bin/make -f
> >  
> > +export DH_VERBOSE=1
> > +
> >  %:
> >   dh $@
> > +

> > +override_dh_clean:
> > + dh_clean
> > + rm $(CURDIR)/lib/NOTEDB/README

No. Please override dh_auto_install, like

        override_dh_auto_install:
                dh_auto_install
                rm debian/note/path-to-this-displaced-README

While your solution would work, it is better avoid changing
upstream-provided files during build.

It is considered customary to install README together with modules in
Perl community? If not, maybe this issue could be discussed with
upstream?

> > diff -Nru note-1.3.26/debian/watch note-1.3.26/debian/watch
> > --- note-1.3.26/debian/watch 2018-12-24 06:00:01.000000000 +0000
> > +++ note-1.3.26/debian/watch 2019-01-30 01:31:36.000000000 +0000
> > @@ -1,2 +1,2 @@
> > -version=3
> > -http://www.daemon.de/idisk/Apps/note/note-((?!latest).*)\.tar\.gz
> > +version=4
> > +https://cpan.metacpan.org/authors/id/T/TL/TLINDEN/note-((?!latest).*)\.tar\.gz
--
        Note, that I send and fetch email in batch, once every 24 hours.
                 If matter is urgent, try https://t.me/kaction
                                                                             --