Bug#916145: closure-compiler: Not working with recent JS code

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

Bug#916145: closure-compiler: Not working with recent JS code

Adrian Bunk-3
On Sat, Apr 06, 2019 at 06:13:05PM +0200, Chris Hofstaedtler wrote:

> * Roland Gruber <[hidden email]> [190406 16:07]:
> > the current version is so old that it got incompatible with recent JS code.
> > E.g. jQuery 3.3.1 cannot be minified as the tool reports parsing errors.
> >
> > Please either update the tool or remove it from the archive. This is now
> > 5 years in unmaintained state.
>
> I've checked all r-deps of closure-compiler in Debian, and they all
> build -- datatables-extensions shows some errors in a prebuilt file,
> but it has done so for a long time, so probably not super relevant.
>
> While I agree that having a 5 year old JS compiler in Debian is not

Now over 6 years.

> a great situation, its also not threatening to the packages in
> Debian using it, so I'd suggest keeping it for now.

Packages that would require a non-prehistoric version of
closure-compiler are already blocked from entering Debian,
see #843951 and #727529 (since 2013!) as examples.

Any actual user installing closure-compiler will have a WTF experience
when discovering that the new Debian release ships a version that was
already outdated when the dinosaurs roamed the earth.

> Adrian: you raised the severity, care to lower it until buster is
> out (or say some words on why)?

IMHO the release team adding a buster-ignore tag would be the best way
forward here - this would still show up as RC bug for bullseye.

> Cheers,
> Chris (from the Salzburg BSP)

cu
Adrian

--

       "Is there not promise of rain?" Ling Tan asked suddenly out
        of the darkness. There had been need of rain for many days.
       "Only a promise," Lao Er said.
                                       Pearl S. Buck - Dragon Seed

Reply | Threaded
Open this post in threaded view
|

Bug#916145: closure-compiler: Not working with recent JS code

Ivo De Decker-3
Control: severity -1 important

Hi,

On Sun, Apr 07, 2019 at 11:16:53AM +0300, Adrian Bunk wrote:
> > Adrian: you raised the severity, care to lower it until buster is
> > out (or say some words on why)?
>
> IMHO the release team adding a buster-ignore tag would be the best way
> forward here - this would still show up as RC bug for bullseye.

No. Downgrading is the way forward.

If you want to update the package for bullseye, filing an RC bug is not the
way to do it. Joining the team and preparing a new package (after the freeze)
is.

Thanks,

Ivo

Reply | Threaded
Open this post in threaded view
|

Processed: Re: Bug#916145: closure-compiler: Not working with recent JS code

Debian Bug Tracking System
Processing control commands:

> severity -1 important
Bug #916145 [closure-compiler] closure-compiler: Not working with recent JS code
Severity set to 'important' from 'serious'

--
916145: https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=916145
Debian Bug Tracking System
Contact [hidden email] with problems