Bug#916448: bumblebee-nvidia: Non installable with nvidia-legacy-390xx-dkms

classic Classic list List threaded Threaded
4 messages Options
Reply | Threaded
Open this post in threaded view
|

Bug#916448: bumblebee-nvidia: Non installable with nvidia-legacy-390xx-dkms

=?UTF-8?Q? "Sebasti=C3=A1n?= Lacuesta"
Package: bumblebee-nvidia
Version: 3.2.1-17
Severity: important

Dear Maintainer,

I tried to install this bumblebee-nvidia together with nvidia-legacy-390xx-
dkms. I couldn't do so because of missing dependency. Can this dependence be
added?

Thanks



-- System Information:
Debian Release: buster/sid
  APT prefers testing
  APT policy: (700, 'testing'), (699, 'unstable'), (698, 'experimental')
Architecture: amd64 (x86_64)
Foreign Architectures: i386

Kernel: Linux 4.18.0-3-amd64 (SMP w/8 CPU cores)
Locale: LANG=es_UY.UTF-8, LC_CTYPE=es_UY.UTF-8 (charmap=UTF-8), LANGUAGE=es_UY:es (charmap=UTF-8)
Shell: /bin/sh linked to /bin/dash
Init: systemd (via /run/systemd/system)
LSM: AppArmor: enabled

Versions of packages bumblebee-nvidia depends on:
ii  bumblebee                                                          3.2.1-17
ii  glx-alternative-nvidia                                             0.8.8
pn  nvidia-driver | nvidia-legacy-340xx-driver | nvidia-legacy-304xx-  <none>

bumblebee-nvidia recommends no packages.

bumblebee-nvidia suggests no packages.

Reply | Threaded
Open this post in threaded view
|

Bug#916448: bumblebee-nvidia: Non installable with nvidia-legacy-390xx-dkms

Andreas Beckmann-4
Control: merge -1 916450
Control: tag -1 pending

On 2018-12-14 16:28, Sebastián Lacuesta Peña wrote:
> I tried to install this bumblebee-nvidia together with nvidia-legacy-390xx-
> dkms. I couldn't do so because of missing dependency. Can this dependence be
> added?

This should be fixed in git already ...

@bluca: Can you take care of the bumblebee stack (bumblebee, bbswitch,
primus) and check if something else needs to be done before uploading it
- a lot of metadata updates are already there, but I didn't look at
standards-version and debhelper-compat (= 11). lintian may know about
more things to do.


Andreas

Reply | Threaded
Open this post in threaded view
|

Bug#916448: bumblebee-nvidia: Non installable with nvidia-legacy-390xx-dkms

Luca Boccassi-3
On Fri, 2018-12-14 at 17:09 +0100, Andreas Beckmann wrote:

> Control: merge -1 916450
> Control: tag -1 pending
>
> On 2018-12-14 16:28, Sebastián Lacuesta Peña wrote:
> > I tried to install this bumblebee-nvidia together with nvidia-
> > legacy-390xx-
> > dkms. I couldn't do so because of missing dependency. Can this
> > dependence be
> > added?
>
> This should be fixed in git already ...
>
> @bluca: Can you take care of the bumblebee stack (bumblebee,
> bbswitch,
> primus) and check if something else needs to be done before uploading
> it
> - a lot of metadata updates are already there, but I didn't look at
> standards-version and debhelper-compat (= 11). lintian may know about
> more things to do.
>
>
> Andreas
Just tested and uploaded bumblebee before seeing this message :-)

I have not bumped debhelper compat, since the packaging is more or less
synced with the upstream PPA it would make it incompatible with Ubuntu
LTS versions - is it something we want for Buster?

--
Kind regards,
Luca Boccassi

signature.asc (499 bytes) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Bug#916448: bumblebee-nvidia: Non installable with nvidia-legacy-390xx-dkms

Luca Boccassi-3
On Fri, 14 Dec 2018 16:21:05 +0000 Luca Boccassi <[hidden email]>
wrote:

> On Fri, 2018-12-14 at 17:09 +0100, Andreas Beckmann wrote:
> > Control: merge -1 916450
> > Control: tag -1 pending
> > 
> > On 2018-12-14 16:28, Sebastián Lacuesta Peña wrote:
> > > I tried to install this bumblebee-nvidia together with nvidia-
> > > legacy-390xx-
> > > dkms. I couldn't do so because of missing dependency. Can this
> > > dependence be
> > > added?
> > 
> > This should be fixed in git already ...
> > 
> > @bluca: Can you take care of the bumblebee stack (bumblebee,
> > bbswitch,
> > primus) and check if something else needs to be done before
uploading
> > it
> > - a lot of metadata updates are already there, but I didn't look at
> > standards-version and debhelper-compat (= 11). lintian may know
about
> > more things to do.
> > 
> > 
> > Andreas

> Just tested and uploaded bumblebee before seeing this message :-)

> I have not bumped debhelper compat, since the packaging is more or
less
> synced with the upstream PPA it would make it incompatible with
Ubuntu
> LTS versions - is it something we want for Buster?

It's already diverged a bit, so I've done the bump to compat 11 for
bumblebee in the last upload.

--
Kind regards,
Luca Boccassi

signature.asc (499 bytes) Download Attachment