Bug#916977: snoopy w/ ld preload enabled breaks "apt upgrade" jessie-to-buster

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

Bug#916977: snoopy w/ ld preload enabled breaks "apt upgrade" jessie-to-buster

Marcos Fouces-2
Hello,

I use testing and updated hundreds of package without any trouble.

Please, could you give an example of a package that fails to upgrade?

Greetings,

Marcos.

On 11/1/19 18:52, Adrian Bunk wrote:

> On Thu, Dec 20, 2018 at 05:26:25PM -0500, [hidden email] wrote:
>> Package: snoopy
>> Version: 2.4.6-4
>> Severity: critical
>> Justification: breaks unrelated software
>>
>> Dear Maintainer,
>>
>> With snoopy installed and enabled on jessie, apt upgrade to buster will break the upgrade process, as the snoopy library goes missing while the ld preload setting persists.  This causes every command invocation to trigger an error message concerning the missing library.  
>> ...
> Hw did you upgrade from jessie to buster?
>
> Skipping a release when upgrading is not supported,
> only jessie -> stretch -> buster is supported.
>
> cu
> Adrian
>