Bug#918578: maybe something to try

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

Bug#918578: maybe something to try

Wolfgang Schweer-3
On Wed, Feb 27, 2019 at 11:45:23AM +0000, Holger Levsen wrote:
> <h01ger> | sunweaver: but if you have some spare cycles, maybe you could look into #918578 ;)
> -  zwiebelbot- | (#debian-release) Debian#918578: gosa: GOsa web interface missing password field - https://bugs.debian.org/918578
> <sunweaver> I have the gosa bug on my radar, but no idea, yet.
> <sunweaver> I have seen it once, when I test-installed unstable's smarty3 on a stretch Debian Edu TJENER.
> <sunweaver> so, it might be unrelated to gosa, in fact.

It is unrelated to gosa (and to smarty3, too).
Actually, it's the changed PHP 7.3 cgi configuration. This bug's log
should contain enough information about it, see:

https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=918578#51

Also, https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=918578#56

contains a link to the buster manual's upgrade chapter with more
information what needs to be fixed if upgrading from stretch.

> maybe someone could try to reproduce this: on stretch, install smarty3
> from sid and see if this bug pops up.

smarty3 Depends: php | php-cgi | php-cli, php-common

So PHP7.3 is pulled in, triggering the bug, I figure.

Maybe gosa's postinst could contain code to fix the cgi configuration.
Also, gosa supports lighttpd. Upgrading in this case should be tested as
well.

Wolfgang

signature.asc (981 bytes) Download Attachment