Bug#918752: bbswitch-source fails to build with m-a due to undefined dh compat

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

Bug#918752: bbswitch-source fails to build with m-a due to undefined dh compat

David Kalnischkies-4
Package: bbswitch-source
Version: 0.8-6
Severity: important

Hi,

with the switch to debhelper compat level 11 the debian/compat file was
removed in favor of using debhelper-compat (= 11) in the control file.

This breaks building with module-assistent as the debian/control.modules.in
file wasn't changed as well and so debhelper has no idea in which compat
mode it should be running and hence bails out failing the build.

Would be nice if you could adapt that file to say:
Build-Depends: debhelper-compat (= 9)

Changing the other fields like Vcs-*, Priority and co is probably in
order, too, but I don't want to ask for too much given that I might be
the only user…
I can do a proper patch/MR on salsa if that is preferred, it just felt
like overkill for the time being [in my timezone at least]. :)


Best regards

David Kalnischkies

signature.asc (849 bytes) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Bug#918752: bbswitch-source fails to build with m-a due to undefined dh compat

Luca Boccassi-3
On Wed, 9 Jan 2019 02:41:21 +0100 David Kalnischkies <david@kalnischkie
s.de> wrote:
> Package: bbswitch-source
> Version: 0.8-6
> Severity: important

> Hi,

> with the switch to debhelper compat level 11 the debian/compat file
was
> removed in favor of using debhelper-compat (= 11) in the control
file.

> This breaks building with module-assistent as the
debian/control.modules.in
> file wasn't changed as well and so debhelper has no idea in which
compat
> mode it should be running and hence bails out failing the build.

> Would be nice if you could adapt that file to say:
> Build-Depends: debhelper-compat (= 9)

> Changing the other fields like Vcs-*, Priority and co is probably in
> order, too, but I don't want to ask for too much given that I might
be
> the only user…
> I can do a proper patch/MR on salsa if that is preferred, it just
felt
> like overkill for the time being [in my timezone at least]. :)


> Best regards

> David Kalnischkies

Hi,

Sorry, my bad, forgot to update the module control file! I've just
uploaded -7 with a fix, and this time I ran module-assistant and it
seemed to work fine. Please let me know if there are more issues.

--
Kind regards,
Luca Boccassi

signature.asc (499 bytes) Download Attachment